aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'autodep_overlay/app-portage/autodep/autodep-0.1.ebuild')
-rw-r--r--autodep_overlay/app-portage/autodep/autodep-0.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/autodep_overlay/app-portage/autodep/autodep-0.1.ebuild b/autodep_overlay/app-portage/autodep/autodep-0.1.ebuild
new file mode 100644
index 0000000..bdbf659
--- /dev/null
+++ b/autodep_overlay/app-portage/autodep/autodep-0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+PYTHON_DEPEND="2:2.6"
+RESTRICT_PYTHON_ABIS='2.4 2.5 3.*'
+
+inherit python
+
+DESCRIPTION="Auto dependency analyser for Gentoo"
+HOMEPAGE="http://alexbers.dyndns.org/autodep/"
+SRC_URI="http://alexbers.dyndns.org/autodep/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="sys-fs/fuse
+ dev-util/pkgconfig"
+RDEPEND="sys-fs/fuse
+ app-portage/portage-utils"
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}