aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndré Erdmann <dywi@mailerd.de>2014-04-03 21:37:43 +0200
committerAndré Erdmann <dywi@mailerd.de>2014-04-03 21:37:43 +0200
commit92616609309a3e5775463e880438a3e8ef2a5ddc (patch)
tree3292da7f4655360223f714efa2905bf2884918da /roverlay-9999.ebuild
parentMakefile: DIST_{TAR,BZIP2,GZIP,XZ} (diff)
downloadR_overlay-92616609309a3e5775463e880438a3e8ef2a5ddc.tar.gz
R_overlay-92616609309a3e5775463e880438a3e8ef2a5ddc.tar.bz2
R_overlay-92616609309a3e5775463e880438a3e8ef2a5ddc.zip
update roverlay-9999.ebuild
* fix python deps * create "roverlay" group during pkg_preinst() * compress config during src_compile() * adopt Makefile changes
Diffstat (limited to 'roverlay-9999.ebuild')
-rw-r--r--roverlay-9999.ebuild25
1 files changed, 9 insertions, 16 deletions
diff --git a/roverlay-9999.ebuild b/roverlay-9999.ebuild
index abe6b6a..290bd51 100644
--- a/roverlay-9999.ebuild
+++ b/roverlay-9999.ebuild
@@ -25,42 +25,35 @@ KEYWORDS=""
IUSE="compress-config xz +prebuilt-documentation"
DEPEND="
- dev-python/setuptools
+ dev-python/setuptools[${PYTHON_USEDEP}]
!prebuilt-documentation? ( >=dev-python/docutils-0.9 )
compress-config? ( app-arch/bzip2 )"
RDEPEND="
sys-apps/portage
- virtual/python-argparse
+ virtual/python-argparse[${PYTHON_USEDEP}]
dev-python/mako[${PYTHON_USEDEP}]
- xz? ( $(python_gen_cond_dep dev-python/backports-lzma[${PYTHON_USEDEP}] python{2_7,3_2}) )
+ xz? ( $(python_gen_cond_dep dev-python/backports-lzma[$(python_gen_usedep python{2_7,3_2})] python{2_7,3_2} ) )
virtual/python-futures[${PYTHON_USEDEP}]"
-pkg_setup() {
+pkg_preinst() {
enewgroup roverlay
}
-python_prepare_all() {
- distutils-r1_python_prepare_all
+python_compile_all() {
+ use prebuilt-documentation || emake htmldoc
if use compress-config; then
einfo "Compressing dependency rules and license map"
emake X_COMPRESS=bzip2 BUILDDIR="${S}/compressed" compress-config
fi
}
-python_compile_all() {
- use prebuilt-documentation || emake htmldoc
-}
-
python_install_all() {
distutils-r1_python_install_all
emake BUILDDIR="${S}/compressed" DESTDIR="${D}" \
- install-data $(usex compress-config install-config{-compressed,})
-
- # could be done in the Makefile as well
- dobin "${S}/bin/install/${PN}-setup-interactive"
-
- newbashcomp "${S}/files/misc/${PN}.bashcomp" "${PN}"
+ BASHCOMPDIR="${D}/$(get_bashcompdir)" \
+ COMPRESSED_CONFIG="$(usex compress-config 1 0)" \
+ install-nonpy
}
pkg_config() {