aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndré Erdmann <dywi@mailerd.de>2012-08-10 17:12:37 +0200
committerAndré Erdmann <dywi@mailerd.de>2012-08-10 17:12:37 +0200
commitfe22bec5472fb8230bfc84d9b4ca3acdd05f4ada (patch)
tree7bbb846cc9a483b9e1591005f45943a598db5616 /Makefile
parentusage guide as html doc (diff)
downloadR_overlay-fe22bec5472fb8230bfc84d9b4ca3acdd05f4ada.tar.gz
R_overlay-fe22bec5472fb8230bfc84d9b4ca3acdd05f4ada.tar.bz2
R_overlay-fe22bec5472fb8230bfc84d9b4ca3acdd05f4ada.zip
Makefile: html target
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index cf7f9c4..4a1452b 100644
--- a/Makefile
+++ b/Makefile
@@ -28,7 +28,7 @@ SELFDOC := $(DOCDIR)/pydoc
default \
clean-log clean distclean _pyclean _pydoc_clean \
run-test run-sync test \
- pydoc $(SELFDOC) $(DOCDIR) doc \
+ pydoc $(SELFDOC) docs htmldoc html \
pyver \
install install-all \
install-roverlay install-pymodules \
@@ -57,8 +57,13 @@ _pydoc_clean:
distclean: clean _pyclean _pydoc_clean
# generates docs in $(DOCDIR)/
-$(DOCDIR): $(SELFDOC)
-docs: $(DOCDIR)
+$(DOCDIR):
+ @mkdir $(DOCDIR)
+
+$(DOCDIR)/html: $(DOCDIR)
+ @mkdir $(DOCDIR)/html
+
+docs: $(SELFDOC) htmldoc
$(SELFDOC)/roverlay:
test -d $(SELFDOC) || mkdir -p $(SELFDOC)
@@ -71,6 +76,11 @@ $(SELFDOC): $(SELFDOC)/roverlay
# alias to $(SELFDOC)
pydoc: $(SELFDOC)
+html: $(DOCDIR)/html $(DOCDIR)/rst/usage.rst
+ rst2html.py $(DOCDIR)/rst/usage.rst $(DOCDIR)/html/usage.html
+
+htmldoc: html
+
# sync all repos
run-sync: $(ROVERLAY_MAIN)
$(PYTHON) $(ROVERLAY_MAIN) sync