aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYu Watanabe <watanabe.yu+github@gmail.com>2018-10-21 18:35:46 +0900
committerYu Watanabe <watanabe.yu+github@gmail.com>2018-10-21 22:34:28 +0900
commit80df8f2518aa07ef3c328e1c634573347e130cf0 (patch)
tree76abdf1b63497c9406d1ba813052ecae0e359990 /meson.build
parentMerge pull request #9437 from poettering/sd-boot-count (diff)
downloadsystemd-80df8f2518aa07ef3c328e1c634573347e130cf0.tar.gz
systemd-80df8f2518aa07ef3c328e1c634573347e130cf0.tar.bz2
systemd-80df8f2518aa07ef3c328e1c634573347e130cf0.zip
missing: support old linux/fou.h
linux/fou.h was introduced in 3.18. FOU_ATTR_REMCSUM_NOPARTIAL was added in 4.0. FOU_CMD_GET was added in 4.1. Follow-up for 53cb501a1314740fa777f145067cefccda954487. Fixes #10474.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 7960e9789..3b0102156 100644
--- a/meson.build
+++ b/meson.build
@@ -476,7 +476,6 @@ foreach decl : [['IFLA_INET6_ADDR_GEN_MODE', 'linux/if_link.h'],
['VXCAN_INFO_PEER', 'linux/can/vxcan.h'],
['FOU_ATTR_REMCSUM_NOPARTIAL', 'linux/fou.h'],
['FOU_CMD_GET', 'linux/fou.h'],
- ['FOU_ENCAP_GUE', 'linux/fou.h'],
]
prefix = decl.length() > 2 ? decl[2] : ''
have = cc.has_header_symbol(decl[1], decl[0], prefix : prefix)
@@ -608,6 +607,7 @@ if not cc.has_header('sys/capability.h')
endif
foreach header : ['crypt.h',
'linux/btrfs.h',
+ 'linux/fou.h',
'linux/memfd.h',
'linux/vm_sockets.h',
'sys/auxv.h',