aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-11-23 13:23:42 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-12-06 10:18:35 +0100
commite783f957181324110d2ee49377c48acc90d735a2 (patch)
treee4aa3502615da4f886bef0c9c212ca5fea9a8a44
parentutil-lib: kill duplicate slashes in lookup paths (diff)
downloadsystemd-e783f957181324110d2ee49377c48acc90d735a2.tar.gz
systemd-e783f957181324110d2ee49377c48acc90d735a2.tar.bz2
systemd-e783f957181324110d2ee49377c48acc90d735a2.zip
Rename "system-preset" source dir to "presets"
I want to add presets/user/ later. This mirrors the layout for units: we have units/ and units/user. The advantage is that we avoid having yet another directory at the top level.
-rw-r--r--meson.build3
-rw-r--r--presets/90-systemd.preset (renamed from system-preset/90-systemd.preset)0
-rw-r--r--presets/meson.build19
3 files changed, 20 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 6288b5697..4f63bffe9 100644
--- a/meson.build
+++ b/meson.build
@@ -2383,6 +2383,7 @@ subdir('units')
subdir('sysctl.d')
subdir('sysusers.d')
subdir('tmpfiles.d')
+subdir('presets')
subdir('hwdb')
subdir('network')
subdir('man')
@@ -2399,8 +2400,6 @@ install_subdir('factory/etc',
install_data('xorg/50-systemd-user.sh',
install_dir : xinitrcdir)
-install_data('system-preset/90-systemd.preset',
- install_dir : systempresetdir)
install_data('modprobe.d/systemd.conf',
install_dir : modprobedir)
install_data('README',
diff --git a/system-preset/90-systemd.preset b/presets/90-systemd.preset
index 11960e542..11960e542 100644
--- a/system-preset/90-systemd.preset
+++ b/presets/90-systemd.preset
diff --git a/presets/meson.build b/presets/meson.build
new file mode 100644
index 000000000..89bed8a05
--- /dev/null
+++ b/presets/meson.build
@@ -0,0 +1,19 @@
+# SPDX-License-Identifier: LGPL-2.1+
+#
+# Copyright 2017 Zbigniew Jędrzejewski-Szmek
+#
+# systemd is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2.1 of the License, or
+# (at your option) any later version.
+#
+# systemd is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with systemd; If not, see <http://www.gnu.org/licenses/>.
+
+install_data('90-systemd.preset',
+ install_dir : systempresetdir)