aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2018-12-20 08:59:18 -0600
committerYu Watanabe <watanabe.yu+github@gmail.com>2018-12-22 17:21:13 +0900
commit8eab766804ef4fa21d26c00fd0baab3f1a47bb5c (patch)
tree1c305649abe3842060577d91fa1106bdd8698909
parentNEWS: add one more name and adjust location (diff)
downloadsystemd-8eab766804ef4fa21d26c00fd0baab3f1a47bb5c.tar.gz
systemd-8eab766804ef4fa21d26c00fd0baab3f1a47bb5c.tar.bz2
systemd-8eab766804ef4fa21d26c00fd0baab3f1a47bb5c.zip
core: support %j in unit dependency resolution
Commit 250e9fadbcc0ca90e697d7efb40855b054ed3b8f introduced support for %j/%J specifier in unit files. The function unit_name_printf is used in unit dependency resolution, such as Wants / After directives, but was missing support for the %j. Add to allow directives such as: [Unit] Wants=bar-%j.target Fixes: systemd/systemd#11217 Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
-rw-r--r--src/core/unit-printf.c1
-rw-r--r--test/TEST-28-PERCENTJ-WANTEDBY/Makefile9
-rwxr-xr-xtest/TEST-28-PERCENTJ-WANTEDBY/test.sh68
3 files changed, 78 insertions, 0 deletions
diff --git a/src/core/unit-printf.c b/src/core/unit-printf.c
index a8e84ebe8..72391ace3 100644
--- a/src/core/unit-printf.c
+++ b/src/core/unit-printf.c
@@ -195,6 +195,7 @@ int unit_name_printf(Unit *u, const char* format, char **ret) {
{ 'N', specifier_prefix_and_instance, NULL },
{ 'p', specifier_prefix, NULL },
{ 'i', specifier_string, u->instance },
+ { 'j', specifier_last_component, NULL },
{ 'g', specifier_group_name, NULL },
{ 'G', specifier_group_id, NULL },
diff --git a/test/TEST-28-PERCENTJ-WANTEDBY/Makefile b/test/TEST-28-PERCENTJ-WANTEDBY/Makefile
new file mode 100644
index 000000000..45e9bfc67
--- /dev/null
+++ b/test/TEST-28-PERCENTJ-WANTEDBY/Makefile
@@ -0,0 +1,9 @@
+BUILD_DIR=$(shell ../../tools/find-build-dir.sh)
+
+all setup run:
+ @basedir=../.. TEST_BASE_DIR=../ BUILD_DIR=$(BUILD_DIR) ./test.sh --$@
+
+clean clean-again:
+ @basedir=../.. TEST_BASE_DIR=../ BUILD_DIR=$(BUILD_DIR) ./test.sh --clean
+
+.PHONY: all setup run clean clean-again
diff --git a/test/TEST-28-PERCENTJ-WANTEDBY/test.sh b/test/TEST-28-PERCENTJ-WANTEDBY/test.sh
new file mode 100755
index 000000000..68935d0da
--- /dev/null
+++ b/test/TEST-28-PERCENTJ-WANTEDBY/test.sh
@@ -0,0 +1,68 @@
+#!/bin/bash
+# -*- mode: shell-script; indent-tabs-mode: nil; sh-basic-offset: 4; -*-
+# ex: ts=8 sw=4 sts=4 et filetype=sh
+set -e
+TEST_DESCRIPTION="Ensure %j Wants directives work"
+RUN_IN_UNPRIVILEGED_CONTAINER=yes
+
+. $TEST_BASE_DIR/test-functions
+
+test_setup() {
+ create_empty_image
+ mkdir -p $TESTDIR/root
+ mount ${LOOPDEV}p1 $TESTDIR/root
+
+ # Create what will eventually be our root filesystem onto an overlay
+ (
+ LOG_LEVEL=5
+ eval $(udevadm info --export --query=env --name=${LOOPDEV}p2)
+
+ setup_basic_environment
+
+ # Set up the services.
+ cat >$initdir/etc/systemd/system/specifier-j-wants.service << EOF
+[Unit]
+Description=Wants with percent-j specifier
+Wants=specifier-j-depends-%j.service
+After=specifier-j-depends-%j.service
+
+[Service]
+Type=oneshot
+ExecStart=test -f /tmp/test-specifier-j-%j
+ExecStart=/bin/sh -c 'echo OK > /testok'
+EOF
+ cat >$initdir/etc/systemd/system/specifier-j-depends-wants.service << EOF
+[Unit]
+Description=Dependent service for percent-j specifier
+
+[Service]
+Type=oneshot
+ExecStart=touch /tmp/test-specifier-j-wants
+EOF
+ cat >$initdir/etc/systemd/system/testsuite.service << EOF
+[Unit]
+Description=Testsuite: Ensure %j Wants directives work
+Wants=specifier-j-wants.service
+After=specifier-j-wants.service
+
+[Service]
+Type=oneshot
+ExecStart=/bin/true
+EOF
+
+ setup_testsuite
+ ) || return 1
+ setup_nspawn_root
+
+ # mask some services that we do not want to run in these tests
+ ln -s /dev/null $initdir/etc/systemd/system/systemd-hwdb-update.service
+ ln -s /dev/null $initdir/etc/systemd/system/systemd-journal-catalog-update.service
+ ln -s /dev/null $initdir/etc/systemd/system/systemd-networkd.service
+ ln -s /dev/null $initdir/etc/systemd/system/systemd-networkd.socket
+ ln -s /dev/null $initdir/etc/systemd/system/systemd-resolved.service
+
+ ddebug "umount $TESTDIR/root"
+ umount $TESTDIR/root
+}
+
+do_test "$@"