aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2014-03-07 03:31:41 +0000
committerJoseph Myers <joseph@codesourcery.com>2014-03-07 03:31:41 +0000
commit6f99f280b00a30b8f0a89a4be1adb2bea41e2954 (patch)
treecac5f1b73b1b255e39bdbf617e499c637c1691f6 /timezone
parentMake tests consistently use *.out output files. (diff)
downloadglibc-6f99f280b00a30b8f0a89a4be1adb2bea41e2954.tar.gz
glibc-6f99f280b00a30b8f0a89a4be1adb2bea41e2954.tar.bz2
glibc-6f99f280b00a30b8f0a89a4be1adb2bea41e2954.zip
Count miscellaneous files built on host for testing as tests.
In <https://sourceware.org/ml/libc-alpha/2014-01/msg00198.html> I raised the question of counting miscellaneous dependencies of tests, built on the host rather than the build system, as tests, so that when test failures don't stop "make check" neither do those other builds on the host, so that a flaky host doesn't stop "make check" from producing a complete summary of test results. Brooks supported that idea in <https://sourceware.org/ml/libc-alpha/2014-02/msg00301.html>. This patch implements that change for all the examples I could find: one message catalog in catgets/, locales in localedata/ and timezone files in timezone/. Tested x86_64. * catgets/Makefile (tests-special): Add $(objpfx)sample.SJIS.cat. ($(objpfx)sample.SJIS.cat): Use $(evaluate-test). * timezone/Makefile (testdata): Move definition above include of Rules. (test-zones): New variable. (tests-special): Add zone files. (build-testdata): Use $(evaluate-test). localedata/ChangeLog: * Makefile (LOCALES): Move definition above include of Rules. (LOCALE_SRCS): Likewise. (CHARMAPS): Likewise. (CTYPE_FILES): Likewise. (tests-special): Add locale files. ($(addprefix $(objpfx),$(CTYPE_FILES))): Use $(evaluate-test).
Diffstat (limited to 'timezone')
-rw-r--r--timezone/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/timezone/Makefile b/timezone/Makefile
index e308cca3ff..998cd14dff 100644
--- a/timezone/Makefile
+++ b/timezone/Makefile
@@ -45,6 +45,14 @@ CPPFLAGS-zic = -DNOT_IN_libc
install-bin-script = tzselect
generated += tzselect
+testdata = $(objpfx)testdata
+
+# List zones generated by separate commands running zic on the host.
+# Each such zic run counts as a separate test.
+test-zones := America/New_York Etc/UTC UTC Europe/Berlin \
+ Australia/Melbourne America/Sao_Paulo Asia/Tokyo
+tests-special += $(addprefix $(testdata)/, $(test-zones))
+
include ../Rules
@@ -71,10 +79,10 @@ CFLAGS-scheck.c = -Wno-strict-prototypes -DNOID -DHAVE_GETTEXT
# We have to make sure the data for testing the tz functions is available.
# Don't add leapseconds here since test-tz made checks that work only without
# leapseconds.
-testdata = $(objpfx)testdata
define build-testdata
GCONV_PATH=${common-objpfx}iconvdata LANGUAGE=C LC_ALL=C \
- $(built-program-cmd) -d $(testdata) -y ./yearistype $<
+ $(built-program-cmd) -d $(testdata) -y ./yearistype $<; \
+$(evaluate-test)
endef
$(objpfx)test-tz.out: $(addprefix $(testdata)/, America/New_York Etc/UTC UTC)