diff options
author | Florian Weimer <fweimer@redhat.com> | 2019-10-07 15:49:48 +0200 |
---|---|---|
committer | Florian Weimer <fweimer@redhat.com> | 2019-10-07 15:49:48 +0200 |
commit | 0caab6638e22a301e8aa0b35f790b15aaf0791d9 (patch) | |
tree | e816389a0615dc2b1ce0710d80d419f5a2472717 /ChangeLog | |
parent | elf: Assign TLS modid later during dlopen [BZ #24930] (diff) | |
download | glibc-0caab6638e22a301e8aa0b35f790b15aaf0791d9.tar.gz glibc-0caab6638e22a301e8aa0b35f790b15aaf0791d9.tar.bz2 glibc-0caab6638e22a301e8aa0b35f790b15aaf0791d9.zip |
nptl: Move pthread_attr_getschedparam implementation into libc
This is part of the libpthread removal project:
<https://sourceware.org/ml/libc-alpha/2019-10/msg00080.html>
Reviewed-by: Adhemerval Zanella <adhemerval.zanella@linaro.org>
Diffstat (limited to 'ChangeLog')
-rw-r--r-- | ChangeLog | 67 |
1 files changed, 67 insertions, 0 deletions
@@ -1,3 +1,70 @@ +2019-10-07 Florian Weimer <fweimer@redhat.com> + + nptl: Move pthread_attr_getschedparam implementation into libc. + * nptl/Makefile (routines): Add pthread_attr_getschedparam. + (libpthread-routines): Remove pthread_attr_getschedparam. + * nptl/Versions (libpthread GLIBC_2.0): Remove + pthread_attr_getschedparam. + * nptl/forward.c (pthread_attr_getschedparam): Remove definition. + * nptl/nptl-init.c (pthread_functions): Remove initializer for + ptr_pthread_attr_getschedparam. + * sysdeps/nptl/pthread-functions.h (struct pthread_functions): + Remove ptr_pthread_attr_getschedparam member. + * sysdeps/unix/sysv/linux/aarch64/libpthread.abilist (GLIBC_2.17): + Remove pthread_attr_getschedparam. + * sysdeps/unix/sysv/linux/alpha/libpthread.abilist (GLIBC_2.0): + Likewise. + * sysdeps/unix/sysv/linux/arm/be/libpthread.abilist (GLIBC_2.4): + Likewise. + * sysdeps/unix/sysv/linux/arm/le/libpthread.abilist (GLIBC_2.4): + Likewise. + * sysdeps/unix/sysv/linux/csky/libpthread.abilist (GLIBC_2.29): + Likewise. + * sysdeps/unix/sysv/linux/hppa/libpthread.abilist (GLIBC_2.2): + Likewise. + * sysdeps/unix/sysv/linux/i386/libpthread.abilist (GLIBC_2.0): + Likewise. + * sysdeps/unix/sysv/linux/ia64/libpthread.abilist (GLIBC_2.2): + Likewise. + * sysdeps/unix/sysv/linux/m68k/coldfire/libpthread.abilist + (GLIBC_2.4): Likewise. + * sysdeps/unix/sysv/linux/m68k/m680x0/libpthread.abilist + (GLIBC_2.0): Likewise. + * sysdeps/unix/sysv/linux/microblaze/be/libpthread.abilist + (GLIBC_2.18): Likewise. + * sysdeps/unix/sysv/linux/microblaze/le/libpthread.abilist + (GLIBC_2.18): Likewise. + * sysdeps/unix/sysv/linux/mips/mips32/libpthread.abilist + (GLIBC_2.0): Likewise. + * sysdeps/unix/sysv/linux/mips/mips64/libpthread.abilist + (GLIBC_2.0): Likewise. + * sysdeps/unix/sysv/linux/nios2/libpthread.abilist (GLIBC_2.21): + Likewise. + * sysdeps/unix/sysv/linux/powerpc/powerpc32/libpthread.abilist + (GLIBC_2.0): Likewise. + * sysdeps/unix/sysv/linux/powerpc/powerpc64/be/libpthread.abilist + (GLIBC_2.3): Likewise. + * sysdeps/unix/sysv/linux/powerpc/powerpc64/le/libpthread.abilist + (GLIBC_2.17): Likewise. + * sysdeps/unix/sysv/linux/riscv/rv64/libpthread.abilist + (GLIBC_2.27): Likewise. + * sysdeps/unix/sysv/linux/s390/s390-32/libpthread.abilist + (GLIBC_2.0): Likewise. + * sysdeps/unix/sysv/linux/s390/s390-64/libpthread.abilist + (GLIBC_2.2): Likewise. + * sysdeps/unix/sysv/linux/sh/be/libpthread.abilist (GLIBC_2.2): + Likewise. + * sysdeps/unix/sysv/linux/sh/le/libpthread.abilist (GLIBC_2.2): + Likewise. + * sysdeps/unix/sysv/linux/sparc/sparc32/libpthread.abilist + (GLIBC_2.0): Likewise. + * sysdeps/unix/sysv/linux/sparc/sparc64/libpthread.abilist + (GLIBC_2.2): Likewise. + * sysdeps/unix/sysv/linux/x86_64/64/libpthread.abilist + (GLIBC_2.2.5): Likewise. + * sysdeps/unix/sysv/linux/x86_64/x32/libpthread.abilist + (GLIBC_2.16): Likewise. + 2019-10-04 Florian Weimer <fweimer@redhat.com> [BZ #24930] |