aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpxinwr <peixing.xin@windriver.com>2020-12-30 20:50:39 +0800
committerGitHub <noreply@github.com>2020-12-30 13:50:39 +0100
commit277ce3060becc120f1c877346562bd6880f4be71 (patch)
treec0cf4a259865653e84f5d4a87ae2e27e7cb20dbc /setup.py
parentbpo-27794: Add `name` attribute to `property` class (GH-23967) (diff)
downloadcpython-277ce3060becc120f1c877346562bd6880f4be71.tar.gz
cpython-277ce3060becc120f1c877346562bd6880f4be71.tar.bz2
cpython-277ce3060becc120f1c877346562bd6880f4be71.zip
bpo-27640: Add --disable-test-modules configure option (GH-23886)
Added --disable-test-modules option to the configure script: don't build nor install test modules. Patch by Xavier de Gaye, Thomas Petazzoni and Peixing Xin. Co-Authored-By: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Co-Authored-By: Xavier de Gaye <xdegaye@gmail.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index e055e44b0f1..8598d2aa5db 100644
--- a/setup.py
+++ b/setup.py
@@ -41,7 +41,7 @@ from distutils.spawn import find_executable
# Compile extensions used to test Python?
-TEST_EXTENSIONS = True
+TEST_EXTENSIONS = (sysconfig.get_config_var('TEST_MODULES') == 'yes')
# This global variable is used to hold the list of modules to be disabled.
DISABLED_MODULE_LIST = []