aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpxinwr <peixing.xin@windriver.com>2020-12-15 06:14:43 +0800
committerGitHub <noreply@github.com>2020-12-14 23:14:43 +0100
commitc117426bf8e7dd7a25e7d15bfbc88253b6ed42de (patch)
tree49c56ed434305c79491794b7be7dea6ca5eac9a6 /configure.ac
parentbpo-42639: atexit now logs callbacks exceptions (GH-23771) (diff)
downloadcpython-c117426bf8e7dd7a25e7d15bfbc88253b6ed42de.tar.gz
cpython-c117426bf8e7dd7a25e7d15bfbc88253b6ed42de.tar.bz2
cpython-c117426bf8e7dd7a25e7d15bfbc88253b6ed42de.zip
bpo-31904: Enable libpython3.so shared library for VxWorks (GH-23741)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 31e39ec4f7d..445dae13587 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1133,7 +1133,7 @@ if test $enable_shared = "yes"; then
PY3LIBRARY=libpython3.so
fi
;;
- Linux*|GNU*|NetBSD*|FreeBSD*|DragonFly*|OpenBSD*)
+ Linux*|GNU*|NetBSD*|FreeBSD*|DragonFly*|OpenBSD*|VxWorks*)
LDLIBRARY='libpython$(LDVERSION).so'
BLDLIBRARY='-L. -lpython$(LDVERSION)'
RUNSHARED=LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
@@ -2798,7 +2798,7 @@ then
# when running test_compile.py.
LINKFORSHARED='-Wl,-E -N 2048K';;
VxWorks*)
- LINKFORSHARED='--export-dynamic';;
+ LINKFORSHARED='-Wl,-export-dynamic';;
esac
fi
AC_MSG_RESULT($LINKFORSHARED)