aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-16 14:49:29 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-16 15:02:21 +0200
commit02b56bb1d4fcdf30b15c3c39a768c711f2adff72 (patch)
treecc9c9dedbb3eb933309b286d441f77d3a221ae6f
parentAdd missing textwrap import to datetimetester (diff)
downloadcpython-gentoo-3.13.0b2_p5.tar.gz
cpython-gentoo-3.13.0b2_p5.tar.bz2
cpython-gentoo-3.13.0b2_p5.zip
Run just-built Python with -s -Sgentoo-3.13.0b2_p5
Add `-s` and `-S` flags to `PYTHON_FOR_BUILD` to ensure that the new executable does not access the system site-packages. This avoids sandbox errors when upgrading from 3.13.0b1. Bug: https://bugs.gentoo.org/934079 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c5631a2380f..9150ff98829 100644
--- a/configure.ac
+++ b/configure.ac
@@ -170,8 +170,8 @@ AC_ARG_WITH([build-python],
AS_VAR_IF([cross_compiling], [yes],
[AC_MSG_ERROR([Cross compiling requires --with-build-python])]
)
- PYTHON_FOR_BUILD='./$(BUILDPYTHON) -E'
- PYTHON_FOR_FREEZE="./_bootstrap_python"
+ PYTHON_FOR_BUILD='./$(BUILDPYTHON) -E -s -S'
+ PYTHON_FOR_FREEZE="./_bootstrap_python -E -s -S"
]
)
AC_SUBST([PYTHON_FOR_BUILD])