aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-10-11 13:50:03 -0400
committerMichał Górny <mgorny@gentoo.org>2021-12-07 09:02:36 +0100
commit4dab7405eb33df813b2b02fe695f2d0293bbb2bf (patch)
treee5ff72649f67dcbd7851c85b9a84f0f86a720b69
parentssl: Hard-disable SSLv3 to avoid automagic deps (diff)
downloadcpython-gentoo-3.10.1.tar.gz
cpython-gentoo-3.10.1.tar.bz2
cpython-gentoo-3.10.1.zip
bpo-45433: Do not link libpython against libcryptgentoo-3.10.1
Save/restore LIBS when calling AC_SEARCH_LIBS(..., crypt). This avoid linking libpython with libcrypt.
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0c069141478..38fd9da2ff8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4051,6 +4051,8 @@ AC_CHECK_FUNCS(setpgrp,
# We search for both crypt and crypt_r as one or the other may be defined
# This gets us our -lcrypt in LIBS when required on the target platform.
+# Save/restore LIBS to avoid linking libpython with libcrypt.
+LIBS_SAVE=$LIBS
AC_SEARCH_LIBS(crypt, crypt)
AC_SEARCH_LIBS(crypt_r, crypt)
@@ -4065,6 +4067,7 @@ char *r = crypt_r("", "", &d);
[AC_DEFINE(HAVE_CRYPT_R, 1, [Define if you have the crypt_r() function.])],
[])
)
+LIBS=$LIBS_SAVE
AC_CHECK_FUNCS(clock_gettime, [], [
AC_CHECK_LIB(rt, clock_gettime, [