summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/neovim/neovim-9999.ebuild')
-rw-r--r--app-editors/neovim/neovim-9999.ebuild19
1 files changed, 16 insertions, 3 deletions
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index 00ff769..90b75a5 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -3,7 +3,7 @@
# $Header: $
EAPI=5
-inherit cmake-utils git-r3
+inherit cmake-utils flag-o-matic git-r3
DESCRIPTION="Vim's rebirth for the 21st century"
HOMEPAGE="https://github.com/neovim/neovim"
@@ -14,7 +14,20 @@ SLOT="0"
KEYWORDS=""
IUSE=""
-RDEPEND="app-admin/eselect-vi
+RDEPEND="dev-lang/perl
+ >=dev-libs/libuv-0.11.27
+ dev-libs/msgpack
sys-libs/ncurses"
DEPEND="${RDEPEND}
- >=dev-libs/libuv-0.11.19"
+ dev-lang/luajit
+ dev-lua/LuaBitOp
+ dev-lua/lpeg
+ dev-lua/cmsgpack
+ virtual/libiconv
+ virtual/libintl"
+
+src_configure() {
+ append-flags "-Wno-error -DNDEBUG -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1"
+ local mycmakeargs=( -DCMAKE_BUILD_TYPE=Release )
+ cmake-utils_src_configure
+}