summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/neovim/neovim-9999.ebuild')
-rw-r--r--app-editors/neovim/neovim-9999.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index ef449d4..64020f8 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -35,6 +35,10 @@ RDEPEND="${CDEPEND}
python? ( dev-python/neovim-python-client )"
src_prepare() {
+ # do not link statically
+ sed -e '/^set(LIBUNIBILIUM/s|ON|OFF|' -e '/^set(LIBTERMKEY/s|ON|OFF|' \
+ -i CMakeLists.txt
+ # use our system vim dir
sed -e '/^# define SYS_VIMRC_FILE/s|$VIM|'"${EPREFIX}"'/etc/vim|' \
-i src/nvim/os_unix_defs.h || die
cmake-utils_src_prepare
@@ -49,7 +53,8 @@ src_configure() {
}
src_install() {
- default
+ cmake-utils_src_install
+ # install a default configuration file
insinto "${EPREFIX}"/etc/vim
doins "${FILESDIR}"/nvimrc
}