summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2015-02-20 17:58:59 +0800
committerBen de Groot <yngwin@gentoo.org>2015-02-20 17:58:59 +0800
commit8f3f8363fcab26f8c8f1a74140680adf1d218029 (patch)
tree11ba301b2a7e9b875593a3a9b6200f1820606252
parentapp-editors/neovim: add snapshot (diff)
downloadyngwin-8f3f8363fcab26f8c8f1a74140680adf1d218029.tar.gz
yngwin-8f3f8363fcab26f8c8f1a74140680adf1d218029.tar.bz2
yngwin-8f3f8363fcab26f8c8f1a74140680adf1d218029.zip
Add neovim-python-client ebuild with dep. Update neovim ebuild.
-rw-r--r--app-editors/neovim/Manifest2
-rw-r--r--app-editors/neovim/neovim-0.0.0_pre20150220.ebuild10
-rw-r--r--app-editors/neovim/neovim-9999.ebuild10
-rw-r--r--dev-python/neovim-python-client/Manifest1
-rw-r--r--dev-python/neovim-python-client/metadata.xml8
-rw-r--r--dev-python/neovim-python-client/neovim-python-client-0.0.28.ebuild24
-rw-r--r--dev-python/trollius/Manifest1
-rw-r--r--dev-python/trollius/metadata.xml8
-rw-r--r--dev-python/trollius/trollius-1.0.4.ebuild19
9 files changed, 74 insertions, 9 deletions
diff --git a/app-editors/neovim/Manifest b/app-editors/neovim/Manifest
index f1f5853..60ca0fa 100644
--- a/app-editors/neovim/Manifest
+++ b/app-editors/neovim/Manifest
@@ -1 +1 @@
-DIST neovim-0.0.0_pre20150220.tar.gz 7369794 SHA256 78b38d4f0e78b9438f54405aceea717dc08dd5e80d69996654bb2042a829351d SHA512 a9045b22e5e7c60d9a735c05d3a82002a92bc2305453b12b37d6f0f9f3c7317399e414b3606a4f34cc9c92080d32a299a6105560a860cda667c85dbe6a03a204 WHIRLPOOL aedd27ed23640362cbf8b4f7daa9182465397122e9e8a0b8af0e2b7adb9a8028fee1515745e9574d62c0f6256a0e842125f5688a4c185b4a1436410d032d2bc8
+DIST neovim-0.0.0_pre20150220.tar.gz 7369427 SHA256 d6628a2de3f5fea5983a6ee9fa7d3eae4e1d3469ab5948ac4d5f27fd3131229c SHA512 4580539c975848cd94402e045e983ee40e585a515ac4dca343fa6ee354359a74222738b682359c1f98619a70578abaf4e482023fdb9b25ea80dbf6e8cf53a22d WHIRLPOOL f68b1d8512f62f8f3b6c7871642c4b257f6f72ed920e6c91a358180a559b0db87ba5e5758d1849437aa00f14322fe59d6318b071616c22e1e700929332bfa98f
diff --git a/app-editors/neovim/neovim-0.0.0_pre20150220.ebuild b/app-editors/neovim/neovim-0.0.0_pre20150220.ebuild
index 0580e56..7c8bb7d 100644
--- a/app-editors/neovim/neovim-0.0.0_pre20150220.ebuild
+++ b/app-editors/neovim/neovim-0.0.0_pre20150220.ebuild
@@ -13,14 +13,14 @@ if [[ ${PV} == 9999 ]]; then
KEYWORDS=""
else
inherit vcs-snapshot
- COMMIT="866da6d65e5078ac5aa91af5b4e78caf07853379"
+ COMMIT="8efb3607a7f6cefce450953c7f8d5e3299347bae"
SRC_URI="https://github.com/${PN}/${PN}/tarball/${COMMIT} -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
LICENSE="Apache-2.0 vim"
SLOT="0"
-IUSE="perl"
+IUSE="perl python"
CDEPEND="dev-lang/luajit
>=dev-libs/libtermkey-0.17
@@ -34,10 +34,12 @@ DEPEND="${CDEPEND}
virtual/libiconv
virtual/libintl"
RDEPEND="${CDEPEND}
- perl? ( dev-lang/perl )"
+ perl? ( dev-lang/perl )
+ python? ( dev-python/neovim-python-client )"
src_configure() {
- append-flags "-Wno-error -DNDEBUG -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1"
+ append-cflags "-Wno-error"
+ append-cppflags "-DNDEBUG -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1"
local mycmakeargs=( -DCMAKE_BUILD_TYPE=Release )
cmake-utils_src_configure
}
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index 0580e56..7c8bb7d 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -13,14 +13,14 @@ if [[ ${PV} == 9999 ]]; then
KEYWORDS=""
else
inherit vcs-snapshot
- COMMIT="866da6d65e5078ac5aa91af5b4e78caf07853379"
+ COMMIT="8efb3607a7f6cefce450953c7f8d5e3299347bae"
SRC_URI="https://github.com/${PN}/${PN}/tarball/${COMMIT} -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
LICENSE="Apache-2.0 vim"
SLOT="0"
-IUSE="perl"
+IUSE="perl python"
CDEPEND="dev-lang/luajit
>=dev-libs/libtermkey-0.17
@@ -34,10 +34,12 @@ DEPEND="${CDEPEND}
virtual/libiconv
virtual/libintl"
RDEPEND="${CDEPEND}
- perl? ( dev-lang/perl )"
+ perl? ( dev-lang/perl )
+ python? ( dev-python/neovim-python-client )"
src_configure() {
- append-flags "-Wno-error -DNDEBUG -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1"
+ append-cflags "-Wno-error"
+ append-cppflags "-DNDEBUG -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=1"
local mycmakeargs=( -DCMAKE_BUILD_TYPE=Release )
cmake-utils_src_configure
}
diff --git a/dev-python/neovim-python-client/Manifest b/dev-python/neovim-python-client/Manifest
new file mode 100644
index 0000000..5e04fa8
--- /dev/null
+++ b/dev-python/neovim-python-client/Manifest
@@ -0,0 +1 @@
+DIST neovim-python-client-0.0.28.tar.gz 42435 SHA256 de13a64d62b0e95264ce308f754189922472c9cd397428e986ee41e679e95f53 SHA512 5810cc83ac5edcefab38b20483cfad916124b5296cc6e8a4dc6229a600b3decfa76f0230826d6c15cce209eb78a8080717587dc783f175827a0eba5c39326c5b WHIRLPOOL d66b911c1e986c150ea559cfa28c8ecb8e969b0944823b57d0df934500aea1165ec26d57405b56058caa79c07128b7b6fa012151c6e0ecd01ac96791ff51a694
diff --git a/dev-python/neovim-python-client/metadata.xml b/dev-python/neovim-python-client/metadata.xml
new file mode 100644
index 0000000..f2b4a5d
--- /dev/null
+++ b/dev-python/neovim-python-client/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>yngwin@gentoo.org</email>
+ <name>Ben de Groot</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/neovim-python-client/neovim-python-client-0.0.28.ebuild b/dev-python/neovim-python-client/neovim-python-client-0.0.28.ebuild
new file mode 100644
index 0000000..0c68887
--- /dev/null
+++ b/dev-python/neovim-python-client/neovim-python-client-0.0.28.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+inherit distutils-r1
+
+DESCRIPTION="Python client to connect to Neovim thru its msgpack-rpc API"
+HOMEPAGE="https://github.com/neovim/python-client"
+SRC_URI="https://github.com/neovim/python-client/archive/0.0.28.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-python/click-3.0
+ >=dev-python/msgpack-0.4.0
+ !python_targets_pypy? ( dev-python/greenlet )
+ !python_targets_python3_4? ( dev-python/trollius )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P/neovim-/}
diff --git a/dev-python/trollius/Manifest b/dev-python/trollius/Manifest
new file mode 100644
index 0000000..2eb410c
--- /dev/null
+++ b/dev-python/trollius/Manifest
@@ -0,0 +1 @@
+DIST trollius-1.0.4.tar.gz 259188 SHA256 8884cae4ec6a2d593abcffd5e700626ad4618f42b11beb2b75998f2e8247de76 SHA512 f8df8c9f0034e6075e2a356a0bcfcd7908d98d8d14b07332a71de0115753e17335f5b8030c06c6b2a5b79437392ccf13f92d46155622f789b13c36d04c6d1f9e WHIRLPOOL 0cc57bee6be7a2bd8785decc406792c0d354dfc24f4a51b40d0de9557e212cbda738f9aab0a41fcb1ebe1a4b72986c09db1e243fd6ca3398f1df400e8c4ae6ad
diff --git a/dev-python/trollius/metadata.xml b/dev-python/trollius/metadata.xml
new file mode 100644
index 0000000..f2b4a5d
--- /dev/null
+++ b/dev-python/trollius/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>yngwin@gentoo.org</email>
+ <name>Ben de Groot</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/trollius/trollius-1.0.4.ebuild b/dev-python/trollius/trollius-1.0.4.ebuild
new file mode 100644
index 0000000..9a24479
--- /dev/null
+++ b/dev-python/trollius/trollius-1.0.4.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+inherit distutils-r1
+
+DESCRIPTION="A port of the Tulip project: asyncio module, PEP3156"
+HOMEPAGE="https://pypi.python.org/pypi/trollius/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="virtual/python-futures"
+RDEPEND="${DEPEND}"