summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2005-08-30 19:04:09 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2005-08-30 19:04:09 +0000
commit4480af781c788545f33bfcfa9b3e605e02f71a54 (patch)
tree450d58dfa43e6e5b79af113e04c911d695a8ba5c /app-emacs
parentFixed digests (diff)
downloadoverlay-4480af781c788545f33bfcfa9b3e605e02f71a54.tar.gz
overlay-4480af781c788545f33bfcfa9b3e605e02f71a54.tar.bz2
overlay-4480af781c788545f33bfcfa9b3e605e02f71a54.zip
Updated delicious api
svn path=/; revision=321
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/delicious/delicious-20050830.ebuild46
-rw-r--r--app-emacs/rnc-mode/rnc-mode-1.0.3_beta.ebuild3
2 files changed, 48 insertions, 1 deletions
diff --git a/app-emacs/delicious/delicious-20050830.ebuild b/app-emacs/delicious/delicious-20050830.ebuild
new file mode 100644
index 0000000..5dca289
--- /dev/null
+++ b/app-emacs/delicious/delicious-20050830.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Emacs client API for del.icio.us"
+HOMEPAGE="http://www.wjsullivan.net/code/delicious-el.html"
+SRC_URI="http://www.gunnarwrobel.de/downloads/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/emacs
+ app-emacs/w3"
+
+SITEFILE=50delicious-gentoo.el
+
+S="${WORKDIR}/${PN}-el"
+
+src_compile() {
+
+ cd ${S}
+
+ EMACSLOADPATH="/usr/share/emacs/site-lisp/w3/:/usr/share/emacs/21.4/lisp/:${S}" elisp-compile *.el || die
+}
+
+src_install() {
+
+ cd ${S}
+
+ dodoc README
+
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}
diff --git a/app-emacs/rnc-mode/rnc-mode-1.0.3_beta.ebuild b/app-emacs/rnc-mode/rnc-mode-1.0.3_beta.ebuild
index a0b1852..3868c5f 100644
--- a/app-emacs/rnc-mode/rnc-mode-1.0.3_beta.ebuild
+++ b/app-emacs/rnc-mode/rnc-mode-1.0.3_beta.ebuild
@@ -1,5 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+# $Header: $
inherit elisp
@@ -10,7 +11,7 @@ HOMEPAGE="http://www.pantor.com/"
SRC_URI="http://www.pantor.com/RncMode-1_0b3.tgz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="x86"
+KEYWORDS="~x86"
DEPEND="virtual/emacs"