summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <roy@marples.name>2007-12-28 18:00:14 +0000
committerRoy Marples <roy@marples.name>2007-12-28 18:00:14 +0000
commit78e8521284ae9c3d7d9c2bacadd7f42349a23478 (patch)
tree17f221382399499601d64c60b59aa4c6aed3ae39
parentFix symlinks and ldscript for libs (diff)
downloaduberlord-78e8521284ae9c3d7d9c2bacadd7f42349a23478.tar.gz
uberlord-78e8521284ae9c3d7d9c2bacadd7f42349a23478.tar.bz2
uberlord-78e8521284ae9c3d7d9c2bacadd7f42349a23478.zip
Move to a git ebuild for initial testing, thanks to Flameeyes
-rw-r--r--sys-apps/openrc/openrc-9999.ebuild (renamed from sys-apps/openrc/openrc-0.1.ebuild)19
1 files changed, 19 insertions, 0 deletions
diff --git a/sys-apps/openrc/openrc-0.1.ebuild b/sys-apps/openrc/openrc-9999.ebuild
index ef11c9e..b66378e 100644
--- a/sys-apps/openrc/openrc-0.1.ebuild
+++ b/sys-apps/openrc/openrc-9999.ebuild
@@ -2,7 +2,13 @@ inherit flag-o-matic eutils toolchain-funcs multilib
DESCRIPTION="OpenRC manages the services, startup and shutdown of a host"
HOMEPAGE="http://roy.marples.name/"
+
+if [ "${PV}" = "9999" ]; then
+inherit git
+EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/openrc.git"
+else
SRC_URI="http://roy.marples.name/${P}.tar.bz2"
+fi
LICENSE="BSD-2"
SLOT="0"
@@ -41,6 +47,19 @@ make_opts() {
echo "${opts}"
}
+src_unpack() {
+ if [ "${PV}" = "9999" ]; then
+ git_src_unpack
+ else
+ unpack ${A}
+ fi
+ cd "${S}"
+
+ # GIT has this rpath for testing, but we need to disable it as it's
+ # a potential security risk
+ sed -i.bak -e '/LDFLAGS += -Wl,-rpath ./ s/^/#/' src/Makefile
+}
+
src_compile() {
use static && append-ldflags -static
emake $(make_opts) CC=$(tc-getCC) || die