summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <torsten@veller.net>2008-03-26 18:52:11 +0100
committerTorsten Veller <torsten@veller.net>2008-03-26 18:52:11 +0100
commita67459c4e8a8602c0846dee50d105285372747f2 (patch)
treedeab53ef51107ebad57c395c0c2ac4d314d35698
parentlive version (diff)
downloadtove-a67459c4e8a8602c0846dee50d105285372747f2.tar.gz
tove-a67459c4e8a8602c0846dee50d105285372747f2.tar.bz2
tove-a67459c4e8a8602c0846dee50d105285372747f2.zip
Add app-misc/wyrd-1.4.5_pre1
-rw-r--r--repo/app-misc/wyrd/Manifest3
-rw-r--r--repo/app-misc/wyrd/metadata.xml15
-rw-r--r--repo/app-misc/wyrd/wyrd-1.4.5_pre1.ebuild44
3 files changed, 62 insertions, 0 deletions
diff --git a/repo/app-misc/wyrd/Manifest b/repo/app-misc/wyrd/Manifest
new file mode 100644
index 0000000..7662674
--- /dev/null
+++ b/repo/app-misc/wyrd/Manifest
@@ -0,0 +1,3 @@
+DIST wyrd-1.4.5pre1.tar.gz 228971 RMD160 a2e9db5fa2142bee87973b10341723d77ba6cd89 SHA1 056aebc7c8150369d634e59750ce22cf8a81c99e SHA256 0791333b2f8273a4bfc5012b903624989477ae81212c457a58eea26205490b91
+EBUILD wyrd-1.4.5_pre1.ebuild 1123 RMD160 56f91a8414dc668256f1b35610b415d038f93278 SHA1 8bd3749bae22d3b0b928b02e75fb3efdb54ecf13 SHA256 3355a33f80053fd2308d89fea27f3b58189ae7af915630bc4418ad47c57f69e9
+MISC metadata.xml 656 RMD160 f2bd211d23d77bb049ae6e7f2fb86e4acbf92c45 SHA1 b09d0c13b6c3a211b0a0a3e56c9b19b790105b61 SHA256 2c4d142cd189c9b5b8659c8b5a998e59308ebb5329c1deae0b473ed72283de83
diff --git a/repo/app-misc/wyrd/metadata.xml b/repo/app-misc/wyrd/metadata.xml
new file mode 100644
index 0000000..5d0f18a
--- /dev/null
+++ b/repo/app-misc/wyrd/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+ <maintainer>
+ <email>tove@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ Wyrd is a text-based front-end to Remind, a sophisticated calendar and alarm
+ program. Remind's power lies in its programmability, and Wyrd does not hide this
+ capability behind flashy GUI dialogs. Rather, Wyrd is designed to make you more
+ efficient at editing your reminder files directly. It also offers a scrollable
+ timetable suitable for visualizing your schedule at a glance.
+ </longdescription>
+</pkgmetadata>
diff --git a/repo/app-misc/wyrd/wyrd-1.4.5_pre1.ebuild b/repo/app-misc/wyrd/wyrd-1.4.5_pre1.ebuild
new file mode 100644
index 0000000..18d3a04
--- /dev/null
+++ b/repo/app-misc/wyrd/wyrd-1.4.5_pre1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/wyrd/wyrd-1.4.4.ebuild,v 1.1 2008/02/22 09:10:20 tove Exp $
+
+inherit eutils
+
+MY_P=${P/_pre/pre}
+
+DESCRIPTION="Text-based front-end to Remind"
+HOMEPAGE="http://pessimization.com/software/wyrd/"
+SRC_URI="http://pessimization.com/software/wyrd/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="unicode"
+
+DEPEND=">=dev-lang/ocaml-3.08
+ sys-libs/ncurses
+ >=x11-misc/remind-03.01"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ use unicode || return 0
+ if ! built_with_use sys-libs/ncurses unicode ; then
+ eerror "To use unicode in wyrd you must build sys-libs/ncurses"
+ eerror "with unicode support."
+ die "Please rebuilt sys-libs/ncurses with unicode in USE!"
+ fi
+}
+
+src_compile() {
+ econf $(use_enable unicode utf8 ) || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install died"
+
+ dodoc ChangeLog || die "dodoc failed"
+ dohtml doc/manual.html || die "dohtml failed"
+}