summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2009-10-07 11:04:15 +0000
committerAndreas Proschofsky <suka@gentoo.org>2009-10-07 11:04:15 +0000
commitf413e8215e9ccaa5532b75da2624771328b5acd1 (patch)
treebdb432e6a706a785642c86ae5e0063339735771b
parentDependency on clutter-imcontext is gone again (diff)
downloadsuka-f413e8215e9ccaa5532b75da2624771328b5acd1.tar.gz
suka-f413e8215e9ccaa5532b75da2624771328b5acd1.tar.bz2
suka-f413e8215e9ccaa5532b75da2624771328b5acd1.zip
Add Emerillon, new GNOME map viewer and the necessary dependencies, for
more infos see: http://blog.pierlux.com/2009/10/06/announcing-emerillon-the-map-viewer/en/ svn path=/; revision=168
-rw-r--r--app-misc/emerillon/Manifest1
-rw-r--r--app-misc/emerillon/emerillon-9999.ebuild39
-rw-r--r--dev-libs/ethos/Manifest1
-rw-r--r--dev-libs/ethos/ethos-9999.ebuild46
-rw-r--r--dev-libs/librest/Manifest2
-rw-r--r--dev-libs/librest/librest-0.6.0.ebuild34
-rw-r--r--gnome-extra/geoclue/Manifest4
-rw-r--r--gnome-extra/geoclue/files/0001-Remove-automagic-deps-and-add-switches-to-enable-dis.patch227
-rw-r--r--gnome-extra/geoclue/files/0002-Fix-NM-pkgcheck.patch25
-rw-r--r--gnome-extra/geoclue/geoclue-0.11.1.ebuild52
10 files changed, 431 insertions, 0 deletions
diff --git a/app-misc/emerillon/Manifest b/app-misc/emerillon/Manifest
new file mode 100644
index 0000000..9678110
--- /dev/null
+++ b/app-misc/emerillon/Manifest
@@ -0,0 +1 @@
+EBUILD emerillon-9999.ebuild 750 RMD160 03878636b3e8a73f24c3a8697372e3a840fb4655 SHA1 dadfa492e9b2ffadc38a489a6cfb79c2550d17ac SHA256 10568b329378b101a0676c23c5e188da39a612807a0834c97a636f7869d93d27
diff --git a/app-misc/emerillon/emerillon-9999.ebuild b/app-misc/emerillon/emerillon-9999.ebuild
new file mode 100644
index 0000000..2ce06da
--- /dev/null
+++ b/app-misc/emerillon/emerillon-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit autotools gnome2 git
+
+EGIT_REPO_URI="git://git.gnome.org/emerillon"
+
+DESCRIPTION="GNOME-based Map viewer, using Open Street Maps"
+HOMEPAGE="http://www.novopia.com/emerillon/"
+SRC_URI=""
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.12.0
+ >=x11-libs/gtk+-2.12.0
+ >=gnome-base/gconf-2.5.90
+ >=media-libs/libchamplain-0.4
+ >=gnome-extra/geoclue-0.11.1
+ >=dev-libs/ethos-0.2
+ >=dev-libs/librest-0.6"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9"
+
+DOCS="AUTHORS NEWS README"
+
+S=${WORKDIR}/trunk
+
+src_unpack() {
+ git_src_unpack
+ cd ${S}
+ eautoreconf
+}
diff --git a/dev-libs/ethos/Manifest b/dev-libs/ethos/Manifest
new file mode 100644
index 0000000..5534b68
--- /dev/null
+++ b/dev-libs/ethos/Manifest
@@ -0,0 +1 @@
+EBUILD ethos-9999.ebuild 938 RMD160 b676156c6a50c3576a5b28c7615b10fbf0d302c5 SHA1 2dac4790bc138289c75752b239d56d7deb44bba8 SHA256 797526443d4e9bb52601efc110feb7366920c8b6b8bd530e3c6d0b7e07abb8ed
diff --git a/dev-libs/ethos/ethos-9999.ebuild b/dev-libs/ethos/ethos-9999.ebuild
new file mode 100644
index 0000000..5ae3c93
--- /dev/null
+++ b/dev-libs/ethos/ethos-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit autotools gnome2 git
+
+EGIT_REPO_URI="git://git.dronelabs.com/ethos"
+
+DESCRIPTION="Generic Plugin Engine for GLib"
+HOMEPAGE="http://git.dronelabs.com/ethos/about/"
+SRC_URI=""
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="introspection javascript python"
+
+RDEPEND=">=dev-libs/glib-2.16.0
+ >=x11-libs/gtk+-2.10.0
+ introspection? ( >=dev-libs/gobject-introspection-0.6.3 )
+ javascript? ( >=dev-libs/gjs-0.2 )
+ python? ( >=dev-python/pygobject-2.15.3
+ >=dev-python/pygtk-2.12 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9"
+
+DOCS="AUTHORS NEWS README TODO"
+
+S=${WORKDIR}/trunk
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-vala
+ $(use_enable python)
+ $(use_enable javascript js)
+ $(use_enable introspection)"
+}
+
+src_unpack() {
+ git_src_unpack
+ cd ${S}
+ ./autogen.sh
+}
diff --git a/dev-libs/librest/Manifest b/dev-libs/librest/Manifest
new file mode 100644
index 0000000..da383de
--- /dev/null
+++ b/dev-libs/librest/Manifest
@@ -0,0 +1,2 @@
+DIST rest-0.6.tar.gz 379628 RMD160 8b7b5bcfd20c66ecf1551bda7785276a27746566 SHA1 9ed2814ae123b73d15598ebd0b1457ab9b6208be SHA256 8734c43d99651c17ce0346ddaac97122b92e28e21e625200b4a12a30f0d8e7f6
+EBUILD librest-0.6.0.ebuild 671 RMD160 4bde4c6f385807833c58d4b8683d467d6a7d0e2a SHA1 f2466799393ca51595299db8e86a501404bb44eb SHA256 9ffdf5d1b8c856bae99e21b366a7145acc1365cdf81626a0e0e35e70b294fa5e
diff --git a/dev-libs/librest/librest-0.6.0.ebuild b/dev-libs/librest/librest-0.6.0.ebuild
new file mode 100644
index 0000000..cabe04d
--- /dev/null
+++ b/dev-libs/librest/librest-0.6.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit gnome2
+
+DESCRIPTION="Library to access RESTful web-services"
+HOMEPAGE="http://moblin.org/projects/librest"
+SRC_URI="http://moblin.org/sites/all/files/rest-0.6.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome"
+
+RDEPEND=">=dev-libs/glib-2.18.0
+ >=net-libs/libsoup-2.4
+ gnome? ( >=net-libs/libsoup-gnome-2.25.1 )
+ >=dev-libs/libxml2-2"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9"
+
+DOCS="AUTHORS NEWS README"
+
+S="${WORKDIR}/rest-0.6"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_with gnome)"
+}
diff --git a/gnome-extra/geoclue/Manifest b/gnome-extra/geoclue/Manifest
new file mode 100644
index 0000000..a68119e
--- /dev/null
+++ b/gnome-extra/geoclue/Manifest
@@ -0,0 +1,4 @@
+AUX 0001-Remove-automagic-deps-and-add-switches-to-enable-dis.patch 7048 RMD160 cba53196a9ae95430e2dee9511259f98308132a2 SHA1 8d432e6cdf9e1b409a7307c5829d738b1183b5fd SHA256 1220b53b93972c6f317b6258272ce53a4718cf0070f5a012bc85f3d1d66ee11a
+AUX 0002-Fix-NM-pkgcheck.patch 727 RMD160 837959313c457eebfff5262124b01fdcd1943112 SHA1 50bf343fbb0d8bccec77b50c947cb50d8cbb3551 SHA256 17b04dd9a1bc6c3ce9e404b104bc7bf10c3c0a9b920afff5a8880950fc5c45cd
+DIST geoclue-0.11.1.tar.gz 557743 RMD160 7727f8ca2278244512068e38daef0653a926b6e5 SHA1 16a2084e2a47cbd4570b2cb31fc13c95c265cec1 SHA256 9c3b38aa8de51063651f93b4d1ba66266605722ecaa436d36791789cae970205
+EBUILD geoclue-0.11.1.ebuild 1378 RMD160 5a085c74fcd55b3c6b38aeb2a91fd9204ee2960f SHA1 f920102e6ff32fa201ef1e1436b22184fa6d80f7 SHA256 b46b2cae4605401d05140a30a7d25f5b5e6cf8fdef93669f011ee2878f167b53
diff --git a/gnome-extra/geoclue/files/0001-Remove-automagic-deps-and-add-switches-to-enable-dis.patch b/gnome-extra/geoclue/files/0001-Remove-automagic-deps-and-add-switches-to-enable-dis.patch
new file mode 100644
index 0000000..9007911
--- /dev/null
+++ b/gnome-extra/geoclue/files/0001-Remove-automagic-deps-and-add-switches-to-enable-dis.patch
@@ -0,0 +1,227 @@
+From 5be732fcd92de66614f434ebeb1bd8ec5905544d Mon Sep 17 00:00:00 2001
+From: Mikel Olasagasti Uranga <mikel@olasagasti.info>
+Date: Mon, 22 Jun 2009 17:24:22 +0200
+Subject: [PATCH] Remove automagic deps and add switches to enable/disable them
+
+---
+ configure.ac | 176 +++++++++++++++++++++++++++++++++++++++++++++------------
+ 1 files changed, 139 insertions(+), 37 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 3109048..8e5e67c 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -55,35 +55,90 @@ AC_DEFINE_UNQUOTED(DBUS_SERVICES_DIR, "$DBUS_SERVICES_DIR", [Where services dir
+
+ CFLAGS="$CFLAGS -g -Wall -Werror -Wno-format"
+
++# -----------------------------------------------------------
++# gtk+
++# -----------------------------------------------------------
++AC_ARG_ENABLE(gtk,
++ AS_HELP_STRING([--enable-gtk=@<:@no/yes/auto@:>@],
++ [build with gtk support]), ,
++ enable_gtk=auto)
+
++if test "x$enable_gtk" != "xno"; then
++ PKG_CHECK_MODULES(GTK,
++ [
++ gtk+-2.0
++ ], have_gtk="yes", have_gtk="no")
+
+-PKG_CHECK_MODULES(GTK, [
+- gtk+-2.0
+-], HAVE_GTK=yes, HAVE_GTK=no)
+-AM_CONDITIONAL(HAVE_GTK, test "x$HAVE_GTK" = "xyes")
++ if test "x$have_gtk" = "xyes"; then
++ AC_DEFINE(HAVE_GTK, 1, [Define if you have gtk+])
++ fi
++else
++ have_gtk=no
++fi
++
++if test "x$enable_gtk" = "xyes" -a "x$have_gtk" != "xyes"; then
++ AC_MSG_ERROR([Couldn't find gtk dependencies.])
++fi
++
++AM_CONDITIONAL(HAVE_GTK, test "x$have_gtk" = "xyes")
+ AC_SUBST(GTK_LIBS)
+ AC_SUBST(GTK_CFLAGS)
+
++# -----------------------------------------------------------
++# connectivity
++# -----------------------------------------------------------
++
+ CONNECTIVITY="None"
+
+-PKG_CHECK_MODULES(CONIC, [
+- conic
+-], HAVE_CONIC=yes, HAVE_CONIC=no)
+-if test "x$HAVE_CONIC" = "xyes"; then
+- CONNECTIVITY="Maemo LibConIC"
+- CONNECTIVITY_LIBS=${CONIC_LIBS}
+- CONNECTIVITY_CFLAGS=${CONIC_CFLAGS}
+- AC_DEFINE(HAVE_CONIC, 1, [define if libconic is installed])
++AC_ARG_ENABLE(conic,
++ AS_HELP_STRING([--enable-conic=@<:@no/yes/auto@:>@],
++ [build with conic support]), ,
++ enable_conic=auto)
++
++if test "x$enable_conic" != "xno"; then
++ PKG_CHECK_MODULES(CONIC,
++ [
++ conic
++ ], have_conic="yes", have_conic="no")
++
++ if test "x$have_conic" = "xyes"; then
++ CONNECTIVITY="Maemo LibConIC"
++ CONNECTIVITY_LIBS=${CONIC_LIBS}
++ CONNECTIVITY_CFLAGS=${CONIC_CFLAGS}
++ AC_DEFINE(HAVE_CONIC, 1, [define if libconic is installed])
++ fi
++else
++ have_conic=no
++fi
++
++if test "x$enable_conic" = "xyes" -a "x$have_conic" != "xyes"; then
++ AC_MSG_ERROR([Couldn't find conic dependencies.])
+ fi
+
+-PKG_CHECK_MODULES(NETWORK_MANAGER, [
+- NetworkManager
+-], HAVE_NETWORK_MANAGER=yes, HAVE_NETWORK_MANAGER=no)
+-if test "x$HAVE_NETWORK_MANAGER" = "xyes"; then
+- CONNECTIVITY="Network Manager"
+- CONNECTIVITY_LIBS=${NETWORK_MANAGER_LIBS}
+- CONNECTIVITY_CFLAGS=${NETWORK_MANAGER_CFLAGS}
+- AC_DEFINE(HAVE_NETWORK_MANAGER, 1, [define if Network Manager is installed])
++
++AC_ARG_ENABLE(networkmanager,
++ AS_HELP_STRING([--enable-networkmanager=@<:@no/yes/auto@:>@],
++ [build with NetworkManager support]), ,
++ enable_networkmanager=auto)
++
++if test "x$enable_networkmanager" != "xno"; then
++ PKG_CHECK_MODULES(NETWORKMANAGER,
++ [
++ NetworkManager
++ ], have_networkmanager="yes", have_networkmanager="no")
++
++ if test "x$have_networkmanager" = "xyes"; then
++ CONNECTIVITY="Network Manager"
++ CONNECTIVITY_LIBS=${NETWORK_MANAGER_LIBS}
++ CONNECTIVITY_CFLAGS=${NETWORK_MANAGER_CFLAGS}
++ AC_DEFINE(HAVE_NETWORK_MANAGER, 1, [define if Network Manager is installed])
++ fi
++else
++ have_networkmanager=no
++fi
++
++if test "x$enable_networkmanager" = "xyes" -a "x$have_networkmanager" != "xyes"; then
++ AC_MSG_ERROR([Couldn't find Network Manager dependencies.])
+ fi
+
+ AC_SUBST(CONNECTIVITY_LIBS)
+@@ -92,35 +147,82 @@ AC_SUBST(CONNECTIVITY_CFLAGS)
+
+ PROVIDER_SUBDIRS="example hostip geonames manual plazes localnet yahoo"
+
+-PKG_CHECK_MODULES(GSMLOC, [
+- gammu >= 1.12
+-], HAVE_GSMLOC=yes, HAVE_GSMLOC=no)
+-if test "x$HAVE_GSMLOC" = "xyes"; then
+- PROVIDER_SUBDIRS="$PROVIDER_SUBDIRS gsmloc"
++# -----------------------------------------------------------
++# gsmloc / gypsy / gpsd
++# -----------------------------------------------------------
++
++AC_ARG_ENABLE(gsmloc,
++ AS_HELP_STRING([--enable-gsmloc=@<:@no/yes/auto@:>@],
++ [build with gsmloc support]), ,
++ enable_gsmloc=auto)
++
++if test "x$enable_gsmloc" != "xno"; then
++ PKG_CHECK_MODULES(GSMLOC,
++ [
++ gammu >= 1.12
++ ], have_gsmloc="yes", have_gsmloc="no")
++
++ if test "x$have_gsmloc" = "xyes"; then
++ PROVIDER_SUBDIRS="$PROVIDER_SUBDIRS gsmloc"
++ else
++ NO_BUILD_PROVIDERS="$NO_BUILD_PROVIDERS gsmloc"
++ fi
+ else
+- NO_BUILD_PROVIDERS="$NO_BUILD_PROVIDERS gsmloc"
++ have_gsmloc=no
++fi
++
++if test "x$enable_gsmloc" = "xyes" -a "x$have_gsmloc" != "xyes"; then
++ AC_MSG_ERROR([Couldn't find gsmloc dependencies.])
+ fi
+ AC_SUBST(GSMLOC_LIBS)
+ AC_SUBST(GSMLOC_CFLAGS)
+
+
+-PKG_CHECK_MODULES(GYPSY, [
+- gypsy
+-], HAVE_GYPSY=yes,HAVE_GYPSY=no)
+-if test "x$HAVE_GYPSY" = "xyes"; then
+- PROVIDER_SUBDIRS="$PROVIDER_SUBDIRS gypsy"
++AC_ARG_ENABLE(gypsy,
++ AS_HELP_STRING([--enable-gypsy=@<:@no/yes/auto@:>@],
++ [build with gypsy support]), ,
++ enable_gypsy=auto)
++
++if test "x$enable_gypsy" != "xno"; then
++ PKG_CHECK_MODULES(GYPSY,
++ [
++ gypsy
++ ], have_gypsy="yes", have_gypsy="no")
++
++ if test "x$have_gypsy" = "xyes"; then
++ PROVIDER_SUBDIRS="$PROVIDER_SUBDIRS gypsy"
++ else
++ NO_BUILD_PROVIDERS="$NO_BUILD_PROVIDERS gypsy"
++ fi
+ else
+- NO_BUILD_PROVIDERS="$NO_BUILD_PROVIDERS gypsy"
++ have_gypsy=no
++fi
++
++if test "x$enable_gypsy" = "xyes" -a "x$have_gypsy" != "xyes"; then
++ AC_MSG_ERROR([Couldn't find gypsy dependencies.])
+ fi
+ AC_SUBST(GYPSY_LIBS)
+ AC_SUBST(GYPSY_CFLAGS)
+
+-AC_CHECK_LIB(gps, gps_open,[libgps=yes] )
+-if test "x$libgps" = xyes; then
+- PROVIDER_SUBDIRS="$PROVIDER_SUBDIRS gpsd"
+- GPSD_LIBS="-lgps"
++AC_ARG_ENABLE(gpsd,
++ AS_HELP_STRING([--enable-gpsd=@<:@no/yes/auto@:>@],
++ [build with gpsd support]), ,
++ enable_gpsd=auto)
++
++if test "x$enable_gpsd" != "xno"; then
++ AC_CHECK_LIB(gps, gps_open,[libgps=yes] )
++ if test "x$have_gpsd" = "xyes"; then
++ PROVIDER_SUBDIRS="$PROVIDER_SUBDIRS gpsd"
++ GPSD_LIBS="-lgps"
++ else
++ NO_BUILD_PROVIDERS="$NO_BUILD_PROVIDERS gpsd"
++ fi
+ else
+- NO_BUILD_PROVIDERS="$NO_BUILD_PROVIDERS gpsd"
++ have_gpsd=no
++fi
++
++if test "x$enable_gpsd" = "xyes" -a "x$have_gpsd" != "xyes"; then
++ AC_MSG_ERROR([Couldn't find gpsd dependencies.])
+ fi
+ AC_SUBST(GPSD_LIBS)
+ AC_SUBST(GPSD_CFLAGS)
+--
+1.6.3.1
+
diff --git a/gnome-extra/geoclue/files/0002-Fix-NM-pkgcheck.patch b/gnome-extra/geoclue/files/0002-Fix-NM-pkgcheck.patch
new file mode 100644
index 0000000..bd03196
--- /dev/null
+++ b/gnome-extra/geoclue/files/0002-Fix-NM-pkgcheck.patch
@@ -0,0 +1,25 @@
+From a8b2cf000d91a8ede9f22b1bfd3bbf7845f5e933 Mon Sep 17 00:00:00 2001
+From: Mikel Olasagasti Uranga <mikel@olasagasti.info>
+Date: Mon, 22 Jun 2009 19:14:09 +0200
+Subject: [PATCH 2/2] Fix NM pkgcheck
+
+---
+ configure.ac | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 8e5e67c..94847f0 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -122,7 +122,7 @@ AC_ARG_ENABLE(networkmanager,
+ enable_networkmanager=auto)
+
+ if test "x$enable_networkmanager" != "xno"; then
+- PKG_CHECK_MODULES(NETWORKMANAGER,
++ PKG_CHECK_MODULES(NETWORK_MANAGER,
+ [
+ NetworkManager
+ ], have_networkmanager="yes", have_networkmanager="no")
+--
+1.6.3.1
+
diff --git a/gnome-extra/geoclue/geoclue-0.11.1.ebuild b/gnome-extra/geoclue/geoclue-0.11.1.ebuild
new file mode 100644
index 0000000..14c24d4
--- /dev/null
+++ b/gnome-extra/geoclue/geoclue-0.11.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit autotools
+
+DESCRIPTION="A modular geoinformation service built on top of the D-Bus messaging system"
+HOMEPAGE="http://freedesktop.org/wiki/Software/GeoClue"
+SRC_URI="http://folks.o-hand.com/jku/geoclue-releases/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="dbus doc gpsd gtk networkmanager"
+
+RDEPEND=">=dev-libs/glib-2
+ >=gnome-base/gconf-2
+ >=dev-libs/dbus-glib-0.60
+ dev-libs/libxml2
+ gpsd? ( sci-geosciences/gpsd )
+ gtk? ( >=x11-libs/gtk+-2 )
+ networkmanager? ( net-misc/networkmanager )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-libs/libxslt
+ doc? ( >=dev-util/gtk-doc )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Remove automagic deps b.fd.o #22416
+ epatch "${FILESDIR}/0001-Remove-automagic-deps-and-add-switches-to-enable-dis.patch"
+ epatch "${FILESDIR}/0002-Fix-NM-pkgcheck.patch"
+
+ eautoreconf
+}
+
+src_compile() {
+ # gross hack to make it build
+ LDFLAGS=""
+ econf --disable-conic --disable-gypsy --disable-gsmloc \
+ $(use_enable gpsd) \
+ $(use_enable gtk) \
+ $(use_enable networkmanager) || die "econf failed"
+ emake || die "Make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README || die "dodoc failed"
+}