summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Ochotnicky <sochotnicky@gentoo.org>2010-04-20 19:42:10 +0200
committerStanislav Ochotnicky <sochotnicky@gentoo.org>2010-04-20 22:15:04 +0200
commit9743226f9500b356a18f84d3f476981dc5ab64f0 (patch)
treeb70f31a29093765af687ca788c1460b5c97bd575
parentAdded net-p2p/deluge-1.2.3 (diff)
downloadsochotnicky-9743226f9500b356a18f84d3f476981dc5ab64f0.tar.gz
sochotnicky-9743226f9500b356a18f84d3f476981dc5ab64f0.tar.bz2
sochotnicky-9743226f9500b356a18f84d3f476981dc5ab64f0.zip
Added net-p2p/gift
-rw-r--r--net-p2p/gift/Manifest6
-rw-r--r--net-p2p/gift/files/gift.confd22
-rw-r--r--net-p2p/gift/files/gift.initd35
-rw-r--r--net-p2p/gift/gift-0.11.8.1-r1.ebuild64
-rw-r--r--net-p2p/gift/metadata.xml14
5 files changed, 141 insertions, 0 deletions
diff --git a/net-p2p/gift/Manifest b/net-p2p/gift/Manifest
new file mode 100644
index 0000000..0879443
--- /dev/null
+++ b/net-p2p/gift/Manifest
@@ -0,0 +1,6 @@
+AUX gift.confd 637 RMD160 23251f99424964430cceeaa7e2f3636ca69b2149 SHA1 cc52831746c2b33bee4fd60467ea598a805a8b78 SHA256 a35d8ab4b3b1e63dd7fc40d21bd77eada4da0fc03fb7e84c0fa378787a9dc218
+AUX gift.initd 828 RMD160 2e38a6d80c05a966dd018ddc62dce639864651bf SHA1 f386a0b2ff31197102405ee83baa069833fa6eec SHA256 31b5c6bccba5805935addf2d57d4d0f27a12535246399df0dc9fa51a2ad040c8
+DIST gift-0.11.8.1.tar.bz2 541446 RMD160 cef5fe571eff21a61219ce40501652c7b1997a02 SHA1 eda16a9abead7552859679696605f7e7350b0bb2 SHA256 7b22e6d36482119a0d2dfd3e911a208439be32f554919536629b4c7c22ea5882
+EBUILD gift-0.11.8.1-r1.ebuild 1944 RMD160 b81c655a4aaae6364bdfe0bee44af3a99dde368e SHA1 0fc746efe4770bac7e2f5dfe54acd733ea41c4fc SHA256 425bb1ca98f293e0759876ce35b892e649fd3d0083c910d3e654f6b4948a71ab
+MISC ChangeLog 6182 RMD160 8f0a2fa677a36807cb218fe385e410a357bbf3b0 SHA1 2dc58f30042624e904b2127229bf574bb04f125b SHA256 6f41896f6527d433e18fa5039fdca42e7fabce3f59af33d419a6af97a7204f7d
+MISC metadata.xml 466 RMD160 d97134e2f8635888bae49d5dfa5d48e00238df9e SHA1 947c7b498788589f707c91da9d9a6f1f5e0c96a4 SHA256 dba84e3d0a6dc35e46c7ae504c7982b5fbe5e71586ab93d285b7cae720bea1f9
diff --git a/net-p2p/gift/files/gift.confd b/net-p2p/gift/files/gift.confd
new file mode 100644
index 0000000..52d5a99
--- /dev/null
+++ b/net-p2p/gift/files/gift.confd
@@ -0,0 +1,22 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift/files/gift.confd,v 1.4 2005/09/16 23:32:20 mkay Exp $
+
+# /etc/conf.d/gift
+# Config file for gift control script
+
+# Change the following vars only if you know
+# what you're doing, there's no checking for
+# invalid data yet!
+
+# owner of giFTd process (don't change, must be existing)
+USER="p2p"
+
+# directory with configuration
+LOCAL_DIR="/usr/share/giFT"
+
+# logfile (/dev/null for nowhere)
+LOG="/var/log/giftd.log"
+
+# nice level, 0<x<19, more nice -> less cpuspeed consumed
+NICE="19"
diff --git a/net-p2p/gift/files/gift.initd b/net-p2p/gift/files/gift.initd
new file mode 100644
index 0000000..a03a768
--- /dev/null
+++ b/net-p2p/gift/files/gift.initd
@@ -0,0 +1,35 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift/files/gift.initd,v 1.7 2006/04/19 02:10:48 squinky86 Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting giFTd"
+ start-stop-daemon --quiet --start -c ${USER} --make-pidfile \
+ --pidfile /var/run/giftd.pid --exec /usr/bin/giftd \
+ --nicelevel ${NICE} -- \
+ --local-dir=${LOCAL_DIR} &>${LOG} &
+ result=$?
+ sleep 1
+ [ -z "`pgrep -u ${USER} giftd`" ] && result=1
+ if [ $result -eq 1 ]; then
+ eerror "Failed to start gift. Check ${LOG} for more information"
+ fi;
+ eend $result
+}
+
+stop() {
+ ebegin "Stopping giFTd - please wait"
+ start-stop-daemon --stop --quiet --pidfile /var/run/giftd.pid
+ eend $?
+}
+
+restart() {
+ svc_stop
+ sleep 10
+ svc_start
+}
diff --git a/net-p2p/gift/gift-0.11.8.1-r1.ebuild b/net-p2p/gift/gift-0.11.8.1-r1.ebuild
new file mode 100644
index 0000000..78ef43e
--- /dev/null
+++ b/net-p2p/gift/gift-0.11.8.1-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift/gift-0.11.8.1-r1.ebuild,v 1.8 2007/05/24 19:47:06 opfer Exp $
+
+inherit eutils libtool
+
+DESCRIPTION="A OpenFT, Gnutella and FastTrack p2p network daemon"
+HOMEPAGE="http://gift.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+IUSE="ares fasttrack gnutella imagemagick openft vorbis"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ~ppc sparc x86 ~x86-fbsd"
+
+DEPEND=">=sys-libs/zlib-1.1.4
+ sys-apps/file
+ imagemagick? ( >=media-gfx/imagemagick-5.5.7.15 )
+ vorbis? ( >=media-libs/libvorbis-1 )"
+PDEPEND="ares? ( net-p2p/gift-ares )
+ fasttrack? ( net-p2p/gift-fasttrack )
+ gnutella? ( net-p2p/gift-gnutella )
+ openft? ( net-p2p/gift-openft )"
+
+GIFTUSER="p2p"
+
+pkg_preinst() {
+ # Add a new user
+ enewuser ${GIFTUSER} -1 /bin/bash /home/p2p users
+}
+
+src_compile() {
+ econf --enable-libmagic \
+ `use_enable imagemagick` \
+ `use_enable vorbis libvorbis` || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "Install failed"
+
+ # init scripts for users who want a central server
+ newconfd ${FILESDIR}/gift.confd gift
+ newinitd ${FILESDIR}/gift.initd gift
+
+ touch ${D}/usr/share/giFT/giftd.log
+ chown ${GIFTUSER}:root ${D}/usr/share/giFT/giftd.log
+}
+
+pkg_postinst() {
+ elog "Configure gift in /usr/share/giFT/ or run gift-setup"
+ elog "as normal user and make:"
+ elog 'cp -R $HOME/.giFT/* /usr/share/giFT/'
+ elog "chown -R p2p:root /usr/share/giFT/*"
+ elog "(be carefull while specyfing directories in gift-setup;"
+ elog "keep in mind that giFT will run as process of user "
+ elog 'specified in /etc/conf.d/gift with his $HOME directory)'
+ echo
+ elog "Also, if you will be using the giFT init script, you"
+ elog "will need to create /usr/share/giFT/giftd.conf"
+ elog "This method is only recommended for users with a"
+ elog "central giFT server."
+ echo
+}
diff --git a/net-p2p/gift/metadata.xml b/net-p2p/gift/metadata.xml
new file mode 100644
index 0000000..58abf52
--- /dev/null
+++ b/net-p2p/gift/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-p2p</herd>
+ <maintainer>
+ <email>net-p2p@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="ares">pull in Ares plugin</flag>
+ <flag name="fasttrack">pull in FastTrack plugin</flag>
+ <flag name="gnutella">pull in Gnutella plugin</flag>
+ <flag name="openft">pull in OpenFT plugin</flag>
+ </use>
+</pkgmetadata>