summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Sennhauser <sera@gentoo.org>2013-12-23 15:45:31 +0100
committerRalph Sennhauser <sera@gentoo.org>2013-12-23 15:45:31 +0100
commitaa90a47e876f1e4dc1528b217418a4a252827ecc (patch)
tree6348da4c64d740a973c5fd5db177d0d2d3cb43a3
parentMask use wayland for e18, required version not yet in tree (diff)
downloadsera-aa90a47e876f1e4dc1528b217418a4a252827ecc.tar.gz
sera-aa90a47e876f1e4dc1528b217418a4a252827ecc.tar.bz2
sera-aa90a47e876f1e4dc1528b217418a4a252827ecc.zip
Add ebuild for x11-wm/enlightenment (e18)
Package-Manager: portage-2.2.7 Manifest-Sign-Key: 3C5CF75A
-rw-r--r--x11-wm/enlightenment/Manifest15
-rw-r--r--x11-wm/enlightenment/enlightenment-0.18.0.ebuild90
-rw-r--r--x11-wm/enlightenment/files/gentoo-sysactions.conf76
-rw-r--r--x11-wm/enlightenment/metadata.xml65
4 files changed, 246 insertions, 0 deletions
diff --git a/x11-wm/enlightenment/Manifest b/x11-wm/enlightenment/Manifest
new file mode 100644
index 0000000..8b5484a
--- /dev/null
+++ b/x11-wm/enlightenment/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+DIST enlightenment-0.18.0.tar.bz2 27615555 SHA256 462045795f624e0639bf064135441c2f4b1104b7a0f39616dd8a7c490532a317 SHA512 e61f55f10e4b916c8797c1787f11c83ee2139c6c637680782a4e43058adf5576fb29e3b61e4e82ade6528e5a06ea09339e33b877d98911eaeaa786e804f52483 WHIRLPOOL 270f1b1a525e37bc6e36653e2b0f0206db29161126c046b539d3cada1ee72b2ab39dd2254730b5deb44c7ad0c55972f2c8a31e06011fd69320fb0f44243ddedb
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.22 (GNU/Linux)
+
+iQEcBAEBCAAGBQJSuEyLAAoJELjwI6Q8XPdaCbIIAJcKmU2bWvNWV26ewUi3Cq0o
+i1i0BbPM/jh6+ro7HZKdvWEHJSSlmUARhxESfXgkEXzaZVbQ1tXdwh7lyzZYppWf
+EYmUkBQsBwJ8ZXC9hQzTddU43jf1EE4HifQH6pBj9QV9akeuPXOi0h6Nb3yBmofz
+B7qRIn9HwyaV8bAjx/V3ueXH64dP/P/JlNloM3IatHXqDIsjL7jLLbOvz1OXAHiu
+bqTfDWmNHyu977o6vXvpMCbwQvcZcSZiIVtfwm+/MOVecTcav0ZQoFTyqxnOMXOu
+QLpFzbN1z0vWD+z1wAh5Qv0KOHU2Fi09utyBcvsrj7uRmGiHC6qyk4u+OfAeDZM=
+=g01O
+-----END PGP SIGNATURE-----
diff --git a/x11-wm/enlightenment/enlightenment-0.18.0.ebuild b/x11-wm/enlightenment/enlightenment-0.18.0.ebuild
new file mode 100644
index 0000000..3ba1f71
--- /dev/null
+++ b/x11-wm/enlightenment/enlightenment-0.18.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Enlightenment DR17 window manager"
+HOMEPAGE="http://www.enlightenment.org/"
+SRC_URI="http://download.enlightenment.org/rel/apps/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0.17/0.18"
+
+E_MODULES_DEFAULT=(
+ conf-applications conf-bindings conf-comp conf-dialogs conf-display
+ conf-interaction conf-intl conf-menus conf-paths conf-performance
+ conf-randr conf-shelves conf-theme conf-window-manipulation
+ conf-window-remembers
+
+ appmenu backlight battery bluez4 clock connman contact cpufreq everything
+ fileman fileman-opinfo gadman ibar ibox mixer msgbus music-control
+ notification pager quickaccess shot start syscon systray tasks teamwork
+ temperature tiling winlist wizard xkbswitch
+)
+E_MODULES=(
+ conf-wallpaper2
+
+ access illume2 wl-desktop-shell wl-screenshot
+)
+IUSE_E_MODULES=(
+ "${E_MODULES_DEFAULT[@]/#/+enlightenment_modules_}"
+ "${E_MODULES[@]/#/enlightenment_modules_}"
+)
+IUSE="doc egl nls pam static-libs systemd +udev ukit wayland ${IUSE_E_MODULES[@]}"
+
+RDEPEND="
+ >=dev-libs/efl-1.8.1[X,egl?,wayland?]
+ >=media-libs/elementary-1.8.0
+ virtual/udev
+ x11-libs/xcb-util-keysyms
+ enlightenment_modules_mixer? ( >=media-libs/alsa-lib-1.0.8 )
+ nls? ( sys-devel/gettext )
+ pam? ( sys-libs/pam )
+ systemd? ( sys-apps/systemd )
+ wayland? (
+ >=dev-libs/wayland-1.3.0
+ >=x11-libs/pixman-0.31.1
+ >=x11-libs/libxkbcommon-0.3.1
+ )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ local config=(
+ --disable-install-sysactions
+ --disable-device-hal
+ --enable-conf
+ --enable-enlightenment-menu
+ --enable-device-udev
+ --enable-enotify
+ --enable-files
+ $(use_enable doc)
+ $(use_enable egl wayland-egl)
+ $(use_enable nls)
+ $(use_enable pam)
+ $(use_enable static-libs static)
+ $(use_enable systemd)
+ $(use_enable udev mount-eeze)
+ $(use_enable ukit mount-udisks)
+ $(use_enable wayland wayland-clients)
+ )
+
+ local i
+ for i in ${E_MODULES_DEFAULT} ${E_MODULES}; do
+ config+=( $(use_enable enlightenment_modules_${i} ${i}) )
+ done
+
+ econf "${config[@]}"
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ insinto /etc/enlightenment
+ newins "${FILESDIR}"/gentoo-sysactions.conf sysactions.conf
+}
diff --git a/x11-wm/enlightenment/files/gentoo-sysactions.conf b/x11-wm/enlightenment/files/gentoo-sysactions.conf
new file mode 100644
index 0000000..fe67623
--- /dev/null
+++ b/x11-wm/enlightenment/files/gentoo-sysactions.conf
@@ -0,0 +1,76 @@
+# ENLIGHTENMENT SYSTEM ACTIONS CONFIGURATION
+#
+# This is a system configuration for allowing or denying certain users or
+# groups to be able to do certain actions that involve system restricted
+# actions such as halt, reboot, suspend, hibernate etc.
+#
+# This file is read in order from top to bottom - the first rule to MATCH
+# will be used for a user or a group, and nothing after that is read.
+#
+# You must put all the ACTION definitons BEFORE user and group rule matches.
+# Any action definitons after a rule match has been found will be ignored.
+# This allows actions to be re-defined for different user groups, so matches
+# so the command for an action can change for matches to the rules later on.
+#
+# Any user or group NOT matched by an allow or a deny will be ALLOWED to
+# perform the action by default (system administrators should be aware of
+# this and implement whatever policies they see fit). Generally speaking
+# a user of a workstation, desktop or laptop is intended to have such abilities
+# to perform these actions, thus the default of allow. For multi-user systems
+# the system administrator is considerd capable enough to restrict what they
+# see they need to.
+#
+# A WARNING to admins: do NOT allow access for users to this system remotely
+# UNLESS you fully trust them or you have locked down permissions to halt/reboot
+# suspend etc. here first. You have been warned.
+#
+# FORMAT:
+#
+# action: halt /sbin/shutdown -h now
+# action: reboot /sbin/shutdown -r now
+# action: suspend /etc/acpi/sleep.sh force
+# action: hibernate /etc/acpi/hibernate.sh force
+#
+# user: username allow: halt reboot suspend hibernate
+# group: groupname deny: *
+# group: * deny: *
+# user: * allow: suspend
+# user: billy allow: halt reboot
+# group: staff deny: halt suspend hibernate
+#
+# etc.
+#
+# user and group name can use glob matches (* == all for example) like the
+# shell. as can action names allowed or denied.
+
+action: halt /sbin/shutdown -h now
+action: reboot /sbin/shutdown -r now
+action: suspend /usr/sbin/pm-suspend
+action: hibernate /usr/sbin/pm-hibernate
+
+# on FreeBSD use this instead of the above.
+#action suspend /usr/sbin/zzz
+
+# root is allowed to do anything - but it needs to be here explicitly anyway
+user: root allow: *
+# members of operator, staff and admin groups should be able to do all
+group: operator allow: *
+group: staff allow: *
+group: admin allow: *
+group: sys allow: *
+group: wheel allow: *
+# common "user" groups for "console users" on desktops/laptops
+group: dialout allow: *
+group: disk allow: *
+group: adm allow: *
+group: cdrom allow: *
+group: floppy allow: *
+group: audio allow: *
+group: dip allow: *
+group: plugdev allow: *
+# put in a list of other users and groups here that are allowed or denied etc.
+# e.g.
+# user: myuser allow: *
+# user: another allow: suspend hibernate
+# deny everyone else by default
+user: * deny: *
diff --git a/x11-wm/enlightenment/metadata.xml b/x11-wm/enlightenment/metadata.xml
new file mode 100644
index 0000000..206b500
--- /dev/null
+++ b/x11-wm/enlightenment/metadata.xml
@@ -0,0 +1,65 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>sera@gentoo.org</email>
+ <name>Ralph Sennhauser</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+ <use>
+ <flag name="egl"></flag>
+ <flag name="ukit"></flag>
+ <flag name="enlightenment_modules_conf-applications"></flag>
+ <flag name="enlightenment_modules_conf-bindings"></flag>
+ <flag name="enlightenment_modules_conf-comp"></flag>
+ <flag name="enlightenment_modules_conf-dialogs"></flag>
+ <flag name="enlightenment_modules_conf-display"></flag>
+ <flag name="enlightenment_modules_conf-interaction"></flag>
+ <flag name="enlightenment_modules_conf-intl"></flag>
+ <flag name="enlightenment_modules_conf-menus"></flag>
+ <flag name="enlightenment_modules_conf-paths"></flag>
+ <flag name="enlightenment_modules_conf-performance"></flag>
+ <flag name="enlightenment_modules_conf-randr"></flag>
+ <flag name="enlightenment_modules_conf-shelves"></flag>
+ <flag name="enlightenment_modules_conf-theme"></flag>
+ <flag name="enlightenment_modules_conf-window-manipulation"></flag>
+ <flag name="enlightenment_modules_conf-window-remembers"></flag>
+ <flag name="enlightenment_modules_appmenu"></flag>
+ <flag name="enlightenment_modules_backlight"></flag>
+ <flag name="enlightenment_modules_battery"></flag>
+ <flag name="enlightenment_modules_bluez4"></flag>
+ <flag name="enlightenment_modules_clock"></flag>
+ <flag name="enlightenment_modules_connman"></flag>
+ <flag name="enlightenment_modules_contact"></flag>
+ <flag name="enlightenment_modules_cpufreq"></flag>
+ <flag name="enlightenment_modules_everything"></flag>
+ <flag name="enlightenment_modules_fileman"></flag>
+ <flag name="enlightenment_modules_fileman-opinfo"></flag>
+ <flag name="enlightenment_modules_gadman"></flag>
+ <flag name="enlightenment_modules_ibar"></flag>
+ <flag name="enlightenment_modules_ibox"></flag>
+ <flag name="enlightenment_modules_mixer"></flag>
+ <flag name="enlightenment_modules_msgbus"></flag>
+ <flag name="enlightenment_modules_music-control"></flag>
+ <flag name="enlightenment_modules_notification"></flag>
+ <flag name="enlightenment_modules_pager"></flag>
+ <flag name="enlightenment_modules_quickaccess"></flag>
+ <flag name="enlightenment_modules_shot"></flag>
+ <flag name="enlightenment_modules_start"></flag>
+ <flag name="enlightenment_modules_syscon"></flag>
+ <flag name="enlightenment_modules_systray"></flag>
+ <flag name="enlightenment_modules_tasks"></flag>
+ <flag name="enlightenment_modules_teamwork"></flag>
+ <flag name="enlightenment_modules_temperature"></flag>
+ <flag name="enlightenment_modules_tiling"></flag>
+ <flag name="enlightenment_modules_winlist"></flag>
+ <flag name="enlightenment_modules_wizard"></flag>
+ <flag name="enlightenment_modules_xkbswitch"></flag>
+ <flag name="enlightenment_modules_conf-wallpaper2"></flag>
+ <flag name="enlightenment_modules_access"></flag>
+ <flag name="enlightenment_modules_illume2"></flag>
+ <flag name="enlightenment_modules_wl-desktop-shell"></flag>
+ <flag name="enlightenment_modules_wl-screenshot"></flag>
+ </use>
+</pkgmetadata>