summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-06-03 00:07:31 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-06-03 00:07:31 -0700
commitefbfb46d6ae4cdcb51f597ad22877466761bb027 (patch)
tree9e09f57edfab742b2bb57db7b39397ea7e843ba1 /app-admin
parentNo ebuild changelog for us (diff)
downloadrobbat2-efbfb46d6ae4cdcb51f597ad22877466761bb027.tar.gz
robbat2-efbfb46d6ae4cdcb51f597ad22877466761bb027.tar.bz2
robbat2-efbfb46d6ae4cdcb51f597ad22877466761bb027.zip
Add my local stuff again.
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/euca2ools/Manifest2
-rw-r--r--app-admin/euca2ools/euca2ools-1.3.1.ebuild71
-rw-r--r--app-admin/euca2ools/euca2ools-2.1.3.ebuild71
3 files changed, 144 insertions, 0 deletions
diff --git a/app-admin/euca2ools/Manifest b/app-admin/euca2ools/Manifest
new file mode 100644
index 0000000..3861cef
--- /dev/null
+++ b/app-admin/euca2ools/Manifest
@@ -0,0 +1,2 @@
+DIST euca2ools-1.3.1.tar.gz 6588 SHA256 4beaefec2673baef0c99698ee761fecb79b8ab4487ddedc3a90ebd8ac4698062 SHA512 a1dab0d50d5c1d6bcb701be756aa967362246b3508657aee3b143a089f965dd980d89229f2320b76505727d1e2ff63c5886ca3666d892c6f66578438e0a7b93a WHIRLPOOL 22c2a64b3c41503b5abfa6c9f3b6610326624fc426966f3801c398f887d75174c2b1d8f85ac72b72347768732ab954bc9554db173eb7aca7bdead59191a4c208
+DIST euca2ools-2.1.3.tar.gz 97006 SHA256 1a20b7f9ca3e08c9ab32b34103d94e19be10e0a7b9eff1b0dc4013541bb7b321 SHA512 83eac8d46ad36572f837f8b7cc4e4fc7aa28b4635fd8aed42cd71858dbcb37320d2d67d72bc469a2577ec5e21404984f703350daa4dc57391aab3c01a30e02e9 WHIRLPOOL 5d7130356b971f1cac1f49613168a083cfb4e913376858c8b4cef8459af1008b71155e2949108d95ba980b77ef9f7b683e65711ade4e85569382be4e4389ba66
diff --git a/app-admin/euca2ools/euca2ools-1.3.1.ebuild b/app-admin/euca2ools/euca2ools-1.3.1.ebuild
new file mode 100644
index 0000000..38f609c
--- /dev/null
+++ b/app-admin/euca2ools/euca2ools-1.3.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+EAPI="4"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Command-line tools for interacting with Amazon EC2 and S3 API-compatible Web services using the REST/Query API"
+HOMEPAGE="http://open.eucalyptus.com"
+SRC_URI="http://open.eucalyptus.com/sites/all/modules/pubdlcnt/pubdlcnt.php?file=http://eucalyptussoftware.com/downloads/releases/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc64"
+IUSE=""
+DEPEND=">=dev-python/boto-1.9d
+ >=dev-lang/python-2.5
+ >=dev-python/m2crypto-0.19.1"
+
+RDEPEND="${DEPEND}"
+
+DOCS="${S}/COPYING
+ ${S}/CHANGELOG
+ ${S}/README
+ ${S}/INSTALL"
+
+src_compile() {
+ emake build || die "emake failed"
+}
+
+src_install() {
+ cd "${S}/euca2ools"
+ distutils_src_install
+ cd "${S}/bin"
+ for tool in *; do
+ newbin ${tool} ${tool}
+ done
+
+ # Install the manpages
+ if [[ -d ${S}/man ]]; then
+ doman ${S}/man/* || die "doman"
+ fi
+}
+
+pkg_postinst(){
+ einfo ""
+ einfo " Euca2ools use cryptographic credentials for authentication. Two
+ types of credentials are issued by EC2- and S3-compatible services: x509
+ certificates and keys. While some commands only require the latter, it is
+ best to always specify both types of credentials."
+
+ einfo ""
+ einfo " Furthermore, unless the front end Web services reside on
+ 'localhost', the URLs of the EC2- and S3-compatible service endpoints must
+ also be specified."
+ einfo ""
+ einfo "If you are running Euca2ools against Eucalyptus, sourcing the
+ \"eucarc\" file that is included as part of the credentials zip-file that
+ you downloaded from the Eucalyptus Web interface should be enough to set up
+ all of the above variables correctly."
+ einfo ""
+ einfo "For more information please refer to the:"
+ einfo " * --help option of the individual commands,"
+ einfo " * check the man pages for each command,"
+ einfo " * consult the local documentation at /usr/share/doc/$P,"
+ einfo " *consult http://open.eucalyptus.com/wiki/Documentation."
+ einfo ""
+}
diff --git a/app-admin/euca2ools/euca2ools-2.1.3.ebuild b/app-admin/euca2ools/euca2ools-2.1.3.ebuild
new file mode 100644
index 0000000..15116ff
--- /dev/null
+++ b/app-admin/euca2ools/euca2ools-2.1.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+EAPI="4"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Command-line tools for interacting with Amazon EC2 and S3 API-compatible Web services using the REST/Query API"
+HOMEPAGE="http://open.eucalyptus.com"
+SRC_URI="https://github.com/eucalyptus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc64"
+IUSE=""
+DEPEND=">=dev-python/boto-1.9d
+ >=dev-lang/python-2.5
+ >=dev-python/m2crypto-0.19.1"
+
+RDEPEND="${DEPEND}"
+
+DOCS="${S}/COPYING
+ ${S}/CHANGELOG
+ ${S}/README
+ ${S}/INSTALL"
+
+src_compile() {
+ distutils_src_compile
+ #emake build || die "emake failed"
+}
+
+src_install() {
+ distutils_src_install
+ cd "${S}/bin"
+ for tool in *; do
+ newbin ${tool} ${tool}
+ done
+
+ # Install the manpages
+ if [[ -d ${S}/man ]]; then
+ doman ${S}/man/* || die "doman"
+ fi
+}
+
+pkg_postinst(){
+ einfo ""
+ einfo " Euca2ools use cryptographic credentials for authentication. Two
+ types of credentials are issued by EC2- and S3-compatible services: x509
+ certificates and keys. While some commands only require the latter, it is
+ best to always specify both types of credentials."
+
+ einfo ""
+ einfo " Furthermore, unless the front end Web services reside on
+ 'localhost', the URLs of the EC2- and S3-compatible service endpoints must
+ also be specified."
+ einfo ""
+ einfo "If you are running Euca2ools against Eucalyptus, sourcing the
+ \"eucarc\" file that is included as part of the credentials zip-file that
+ you downloaded from the Eucalyptus Web interface should be enough to set up
+ all of the above variables correctly."
+ einfo ""
+ einfo "For more information please refer to the:"
+ einfo " * --help option of the individual commands,"
+ einfo " * check the man pages for each command,"
+ einfo " * consult the local documentation at /usr/share/doc/$P,"
+ einfo " *consult http://open.eucalyptus.com/wiki/Documentation."
+ einfo ""
+}