summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Brown <rbrown@gentoo.org>2007-09-18 15:52:26 +0000
committerRichard Brown <rbrown@gentoo.org>2007-09-18 15:52:26 +0000
commit5e6d31015960fc67f073441d37cf668a546475d9 (patch)
tree4a105749c7ca8a7fe3a340cdf6436a7411ab5745
parentAdd ruby-mmap (diff)
downloadrbrown-5e6d31015960fc67f073441d37cf668a546475d9.tar.gz
rbrown-5e6d31015960fc67f073441d37cf668a546475d9.tar.bz2
rbrown-5e6d31015960fc67f073441d37cf668a546475d9.zip
Lazy ruby mmap ebuild
svn path=/; revision=45
-rw-r--r--dev-ruby/ruby-mmap/files/ruby-mmap-0.2.6-oniguruma_rb_reg_regsub.patch20
-rw-r--r--dev-ruby/ruby-mmap/ruby-mmap-0.2.6.ebuild10
2 files changed, 29 insertions, 1 deletions
diff --git a/dev-ruby/ruby-mmap/files/ruby-mmap-0.2.6-oniguruma_rb_reg_regsub.patch b/dev-ruby/ruby-mmap/files/ruby-mmap-0.2.6-oniguruma_rb_reg_regsub.patch
new file mode 100644
index 0000000..6b5160b
--- /dev/null
+++ b/dev-ruby/ruby-mmap/files/ruby-mmap-0.2.6-oniguruma_rb_reg_regsub.patch
@@ -0,0 +1,20 @@
+--- mmap.c.orig Thu Feb 1 14:52:50 2007
++++ mmap.c Thu Feb 1 14:55:16 2007
+@@ -1113,7 +1113,7 @@
+ }
+ else {
+ RSTRING(str)->ptr += start;
+- repl = rb_reg_regsub(repl, str, regs);
++ repl = rb_reg_regsub(repl, str, regs, pat);
+ RSTRING(str)->ptr -= start;
+ }
+ if (OBJ_TAINTED(repl)) tainted = 1;
+@@ -1211,7 +1211,7 @@
+ }
+ else {
+ RSTRING(str)->ptr += start;
+- val = rb_reg_regsub(repl, str, regs);
++ val = rb_reg_regsub(repl, str, regs, pat);
+ RSTRING(str)->ptr -= start;
+ }
+ if (OBJ_TAINTED(repl)) tainted = 1;
diff --git a/dev-ruby/ruby-mmap/ruby-mmap-0.2.6.ebuild b/dev-ruby/ruby-mmap/ruby-mmap-0.2.6.ebuild
index 10a71be..e02196d 100644
--- a/dev-ruby/ruby-mmap/ruby-mmap-0.2.6.ebuild
+++ b/dev-ruby/ruby-mmap/ruby-mmap-0.2.6.ebuild
@@ -21,7 +21,15 @@ DEPEND=">=dev-lang/ruby-1.8"
S=${WORKDIR}/${MY_P}
-src_compile() {
+src_unpack() {
+ unpack ${A}
+
+ if built_with_use dev-lang/ruby cjk; then
+ cd "${S}"
+ epatch "${FILESDIR}/ruby-mmap-0.2.6-oniguruma_rb_reg_regsub.patch"
+ fi
+}
+src_compile() {
ruby_src_compile all rdoc || die
}