summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/adodb/adodb-5.14.ebuild')
-rw-r--r--dev-php/adodb/adodb-5.14.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-php/adodb/adodb-5.14.ebuild b/dev-php/adodb/adodb-5.14.ebuild
new file mode 100644
index 0000000..77480ec
--- /dev/null
+++ b/dev-php/adodb/adodb-5.14.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/adodb/adodb-5.11.ebuild,v 1.5 2011/03/30 19:18:54 xmw Exp $
+
+EAPI="2"
+
+inherit php-lib-r1 versionator
+
+MY_PV=$(delete_all_version_separators "${PV}" )
+DESCRIPTION="Active Data Objects Data Base library for PHP."
+HOMEPAGE="http://adodb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/adodb/${PN}${MY_PV}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S=${WORKDIR}/${PN}$(get_major_version)
+
+need_php5
+
+pkg_setup() {
+ ewarn "ADODB requires some form of SQL or ODBC support in your PHP."
+}
+
+src_install() {
+ # install php files
+ php-lib-r1_src_install . $(find . -name '*.php' -print)
+
+ # install xsl files
+ php-lib-r1_src_install . xsl/*.xsl
+
+ # install documentation
+ dodoc-php *.txt xmlschema.dtd session/adodb-sess.txt pear/readme.Auth.txt
+ dohtml-php docs/*.htm
+}