summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2011-05-16 06:07:41 +0000
committerPeter Volkov <pva@gentoo.org>2011-05-16 06:07:41 +0000
commitaef6112bba52b8617cb23446c6a656bf25e76057 (patch)
treec9b2a26b83dd805b33bb9ff4ca93ead1a101d6f6
parentnet-firewall/xtables-addons: version bump. Need newer kernel to test. (diff)
downloadpva-aef6112bba52b8617cb23446c6a656bf25e76057.tar.gz
pva-aef6112bba52b8617cb23446c6a656bf25e76057.tar.bz2
pva-aef6112bba52b8617cb23446c6a656bf25e76057.zip
sys-cluster/vzctl: version bump.
svn path=/; revision=482
-rw-r--r--sys-cluster/vzctl/Manifest2
-rw-r--r--sys-cluster/vzctl/vzctl-3.0.26.3.ebuild83
2 files changed, 85 insertions, 0 deletions
diff --git a/sys-cluster/vzctl/Manifest b/sys-cluster/vzctl/Manifest
index d384573..64366c8 100644
--- a/sys-cluster/vzctl/Manifest
+++ b/sys-cluster/vzctl/Manifest
@@ -1,5 +1,7 @@
AUX vzctl-3.0.26.2-vzeventd.patch 2315 RMD160 ebc24de1454ccdb6375be8562dbde0c0e233ecd0 SHA1 1b52d832b09dfc55e63e9c87324734311f6f27a6 SHA256 1f767c686841f24432ac4e75a9743b41362e096fbb01d99263e82853636c8c9e
DIST vzctl-3.0.26.2.tar.bz2 405656 RMD160 e67c18ccf54b92a12cd7d3470a2fc302869c9d98 SHA1 cbdb995999f96bf2192e820dccad222a0548ee0e SHA256 6533c15c967a294bf7566a2d0c8b486519f11af22d669df518f451510256887f
+DIST vzctl-3.0.26.3.tar.bz2 406377 RMD160 e36f924e8d46f7822125e7737551da46111e1295 SHA1 f95f0aee8592161fc3a4179aac11d694fecd57ee SHA256 2317cde3d5d8604739f78a3ac3b753d1c11f4dcff28390b54eb888bf425b451b
EBUILD vzctl-3.0.26.2-r1.ebuild 2355 RMD160 7eaa93a1e62f4fbc4d3fd37655a2ce6dab5e8f54 SHA1 7be76147664939798d7cce0a1b0a79027de3c03b SHA256 ec4e21bdf9e2047f78217f0fe899f12a82c7c4fdefad830ddc686f5ce427da89
+EBUILD vzctl-3.0.26.3.ebuild 2303 RMD160 a14e7baab124ffb8f624e47ef68c8e3418fed318 SHA1 0cd370e567e695c1646e95514e77dc0b710a481b SHA256 107393ab84f331ea85e7a484f1ea4d85a9fddcaa928f1a45d9dad53111de9698
MISC ChangeLog 15778 RMD160 83b14d646874d98d7f9837a8ff1d4f586cd6c949 SHA1 99be2147cf37e7e362d9edfde4bb7e6ac2649318 SHA256 ce0aa0d4e66d73a556e1663e78084eee2075ffa7d18f2ec41db3ef163678f3f9
MISC metadata.xml 250 RMD160 859a9aa257ba731f151779434edc614d186d86cf SHA1 0e65923b7b0996ac7e063048e2fe5814453407b7 SHA256 70752023c9e02de0ce3540c4c09bc3256c72568be427bb5c7e9886745b5d2215
diff --git a/sys-cluster/vzctl/vzctl-3.0.26.3.ebuild b/sys-cluster/vzctl/vzctl-3.0.26.3.ebuild
new file mode 100644
index 0000000..0d694a4
--- /dev/null
+++ b/sys-cluster/vzctl/vzctl-3.0.26.3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-3.0.26.2.ebuild,v 1.1 2011/03/22 16:28:14 pva Exp $
+
+EAPI="4"
+
+inherit bash-completion eutils
+
+DESCRIPTION="OpenVZ ConTainers control utility"
+HOMEPAGE="http://openvz.org/"
+SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc64 ~sparc ~x86"
+IUSE="bash-completion"
+
+RDEPEND="
+ net-firewall/iptables
+ sys-apps/ed
+ sys-apps/iproute2
+ sys-fs/vzquota"
+
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # Set default OSTEMPLATE on gentoo
+ sed -e 's:=redhat-:=gentoo-:' -i etc/dists/default || die
+}
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --enable-udev \
+ $(use_enable bash-completion bashcomp) \
+ --enable-logrotate
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-gentoo
+
+ # install the bash-completion script into the right location
+ rm -rf "${ED}"/etc/bash_completion.d
+ dobashcompletion etc/bash_completion.d/vzctl.sh vzctl
+
+ # We need to keep some dirs
+ keepdir /vz/{dump,lock,root,private,template/cache}
+ keepdir /etc/vz/names /var/lib/vzctl/veip
+}
+
+pkg_postinst() {
+ bash-completion_pkg_postinst
+ local conf_without_OSTEMPLATE
+ for file in \
+ $(find "${EROOT}/etc/vz/conf/" \( -name *.conf -a \! -name 0.conf \)); do
+ if ! grep '^OSTEMPLATE' $file > /dev/null; then
+ conf_without_OSTEMPLATE+=" $file"
+ fi
+ done
+
+ if [[ -n ${conf_without_OSTEMPLATE} ]]; then
+ ewarn
+ ewarn "OSTEMPLATE default was changed from redhat-like to gentoo."
+ ewarn "This means that any VEID.conf files without explicit or correct"
+ ewarn "OSTEMPLATE set will use gentoo scripts instead of redhat."
+ ewarn "Please check the following configs:"
+ for file in ${conf_without_OSTEMPLATE}; do
+ ewarn "${file}"
+ done
+ ewarn
+ fi
+
+ ewarn "To avoid loosing network to CTs on iface down/up, please, add the"
+ ewarn "following code to /etc/conf.d/net:"
+ ewarn " postup() {"
+ ewarn " /usr/sbin/vzifup-post \${IFACE}"
+ ewarn " }"
+
+ ewarn "Starting with 3.0.25 there is new vzeventd service to reboot CTs."
+ ewarn "Please, drop /usr/share/vzctl/scripts/vpsnetclean and"
+ ewarn "/usr/share/vzctl/scripts/vpsreboot from crontab and use"
+ ewarn "/etc/init.d/vzeventd."
+}