summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/spotify/spotify-0.8.8.323.ebuild')
-rw-r--r--media-sound/spotify/spotify-0.8.8.323.ebuild34
1 files changed, 15 insertions, 19 deletions
diff --git a/media-sound/spotify/spotify-0.8.8.323.ebuild b/media-sound/spotify/spotify-0.8.8.323.ebuild
index f37a6d2..8e244c6 100644
--- a/media-sound/spotify/spotify-0.8.8.323.ebuild
+++ b/media-sound/spotify/spotify-0.8.8.323.ebuild
@@ -69,26 +69,26 @@ src_unpack() {
}
src_prepare() {
-# # link against openssl-1.0.0 as it crashes with 0.9.8
-# sed -i \
-# -e 's/\(lib\(ssl\|crypto\).so\).0.9.8/\1.1.0.0/g' \
-# usr/share/spotify/spotify || die "sed failed"
+ # link against openssl-1.0.0 as it crashes with 0.9.8
+ sed -i \
+ -e 's/\(lib\(ssl\|crypto\).so\).0.9.8/\1.1.0.0/g' \
+ opt/spotify/spotify-client/spotify || die "sed failed"
# different NSPR / NSS library names for some reason
sed -i \
-e 's/\(lib\(nss3\|nssutil3\|smime3\).so\).1d/\1.12/g' \
-e 's/\(lib\(plc4\|nspr4\).so\).0d\(.\)/\1.9\3\3/g' \
opt/spotify/spotify-client/libcef.so || die "sed failed"
-# # Fix desktop entry to launch spotify-dbus.py for GNOME integration
-# if use gnome ; then
-# sed -i \
-# -e 's/spotify \%U/spotify-dbus.py \%U/g' \
-# usr/share/applications/spotify.desktop || die "sed failed"
-# fi
-# #and fix other stuff in the desktop file as well
-# sed -i \
-# -e 's/x-scheme-handler\/spotify$/x-scheme-handler\/spotify\;/g' \
-# -e 's/AudioVideo$/AudioVideo\;/g' \
-# usr/share/applications/spotify.desktop || die "sed failed"
+ # Fix desktop entry to launch spotify-dbus.py for GNOME integration
+ if use gnome ; then
+ sed -i \
+ -e 's/spotify \%U/spotify-dbus.py \%U/g' \
+ opt/spotify/spotify-client/spotify.desktop || die "sed failed"
+ fi
+ #and fix other stuff in the desktop file as well
+ sed -i \
+ -e 's/x-scheme-handler\/spotify$/x-scheme-handler\/spotify\;/g' \
+ -e 's/AudioVideo$/AudioVideo\;/g' \
+ opt/spotify/spotify-client/spotify.desktop || die "sed failed"
}
src_install() {
@@ -101,13 +101,9 @@ src_install() {
# install in /opt/spotify
SPOTIFY_HOME=/opt/spotify/spotify-client
-# dodir ${SPOTIFY_HOME}
insinto ${SPOTIFY_HOME}
doins -r opt/spotify/spotify-client/*
fperms +x ${SPOTIFY_HOME}/spotify
-#
-# dodir /usr/share
-# dosym ${SPOTIFY_HOME} /usr/share/spotify
dodir /usr/bin
cat <<-EOF >"${D}"/usr/bin/spotify