summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <mthode@mthode.org>2012-10-16 20:27:50 -0500
committerMatthew Thode <mthode@mthode.org>2012-10-16 20:27:50 -0500
commitbfac053b5275677634d6b46afc92c45770f6418a (patch)
tree2e1a4d0034adf19e39b90d2a87b158524d5a2284
parentremoving nss-ldapd, changes upstream now (diff)
downloadprometheanfire-bfac053b5275677634d6b46afc92c45770f6418a.tar.gz
prometheanfire-bfac053b5275677634d6b46afc92c45770f6418a.tar.bz2
prometheanfire-bfac053b5275677634d6b46afc92c45770f6418a.zip
add spotify for testing
-rw-r--r--media-sound/spotify/Manifest3
-rw-r--r--media-sound/spotify/spotify-0.8.4.103.ebuild123
2 files changed, 126 insertions, 0 deletions
diff --git a/media-sound/spotify/Manifest b/media-sound/spotify/Manifest
new file mode 100644
index 0000000..037d644
--- /dev/null
+++ b/media-sound/spotify/Manifest
@@ -0,0 +1,3 @@
+DIST spotify-client_0.8.4.103.g9cb177b.260-1_amd64.deb 31702600 SHA256 d350defa4164aaf129985df7e3ca33fc3f88aad2fac1637e6a26cc1794f3b378 SHA512 0f07ff8e2844d3f2626fa02351474a76b0d7178dd94d4d857ff2a0b6d28f887980889e4bc57fab18ab2a0cb6d7771e90bb7a20c2427ab69e2195f5de47ae3622 WHIRLPOOL 7d8a24fdbd9a12e92443264bcb01f27a322028c2074b40cb26e8f0e06195175ae8f369da41cde5d8dbe741792ad3250dc408addf9ceee594f2782a45772817f7
+DIST spotify-client_0.8.4.103.g9cb177b.260-1_i386.deb 28110850 SHA256 61502995da6b126eb6801bf92a8463a7fdd37dc6be0e0aba3560bdadde3531c7 SHA512 b48c70267781dc4b6d5afeee8061a95266de59ae02d252b054cd3a63a8bdcb19a461e7c28095d3884f7e7ff1129778ab7549dda9b891dc107f54182e13725dc2 WHIRLPOOL 0c443030bad393721c964c36561b84eb1388248a47d0dcc2f14541f5a33de4364a2de081e69c8c379e3a4ef529209b76d1f2e14fdaef68631471b414e01ba239
+EBUILD spotify-0.8.4.103.ebuild 3118 SHA256 6964996f6c819c549a5a5fc6b7685289546d1cdd4d6d313925026faa94fd5138 SHA512 873dbf0f59dc7e41ec12e71bce2351f4ad9de82f6e8ac509b3ceb09c15d64d14212c454cb4e8bc0948b7ba34cc26f5c3bfe74951642dc7acbfc1a45b76e8c88b WHIRLPOOL 203263d9dc330156c77f7b3449191fc2ce921c035a7225393348963b73568d064d0678fbaa6bf56f4f3fd7319d988b1a9606744e788198c183d88bb042c8d73b
diff --git a/media-sound/spotify/spotify-0.8.4.103.ebuild b/media-sound/spotify/spotify-0.8.4.103.ebuild
new file mode 100644
index 0000000..0900588
--- /dev/null
+++ b/media-sound/spotify/spotify-0.8.4.103.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+DESCRIPTION="Spotify is a social music platform"
+HOMEPAGE="https://www.spotify.com/ch-de/download/previews/"
+MY_PV="${PV}.g9cb177b.260-1"
+MY_P="${PN}-client_${MY_PV}"
+SRC_BASE="http://repository.spotify.com/pool/non-free/${PN:0:1}/${PN}/"
+#SRC_BASE="http://download.spotify.com/preview/"
+SRC_URI="
+ x86? ( ${SRC_BASE}${MY_P}_i386.deb )
+ amd64? ( ${SRC_BASE}${MY_P}_amd64.deb )
+ "
+LICENSE="Spotify"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pulseaudio gnome"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ x11-libs/libX11
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libXrender
+ x11-libs/libXrandr
+ x11-libs/libXinerama
+ x11-libs/libXext
+ x11-libs/libxcb
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-webkit:4
+ x11-libs/qt-dbus:4
+ x11-libs/libXScrnSaver
+ media-libs/freetype
+ media-libs/fontconfig
+ media-libs/alsa-lib
+ dev-libs/openssl
+ dev-libs/glib:2
+ media-libs/libpng:1.2
+ dev-db/sqlite:3
+ sys-libs/zlib
+ app-arch/bzip2
+ sys-apps/dbus
+ sys-apps/util-linux
+ dev-libs/expat
+ >=dev-libs/nspr-4.9
+ gnome-base/gconf:2
+ x11-libs/gtk+:2
+ dev-libs/nss
+ dev-libs/glib:2
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.21 )
+ gnome? ( gnome-extra/gnome-integration-spotify )"
+
+RESTRICT="mirror strip"
+
+src_unpack() {
+ mkdir "${P}"
+ cd "${P}"
+ unpack ${A}
+ unpack ./data.tar.gz
+}
+
+src_prepare() {
+ # link against openssl-1.0.0 as it crashes with 0.9.8
+ sed -i \
+ -e 's/\(lib\(ssl\|crypto\).so\).0.9.8/\1.1.0.0/g' \
+ usr/share/spotify/spotify || die "sed failed"
+ # different NSPR / NSS library names for some reason
+ sed -i \
+ -e 's/\(lib\(nss3\|nssutil3\|smime3\).so\).1d/\1.12/g' \
+ -e 's/\(lib\(plc4\|nspr4\).so\).0d\(.\)/\1.9\3\3/g' \
+ usr/share/spotify/libcef.so || die "sed failed"
+ # Fix desktop entry to launch spotify-dbus.py for GNOME integration
+ if use gnome ; then
+ sed -i \
+ -e 's/spotify \%U/spotify-dbus.py \%U/g' \
+ usr/share/applications/spotify.desktop || die "sed failed"
+ fi
+}
+
+src_install() {
+ dodoc usr/share/doc/spotify-client/changelog.Debian.gz
+ dodoc usr/share/doc/spotify-client/copyright
+ insinto /usr/share/applications
+ doins usr/share/applications/*.desktop
+ insinto /usr/share/pixmaps
+ doins usr/share/pixmaps/*.png
+
+ # install in /opt/spotify
+ SPOTIFY_HOME=/opt/spotify
+ dodir ${SPOTIFY_HOME}
+ insinto ${SPOTIFY_HOME}
+ doins -r usr/share/spotify/*
+ fperms +x ${SPOTIFY_HOME}/spotify
+ dodir /usr/share
+ dosym ${SPOTIFY_HOME} /usr/share/spotify
+
+ dodir /usr/bin
+ cat <<-EOF >"${D}"/usr/bin/spotify
+ #! /bin/sh
+ LD_PRELOAD="\${LD_PRELOAD} /usr/share/spotify/libcef.so"
+ export LD_PRELOAD
+ exec ${SPOTIFY_HOME}/spotify "\$@"
+ EOF
+ fperms +x /usr/bin/spotify
+
+ # revdep-rebuild produces a false positive because of symbol versioning
+ dodir /etc/revdep-rebuild
+ cat <<-EOF >"${D}"/etc/revdep-rebuild/10${PN}
+ SEARCH_DIRS_MASK="${SPOTIFY_HOME}"
+ EOF
+}
+
+pkg_postinst() {
+ ewarn "If Spotify crashes after an upgrade its cache may be corrupt."
+ ewarn "To remove the cache:"
+ ewarn "rm -rf ~/.cache/spotify"
+}