summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/xlwt/xlwt-0.7.4-r256.ebuild')
-rw-r--r--dev-python/xlwt/xlwt-0.7.4-r256.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/xlwt/xlwt-0.7.4-r256.ebuild b/dev-python/xlwt/xlwt-0.7.4-r256.ebuild
new file mode 100644
index 0000000..b679160
--- /dev/null
+++ b/dev-python/xlwt/xlwt-0.7.4-r256.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header$
+
+EAPI="4"
+
+inherit python-distutils-ng
+
+DESCRIPTION="Python library to create spreadsheet files compatible with Excel"
+HOMEPAGE="http://pypi.python.org/pypi/xlwt"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc-aix ~hppa-hpux ~ia64-hpux ~x86-interix ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND=""
+
+python_prepare_all() {
+ sed -i \
+ -e "s,'doc,# 'doc,g" \
+ -e "s,'exa,# 'exa,g" \
+ setup.py || die
+}
+
+python_install_all() {
+ dohtml xlwt/doc/*.html
+ if use examples; then
+ insinto "/usr/share/doc/${PF}"
+ doins -r xlwt/examples
+ fi
+}