summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <none@none>2012-03-03 19:02:47 +0100
committerKrzysztof Pawlik <none@none>2012-03-03 19:02:47 +0100
commitd2da3fa38c166446de16e6806ea3860d6c461a12 (patch)
tree631b37200d863ee01c07dc9d04ff3c9ae3be03fe
parentRename PACKAGE_SPECIFIC_S. (diff)
downloadnelchael-d2da3fa38c166446de16e6806ea3860d6c461a12.tar.gz
nelchael-d2da3fa38c166446de16e6806ea3860d6c461a12.tar.bz2
nelchael-d2da3fa38c166446de16e6806ea3860d6c461a12.zip
Documentation for eclass.
-rw-r--r--eclass/python-distutils-ng.eclass14
1 files changed, 13 insertions, 1 deletions
diff --git a/eclass/python-distutils-ng.eclass b/eclass/python-distutils-ng.eclass
index ca6eaa8..3260d1b 100644
--- a/eclass/python-distutils-ng.eclass
+++ b/eclass/python-distutils-ng.eclass
@@ -13,7 +13,19 @@
# The Python eclass is designed to allow an easier installation of Python
# packages and their incorporation into the Gentoo Linux system.
#
-# TODO: Document implementations!
+# This eclass provides functions for following phases:
+# - src_prepare - you can define python_prepare_all function that will be run
+# before creating implementation-specific directory and python_prepare
+# function that will be run for each implementation
+# - src_configure - you can define python_configure function that will be run
+# for each implementation
+# - src_compile - you can define python_compile function that will be run for
+# each implementation, default function will run `setup.py build'
+# - src_test - you can define python_test function that will be run for each
+# implementation
+# - src_install - you can define python_install function that will be run for
+# each implementation and python_install_all that will be run in original
+# directory (so it wil lnot contain any implementation-specific files)
# @ECLASS-VARIABLE: PYTHON_COMPAT
# @DESCRIPTION: