summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pam_yubico/pam_yubico-2.5.ebuild')
-rw-r--r--sys-auth/pam_yubico/pam_yubico-2.5.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-auth/pam_yubico/pam_yubico-2.5.ebuild b/sys-auth/pam_yubico/pam_yubico-2.5.ebuild
new file mode 100644
index 0000000..353c25b
--- /dev/null
+++ b/sys-auth/pam_yubico/pam_yubico-2.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+inherit autotools eutils pam
+
+DESCRIPTION="Yubico Pluggable Authentication Module (PAM)"
+HOMEPAGE="http://code.google.com/p/yubico-pam/"
+SRC_URI="http://yubico-pam.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug ldap"
+
+DEPEND=">=sys-auth/ykclient-2.3
+ ldap? ( net-nds/openldap )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ if ! use debug ; then
+ epatch "${FILESDIR}/${P}-nodebug.patch"
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_with ldap) \
+ --with-pam-dir="$(getpam_mod_dir)" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc ChangeLog NEWS README doc/* || die
+}