summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pam_yubico/files/pam_yubico-2.5-nodebug.patch')
-rw-r--r--sys-auth/pam_yubico/files/pam_yubico-2.5-nodebug.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-auth/pam_yubico/files/pam_yubico-2.5-nodebug.patch b/sys-auth/pam_yubico/files/pam_yubico-2.5-nodebug.patch
new file mode 100644
index 0000000..ed1bd9f
--- /dev/null
+++ b/sys-auth/pam_yubico/files/pam_yubico-2.5-nodebug.patch
@@ -0,0 +1,24 @@
+diff -Naur pam_yubico-2.5.orig/Makefile.am pam_yubico-2.5/Makefile.am
+--- pam_yubico-2.5.orig/Makefile.am 2010-09-10 17:42:19.000000000 +0900
++++ pam_yubico-2.5/Makefile.am 2010-11-07 09:56:08.790170862 +0900
+@@ -37,7 +37,7 @@
+ pam_yubico_la_LIBADD = @LTLIBYKCLIENT@ @LIBLDAP@
+ pam_yubico_la_LDFLAGS = -module -avoid-version
+
+-DEFS = -DDEBUG_PAM -DPAM_DEBUG @DEFS@
++DEFS = @DEFS@
+
+ # Self tests.
+
+diff -Naur pam_yubico-2.5.orig/pam_yubico.c pam_yubico-2.5/pam_yubico.c
+--- pam_yubico-2.5.orig/pam_yubico.c 2010-09-10 06:38:07.000000000 +0900
++++ pam_yubico-2.5/pam_yubico.c 2010-11-07 10:01:46.348254257 +0900
+@@ -61,6 +61,8 @@
+ printf ("\n"); \
+ } while (0)
+ # endif
++#else
++# define D(x) ;
+ #endif
+
+ #include <ykclient.h>