summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/xen-sources/xen-sources-2.6.20.ebuild')
-rw-r--r--sys-kernel/xen-sources/xen-sources-2.6.20.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-kernel/xen-sources/xen-sources-2.6.20.ebuild b/sys-kernel/xen-sources/xen-sources-2.6.20.ebuild
new file mode 100644
index 0000000..2f2dced
--- /dev/null
+++ b/sys-kernel/xen-sources/xen-sources-2.6.20.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+ETYPE="sources"
+UNIPATCH_STRICTORDER="1"
+K_WANT_GENPATCHES="base"
+K_GENPATCHES_VER="13"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="Full sources for a dom0/domU Linux kernel to run under Xen"
+HOMEPAGE="http://www.xensource.com/xen/xen/"
+
+XEN_VERSION="3.1.0-fc7-2925"
+XEN_BASE_KV="2.6.20"
+XEN_PATCH="patch-${XEN_BASE_KV}_to_xen-${XEN_VERSION}.bz2"
+# Change to gentoo mirror when pushed into portage:
+PATCH_URI="http://dev.gentoo.org/~marineam/files/xen/${XEN_PATCH}"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${PATCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/${XEN_PATCH}"
+
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="${DEPEND}
+ >=sys-devel/binutils-2.17"
+
+pkg_postinst() {
+ postinst_sources
+
+ elog "This kernel is for Xen 3.1.0 and based on RedHat's patchset in"
+ elog "Fedora 7, if you have troubles try xen-sources-2.6.18* which is"
+ elog "based on the patches released with Xen."
+}