summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/ion3/files/20080207/201_all_fix-paths.patch')
-rw-r--r--x11-wm/ion3/files/20080207/201_all_fix-paths.patch76
1 files changed, 76 insertions, 0 deletions
diff --git a/x11-wm/ion3/files/20080207/201_all_fix-paths.patch b/x11-wm/ion3/files/20080207/201_all_fix-paths.patch
new file mode 100644
index 0000000..9cc3ca4
--- /dev/null
+++ b/x11-wm/ion3/files/20080207/201_all_fix-paths.patch
@@ -0,0 +1,76 @@
+diff -uNr ion-3-20080207.orig/system.mk ion-3-20080207/system.mk
+--- ion-3-20080207.orig/system.mk 2008-02-08 20:23:22.000000000 +0100
++++ ion-3-20080207/system.mk 2008-02-08 23:04:55.000000000 +0100
+@@ -8,7 +8,7 @@
+
+ # Installation path prefix. Unless you know what you're doing, the default
+ # of /usr/local is likely the correct choice.
+-PREFIX=/usr/local
++PREFIX=/usr
+
+ # Unless you are creating a package conforming to some OS's standards, you
+ # probably do not want to modify the following directories:
+@@ -16,7 +16,7 @@
+ # Main binaries
+ BINDIR=$(PREFIX)/bin
+ # Configuration .lua files
+-ETCDIR=$(PREFIX)/etc/ion3
++ETCDIR=/etc/X11/ion3
+ # Some .lua files and ion-* shell scripts
+ SHAREDIR=$(PREFIX)/share/ion3
+ # Manual pages
+@@ -62,18 +62,18 @@
+
+ # If you have installed Lua 5.1 from the official tarball without changing
+ # paths, this should do it.
+-LUA_DIR=/usr/local
+-LUA_LIBS = -L$(LUA_DIR)/lib -llua
+-LUA_INCLUDES = -I$(LUA_DIR)/include
+-LUA=$(LUA_DIR)/bin/lua
+-LUAC=$(LUA_DIR)/bin/luac
++#LUA_DIR=/usr/local
++#LUA_LIBS = -L$(LUA_DIR)/lib -llua
++#LUA_INCLUDES = -I$(LUA_DIR)/include
++#LUA=$(LUA_DIR)/bin/lua
++#LUAC=$(LUA_DIR)/bin/luac
+
+ # If you are using the Debian packages, the following settings should be
+ # what you want.
+-#LUA_LIBS=`pkg-config --libs lua5.1`
+-#LUA_INCLUDES=`pkg-config --cflags lua5.1`
+-#LUA=/usr/bin/lua5.1
+-#LUAC=/usr/bin/luac5.1
++LUA_LIBS=`pkg-config --libs lua`
++LUA_INCLUDES=`pkg-config --cflags lua`
++LUA=/usr/bin/lua
++LUAC=/usr/bin/luac
+
+
+ ##
+@@ -127,7 +127,7 @@
+ # You may uncomment this if you know that your system C libary provides
+ # asprintf and vasprintf. (GNU libc does.) If HAS_SYSTEM_ASPRINTF is not
+ # defined, an implementation provided in libtu/sprintf_2.2/ is used.
+-#HAS_SYSTEM_ASPRINTF=1
++HAS_SYSTEM_ASPRINTF=1
+
+ # The following setting is needed with GNU libc for clock_gettime and the
+ # monotonic clock. Other systems may not need it, or may not provide a
+@@ -169,14 +169,14 @@
+
+ #C89_SOURCE=-ansi
+
+-#POSIX_SOURCE=-D_POSIX_C_SOURCE=200112L
++POSIX_SOURCE=-D_POSIX_C_SOURCE=200112L
+
+ # Most systems
+-#XOPEN_SOURCE=-D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED
++XOPEN_SOURCE=-D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED
+ # SunOS, (Irix)
+ #XOPEN_SOURCE=-D__EXTENSIONS__
+
+-#C99_SOURCE=-std=c99 -DCF_HAS_VA_COPY
++C99_SOURCE=-std=c99 -DCF_HAS_VA_COPY
+
+ # The -DCF_HAS_VA_COPY option should allow for some optimisations, and
+ # in some cases simply defining