summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2018-03-12 22:23:02 +0100
committerThomas Raschbacher <lordvan@gentoo.org>2018-03-12 22:23:02 +0100
commit336dc19c7c0e6cb6453b219aa0cfa459f2805508 (patch)
tree2081a2b7ef94e5ad53c5732403366792cebbf21e
parentadd doc warning (diff)
downloadlordvan-336dc19c7c0e6cb6453b219aa0cfa459f2805508.tar.gz
lordvan-336dc19c7c0e6cb6453b219aa0cfa459f2805508.tar.bz2
lordvan-336dc19c7c0e6cb6453b219aa0cfa459f2805508.zip
first compiling version of new ebuild
-rw-r--r--x11-wm/enlightenment/Manifest4
-rw-r--r--x11-wm/enlightenment/enlightenment-0.22.1.ebuild133
-rw-r--r--x11-wm/enlightenment/files/gentoo-sysactions.conf76
-rw-r--r--x11-wm/enlightenment/metadata.xml118
4 files changed, 331 insertions, 0 deletions
diff --git a/x11-wm/enlightenment/Manifest b/x11-wm/enlightenment/Manifest
new file mode 100644
index 0000000..ec0bf35
--- /dev/null
+++ b/x11-wm/enlightenment/Manifest
@@ -0,0 +1,4 @@
+AUX gentoo-sysactions.conf 3056 SHA256 5939973a9fbaaba81751e936fb541d6aebd7ec1c599174ea568f5a579356939f SHA512 688f02cbff0d50a847eb08ca7832699b836adca9b22e15a780943a8e5a8213aac04b335cfdf3cb96adbff238f681ae8954a720153e8e35b2afaba3225d53206a WHIRLPOOL 0c05e0d295ede8b2f436a87c4b98876fed64d5cc780f13bb6bde1a74a3c87847f2f90ab482a61c2b39f20894572329f5497e5da22537261eef2f0a9fb33ce56d
+DIST enlightenment-0.22.1.tar.xz 25646312 SHA256 207b6b88dafc4932ab007a835510823c5a1dd8c191876ac037628176ca77a7e0 SHA512 cb7d4124a17f294f8617da970e233dd212cc426be63e94b74299ffc8dd0c8535284eee9c93a25273aa4c1bf1831a056bb73c4c96197985d469392f451aaa993e WHIRLPOOL 038b408af8c9c113333542f2690ad7c4063242c36120e78772944d6d80060505da1703d1f51bda50af8a2685c3cb44a68cb11683759d2a2bdae8e02df223065a
+EBUILD enlightenment-0.22.1.ebuild 3383 SHA256 485cd2a8a882fd16b6412eef140b49de87a02ad06d8284f01cb60c0342965d42 SHA512 88c77986ba42cc91090dbc400a5c6b09ca245f096814f65f71e27e63755ae7b58fb5507863f4225b6683342a8813e99a36beaddeb927313aa9a73c5a4a452f09 WHIRLPOOL 5ccacf00aad899e74b95de2d1cf0f4785c1c4bd135a17d6aa8e90a12b1d5b39a54d3641ce96363550973a79a259510fc1f5f9e4fec37efefc9fbe9f3f9a8629d
+MISC metadata.xml 7323 SHA256 907236a9d7c02476c4461923100f646e88e8978b2871fdbf853ebb6985acb9b2 SHA512 f2eb2e9df509af18da7e5cf09569c253baa6276318681925db125cfe77e2c77d777f04997d6720468c83756a707721825b79e0a162078d989ee756a83703a60c WHIRLPOOL 99e60ae8ee1bc1c41328f5a84e05040fb7ac5f40bcfcebafbeecd1497b54ffa8fab8e48832c7410edcfa58d3c2a78bc3c40bced78718fa3a3c90a1250f022cbe
diff --git a/x11-wm/enlightenment/enlightenment-0.22.1.ebuild b/x11-wm/enlightenment/enlightenment-0.22.1.ebuild
new file mode 100644
index 0000000..a5b3a8e
--- /dev/null
+++ b/x11-wm/enlightenment/enlightenment-0.22.1.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+MY_P=${P/_/-}
+SRC_URI="https://download.enlightenment.org/rel/apps/${PN}/${MY_P}.tar.xz"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+HOMEPAGE="https://www.enlightenment.org/"
+DESCRIPTION="Enlightenment DR17 window manager"
+
+inherit autotools xdg-utils
+
+LICENSE="BSD-2"
+SLOT="0.17/${PV%%_*}"
+
+__CONF_MODS=(
+ applications bindings dialogs display
+ interaction intl menus
+ paths performance randr shelves theme
+ window-manipulation window-remembers
+)
+__NORM_MODS=(
+ appmenu backlight bluez4 battery
+ clock conf connman cpufreq everything
+ fileman fileman-opinfo gadman geolocation
+ ibar ibox lokker
+ mixer msgbus music-control notification
+ pager packagekit pager-plain quickaccess
+ shot start syscon sysinfo systray tasks teamwork temperature tiling time
+ winlist wireless wizard wl-buffer wl-desktop-shell wl-drm wl-text-input
+ wl-weekeyboard wl-wl wl-x11 xkbswitch xwayland
+)
+IUSE_E_MODULES=(
+ ${__CONF_MODS[@]/#/enlightenment_modules_conf-}
+ ${__NORM_MODS[@]/#/enlightenment_modules_}
+)
+
+IUSE="doc nls pam spell static-libs systemd ukit wayland ${IUSE_E_MODULES[@]/#/+}"
+
+RDEPEND="
+ pam? ( sys-libs/pam )
+ systemd? ( sys-apps/systemd )
+ wayland? (
+ dev-libs/efl[wayland]
+ >=dev-libs/wayland-1.10.0
+ >=x11-libs/pixman-0.31.1
+ >=x11-libs/libxkbcommon-0.3.1
+ )
+ >=dev-libs/efl-1.18[X]
+ x11-libs/xcb-util-keysyms"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+#PATCHES=(
+# "${FILESDIR}"/quickstart.diff
+#)
+
+#src_prepare() {
+# default
+# eautoreconf
+#}
+
+# Sanity check to make sure module lists are kept up-to-date.
+check_modules() {
+ local detected=$(
+ awk -F'[\\[\\](, ]' '$1 == "AC_E_OPTIONAL_MODULE" { print $3 }' \
+ configure.ac | sed 's:_:-:g' | LC_COLLATE=C sort
+ )
+ local sorted=$(
+ printf '%s\n' ${IUSE_E_MODULES[@]/#enlightenment_modules_} | \
+ LC_COLLATE=C sort
+ )
+ if [[ ${detected} != "${sorted}" ]] ; then
+ local out new old
+ eerror "The ebuild needs to be kept in sync."
+ echo "${sorted}" > ebuild-iuse
+ echo "${detected}" > configure-detected
+ out=$(diff -U 0 ebuild-iuse configure-detected | sed -e '1,2d' -e '/^@@/d')
+ new=$(echo "${out}" | sed -n '/^+/{s:^+::;p}')
+ old=$(echo "${out}" | sed -n '/^-/{s:^-::;p}')
+ eerror "Add these modules: $(echo ${new})"
+ eerror "Drop these modules: $(echo ${old})"
+ die "please update the ebuild"
+ fi
+}
+
+src_configure() {
+ check_modules
+
+ E_ECONF=(
+ --disable-install-sysactions
+ $(use_enable doc)
+ $(use_enable nls)
+ $(use_enable pam)
+ $(use_enable systemd)
+ --enable-device-udev
+ $(use_enable ukit mount-udisks)
+ $(use_enable wayland)
+ )
+ local u c
+ for u in ${IUSE_E_MODULES[@]} ; do
+ c=${u#enlightenment_modules_}
+ # Disable modules by hand since we default to enabling them all.
+ case ${c} in
+ wl-*|xwayland)
+ if ! use wayland ; then
+ E_ECONF+=( --disable-${c} )
+ continue
+ fi
+ ;;
+ esac
+ E_ECONF+=( $(use_enable ${u} ${c}) )
+ done
+ econf ${MY_ECONF} "${E_ECONF[@]}"
+}
+
+src_install() {
+ default
+ DOCS=( ABOUT-NLS AUTHORS ChangeLog COPYING INSTALL NEWS README )
+ einstalldocs
+ insinto /etc/enlightenment
+ newins "${FILESDIR}"/gentoo-sysactions.conf sysactions.conf
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}
diff --git a/x11-wm/enlightenment/files/gentoo-sysactions.conf b/x11-wm/enlightenment/files/gentoo-sysactions.conf
new file mode 100644
index 0000000..fe67623
--- /dev/null
+++ b/x11-wm/enlightenment/files/gentoo-sysactions.conf
@@ -0,0 +1,76 @@
+# ENLIGHTENMENT SYSTEM ACTIONS CONFIGURATION
+#
+# This is a system configuration for allowing or denying certain users or
+# groups to be able to do certain actions that involve system restricted
+# actions such as halt, reboot, suspend, hibernate etc.
+#
+# This file is read in order from top to bottom - the first rule to MATCH
+# will be used for a user or a group, and nothing after that is read.
+#
+# You must put all the ACTION definitons BEFORE user and group rule matches.
+# Any action definitons after a rule match has been found will be ignored.
+# This allows actions to be re-defined for different user groups, so matches
+# so the command for an action can change for matches to the rules later on.
+#
+# Any user or group NOT matched by an allow or a deny will be ALLOWED to
+# perform the action by default (system administrators should be aware of
+# this and implement whatever policies they see fit). Generally speaking
+# a user of a workstation, desktop or laptop is intended to have such abilities
+# to perform these actions, thus the default of allow. For multi-user systems
+# the system administrator is considerd capable enough to restrict what they
+# see they need to.
+#
+# A WARNING to admins: do NOT allow access for users to this system remotely
+# UNLESS you fully trust them or you have locked down permissions to halt/reboot
+# suspend etc. here first. You have been warned.
+#
+# FORMAT:
+#
+# action: halt /sbin/shutdown -h now
+# action: reboot /sbin/shutdown -r now
+# action: suspend /etc/acpi/sleep.sh force
+# action: hibernate /etc/acpi/hibernate.sh force
+#
+# user: username allow: halt reboot suspend hibernate
+# group: groupname deny: *
+# group: * deny: *
+# user: * allow: suspend
+# user: billy allow: halt reboot
+# group: staff deny: halt suspend hibernate
+#
+# etc.
+#
+# user and group name can use glob matches (* == all for example) like the
+# shell. as can action names allowed or denied.
+
+action: halt /sbin/shutdown -h now
+action: reboot /sbin/shutdown -r now
+action: suspend /usr/sbin/pm-suspend
+action: hibernate /usr/sbin/pm-hibernate
+
+# on FreeBSD use this instead of the above.
+#action suspend /usr/sbin/zzz
+
+# root is allowed to do anything - but it needs to be here explicitly anyway
+user: root allow: *
+# members of operator, staff and admin groups should be able to do all
+group: operator allow: *
+group: staff allow: *
+group: admin allow: *
+group: sys allow: *
+group: wheel allow: *
+# common "user" groups for "console users" on desktops/laptops
+group: dialout allow: *
+group: disk allow: *
+group: adm allow: *
+group: cdrom allow: *
+group: floppy allow: *
+group: audio allow: *
+group: dip allow: *
+group: plugdev allow: *
+# put in a list of other users and groups here that are allowed or denied etc.
+# e.g.
+# user: myuser allow: *
+# user: another allow: suspend hibernate
+# deny everyone else by default
+user: * deny: *
diff --git a/x11-wm/enlightenment/metadata.xml b/x11-wm/enlightenment/metadata.xml
new file mode 100644
index 0000000..cda7161
--- /dev/null
+++ b/x11-wm/enlightenment/metadata.xml
@@ -0,0 +1,118 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>enlightenment@gentoo.org</email>
+ <name>Project Enlightenment</name>
+</maintainer>
+<use>
+ <flag name="pango">Enable pango font rendering</flag>
+ <flag name="xrandr">Enable support for the X xrandr extension</flag>
+ <flag name="ukit">Use upower/udisks to automount devices</flag>
+ <flag name="enlightenment_modules_appmenu">Gadget that hold the toolbar of the foreground application</flag>
+ <flag name="enlightenment_modules_backlight">Backlight control slider gadget</flag>
+ <flag name="enlightenment_modules_battery">A gadget to visualize your battery status</flag>
+ <flag name="enlightenment_modules_bluez4">Configure Bluetooth devices</flag>
+ <flag name="enlightenment_modules_clock">Nice clock gadget to show current time</flag>
+ <flag name="enlightenment_modules_connman">Control Wifi and wired networks as a user</flag>
+ <flag name="enlightenment_modules_cpufreq">Gadget to monitor and change the CPU frequency</flag>
+ <flag name="enlightenment_modules_everything">The run command module provides an application launcher dialog</flag>
+ <flag name="enlightenment_modules_fileman">Enlightenment's integrated file manager</flag>
+ <flag name="enlightenment_modules_fileman-opinfo">Can be placed on the desktop or in a shelf</flag>
+ <flag name="enlightenment_modules_gadman">Module to manage gadgets on the desktop</flag>
+ <flag name="enlightenment_modules_geolocation">Geolocation</flag>
+ <flag name="enlightenment_modules_ibar">Iconic application launcher</flag>
+ <flag name="enlightenment_modules_ibox">A home for your iconified applications</flag>
+ <flag name="enlightenment_modules_lokker">Screen locker</flag>
+ <flag name="enlightenment_modules_mixer">A module to provide a mixer for changing volume</flag>
+ <flag name="enlightenment_modules_msgbus">DBus Extension</flag>
+ <flag name="enlightenment_modules_music-control">Control your music in your shelf</flag>
+ <flag name="enlightenment_modules_notification">notification-daemon alternative. Popup if an event occur</flag>
+ <flag name="enlightenment_modules_packagekit">Package manager integration</flag>
+ <flag name="enlightenment_modules_pager">Gadget to allow you to visualize your virtual desktops and the windows they contain</flag>
+ <flag name="enlightenment_modules_pager-plain">A simpler desktop pager</flag>
+ <flag name="enlightenment_modules_quickaccess">Enlightenment Quickaccess Launcher</flag>
+ <flag name="enlightenment_modules_shot">Simple screenshot+save/upload module</flag>
+ <flag name="enlightenment_modules_start">Enlightenment's 'Start' button equivalent</flag>
+ <flag name="enlightenment_modules_syscon">This module provides a unified popup dialog for all the system actions in Enlightenment</flag>
+ <flag name="enlightenment_modules_sysinfo">TODO blabla</flag>
+ <flag name="enlightenment_modules_systray">system tray that hold applications icons like Skype, Pidgin, Kopete and others</flag>
+ <flag name="enlightenment_modules_tasks">Gadget to allow you to switch tasks</flag>
+ <flag name="enlightenment_modules_teamwork">Enable teamwork module</flag>
+ <flag name="enlightenment_modules_temperature">Temperature monitor</flag>
+ <flag name="enlightenment_modules_time">Time related gadgets</flag>
+ <flag name="enlightenment_modules_tiling">Positions/resizes your windows tilingly</flag>
+ <flag name="enlightenment_modules_winlist">A module to show the list of client applications presently running</flag>
+ <flag name="enlightenment_modules_wizard">First Run Wizard</flag>
+ <flag name="enlightenment_modules_wireless">WiFi monitoring</flag>
+ <flag name="enlightenment_modules_wl-buffer">TODO: lala</flag>
+ <flag name="enlightenment_modules_wl-desktop-shell">Enlightenment Wayland Desktop Shell</flag>
+ <flag name="enlightenment_modules_wl-drm">Wayland DRM (Direct Rendering Manager) compositing module</flag>
+ <flag name="enlightenment_modules_wl-text-input">Wayland text input support</flag>
+ <flag name="enlightenment_modules_wl-weekeyboard">Wayland virtual keyboard</flag>
+ <flag name="enlightenment_modules_wl-wl">Wayland-in-Wayland module</flag>
+ <flag name="enlightenment_modules_wl-x11">Wayland-in-X11 module</flag>
+ <flag name="enlightenment_modules_xkbswitch">Keyboard layout configuration and switcher</flag>
+ <flag name="enlightenment_modules_xwayland">X/Wayland integration</flag>
+ <flag name="enlightenment_modules_conf">Settings Panel</flag>
+ <flag name="enlightenment_modules_conf-applications">Allows configuration of Ibar, Restart, and Startup applications</flag>
+ <flag name="enlightenment_modules_conf-bindings">Input Control Settings</flag>
+ <flag name="enlightenment_modules_conf-dialogs">Configure default dialog properties</flag>
+ <flag name="enlightenment_modules_conf-display">Used to configure your screen</flag>
+ <flag name="enlightenment_modules_conf-interaction">Configure Mouse and Touch input</flag>
+ <flag name="enlightenment_modules_conf-intl">Used to select a default language</flag>
+ <flag name="enlightenment_modules_conf-menus">Configures menu behavior</flag>
+ <flag name="enlightenment_modules_conf-paths">Specifies the Enlightenment search paths and default directories</flag>
+ <flag name="enlightenment_modules_conf-performance">Used to configure certain performance related items as frame rates and cache settings</flag>
+ <flag name="enlightenment_modules_conf-randr">Used to configure your screen's resolution</flag>
+ <flag name="enlightenment_modules_conf-shelves">Shelf configuration dialog</flag>
+ <flag name="enlightenment_modules_conf-theme">Used to configure your theme preferences</flag>
+ <flag name="enlightenment_modules_conf-window-manipulation">Configures window raise, resistance, and maximize policies</flag>
+ <flag name="enlightenment_modules_conf-window-remembers">Delete existing window remembers</flag>
+</use>
+<longdescription>
+Enlightenment is a completely themeable, highly configurable Window Manager for
+the X Window System, traditionally used in Unix environments.
+
+Enlightenment Features:
+* Fully configurable window borders
+* Iconboxes to store icons in
+* Graphical Pager that also does miniature snapshots of your screen
+* IPC mechanism to remote-control Enlightenment
+* Theme support
+* Menus
+* Translucent moving of windows
+* Window groups
+* Virtual Desktops
+* Multiple Desktops (more than one desktop of Virtual Desktops)
+* Desktop Background selection and management
+* Sound support
+* Multiple focus modes
+* Many resize and move mode settings
+* Manual placement of windows option
+* Autoraising of windows option
+* Tooltips
+* Configurable keybindings
+* Configurable desktop bindings
+* DGA support for fullscreen client zoom
+* Window shading
+* Miniature snapshot icons
+* Multiple border styles at once
+* Window layers
+* Array menus
+* Internal configuration dialogs
+* Auto-scrolling menus
+* KDE hint support
+* GNOME hint support
+* Primitive Windowmaker/Afterstep dock App support.
+* X11R6 session management support
+* Internal per-app based session and property management.
+* Background auto scanning support
+* Truetype anti-aliased font support
+* Window auto-cleanup support
+* Graphical on-line help.
+</longdescription>
+<upstream>
+ <remote-id type="sourceforge">enlightenment</remote-id>
+</upstream>
+</pkgmetadata>