summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-mud/kmuddy/kmuddy-0.8.ebuild')
-rw-r--r--games-mud/kmuddy/kmuddy-0.8.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/games-mud/kmuddy/kmuddy-0.8.ebuild b/games-mud/kmuddy/kmuddy-0.8.ebuild
index 00074be..32ba85d 100644
--- a/games-mud/kmuddy/kmuddy-0.8.ebuild
+++ b/games-mud/kmuddy/kmuddy-0.8.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/games-mud/kmuddy/kmuddy-0.8.ebuild,v 1.6 2008/08/01 17:58:12 armin76 Exp $
-inherit base eutils kde-functions
+WANT_AUTOMAKE=1.9
+
+inherit base eutils kde-functions autotools
DESCRIPTION="MUD client for KDE"
HOMEPAGE="http://www.kmuddy.com/"
@@ -20,7 +22,17 @@ need-kde 3
PATCHES=( "${FILESDIR}/${P}-nocrash.patch"
"${FILESDIR}/${P}-gcc43.patch"
"${FILESDIR}/${P}-idle-crash.patch"
+ "${FILESDIR}/${P}-libtool.patch"
)
+# "${FILESDIR}/${P}-linking.patch"
+
+src_unpack() {
+ base_src_unpack
+ cd "${S}"
+ mv admin/acinclude.m4.in acinclude.m4
+ eautoreconf
+ find . -name Makefile.in -exec perl admin/am_edit ';'
+}
src_compile() {
econf \