summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libnds/libnds-20060719.ebuild')
-rw-r--r--dev-libs/libnds/libnds-20060719.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/libnds/libnds-20060719.ebuild b/dev-libs/libnds/libnds-20060719.ebuild
new file mode 100644
index 0000000..100bb84
--- /dev/null
+++ b/dev-libs/libnds/libnds-20060719.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/devhelp/devhelp-0.12.ebuild,v 1.1 2006/08/01 09:09:34 leonardop Exp $
+
+DESCRIPTION="Nintendo DS Libraries for devkitPro ARM"
+HOMEPAGE="http://devkitpro.org/"
+SRC_URI="mirror://sourceforge/devkitpro/libnds-src-20060719.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* x86"
+IUSE=""
+
+DEPEND="dev-util/devkitarm-bin"
+S=${WORKDIR}
+
+src_compile() {
+ cd ${S}
+ export DEVKITARM=/opt/devkitARM
+ export PATH=/opt/devkitARM/bin:${PATH}
+ emake || die "make failed"
+}
+
+src_install() {
+ local INSTDIR=/opt/devkitARM
+ cd ${S}
+ dodir ${INSTDIR}/libnds
+ tar -cvf - . | tar -xvf - -C ${D}${INSTDIR}/libnds
+ }