summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin F. Quinn <kevquinn@gentoo.org>2006-12-20 19:51:53 +0000
committerKevin F. Quinn <kevquinn@gentoo.org>2006-12-20 19:51:53 +0000
commit68aa6e4fc91147676b93a982e17570a9af4497e0 (patch)
tree9550afa11da3c164ff5414d0e44427eec712cb10
parentFix cut-n-paste error in new gcc-specs-directive (diff)
downloadkevquinn-68aa6e4fc91147676b93a982e17570a9af4497e0.tar.gz
kevquinn-68aa6e4fc91147676b93a982e17570a9af4497e0.tar.bz2
kevquinn-68aa6e4fc91147676b93a982e17570a9af4497e0.zip
Align 2.5 with 2.4-r4; remove obsolete stuff
svn path=/; revision=134
-rw-r--r--hardened/toolchain/branches/gcc-glibc-nopie/sys-libs/glibc/glibc-2.4-r4.ebuild6
-rw-r--r--hardened/toolchain/branches/gcc-glibc-nopie/sys-libs/glibc/glibc-2.5.ebuild8
2 files changed, 3 insertions, 11 deletions
diff --git a/hardened/toolchain/branches/gcc-glibc-nopie/sys-libs/glibc/glibc-2.4-r4.ebuild b/hardened/toolchain/branches/gcc-glibc-nopie/sys-libs/glibc/glibc-2.4-r4.ebuild
index 3ea83c0..b6dc759 100644
--- a/hardened/toolchain/branches/gcc-glibc-nopie/sys-libs/glibc/glibc-2.4-r4.ebuild
+++ b/hardened/toolchain/branches/gcc-glibc-nopie/sys-libs/glibc/glibc-2.4-r4.ebuild
@@ -238,10 +238,6 @@ toolchain-glibc_src_unpack() {
einfo "Patching to make test failures clear, and to run all of them."
epatch ${FILESDIR}/2.4/glibc-2.4-testfailobvious.patch
-# Building -fno-PIE anyway, so don't need this
-# einfo "Patching to get working PIE binaries on PIE (hardened) platforms"
-# epatch ${FILESDIR}/2.4/glibc-2.4-hardened-pie.patch
-
if use hardened; then
einfo "Installing Hardened Gentoo SSP handler"
cp -f ${FILESDIR}/2.4/glibc-2.4-gentoo-stack_chk_fail.c \
@@ -737,8 +733,6 @@ setup_flags() {
# to the glibc build process. See bug #94325
filter-flags -fstack-protector
- # Don't let the compiler automatically build PIEs unless USE=hardened.
- #use hardened || filter-flags -fPIE
# Don't build glibc itself with PIE - otherwise you get broken crt*
# files, and PIE objects in libc.a and friends which isn't useful.
filter-flags -fPIE
diff --git a/hardened/toolchain/branches/gcc-glibc-nopie/sys-libs/glibc/glibc-2.5.ebuild b/hardened/toolchain/branches/gcc-glibc-nopie/sys-libs/glibc/glibc-2.5.ebuild
index ae28828..86efbc3 100644
--- a/hardened/toolchain/branches/gcc-glibc-nopie/sys-libs/glibc/glibc-2.5.ebuild
+++ b/hardened/toolchain/branches/gcc-glibc-nopie/sys-libs/glibc/glibc-2.5.ebuild
@@ -221,9 +221,6 @@ toolchain-glibc_src_unpack() {
einfo "Patching to make test failures clear, and to run all of them."
epatch ${FILESDIR}/2.4/glibc-2.4-testfailobvious.patch
- einfo "Patching to get working PIE binaries on PIE (hardened) platforms"
- epatch ${FILESDIR}/2.4/glibc-2.4-hardened-pie.patch
-
if use hardened; then
einfo "Installing Hardened Gentoo SSP handler"
cp -f ${FILESDIR}/2.4/glibc-2.4-gentoo-stack_chk_fail.c \
@@ -720,8 +717,9 @@ setup_flags() {
# to the glibc build process. See bug #94325
filter-flags -fstack-protector
- # Don't let the compiler automatically build PIEs unless USE=hardened.
- use hardened || filter-flags -fPIE
+ # Don't build glibc itself with PIE - otherwise you get broken crt*
+ # files, and PIE objects in libc.a and friends which isn't useful.
+ filter-flags -fPIE
}
check_kheader_version() {