summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/luabit/luabit-0.4.ebuild')
-rw-r--r--dev-lua/luabit/luabit-0.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-lua/luabit/luabit-0.4.ebuild b/dev-lua/luabit/luabit-0.4.ebuild
new file mode 100644
index 0000000..5fdc40e
--- /dev/null
+++ b/dev-lua/luabit/luabit-0.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="A bitwise operation lib totally written in Lua."
+HOMEPAGE="http://luaforge.net/projects/bit/"
+SRC_URI="http://luaforge.net/frs/download.php/2185/${P}.zip"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-lang/lua"
+RDEPEND="${DEPEND}
+ app-arch/unzip"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ local luaver=
+ luaver="$(lua -v 2>&1| cut -d' ' -f2)"
+ luaver="${luaver%.*}"
+
+ insinto /usr/share/lua/${luaver}
+ doins *.lua || die "doins failed"
+}
+