summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-nds/openldap-totp/Manifest1
-rw-r--r--net-nds/openldap-totp/metadata.xml5
-rw-r--r--net-nds/openldap-totp/openldap-totp-20170906.ebuild48
3 files changed, 54 insertions, 0 deletions
diff --git a/net-nds/openldap-totp/Manifest b/net-nds/openldap-totp/Manifest
new file mode 100644
index 00000000..afcd52f8
--- /dev/null
+++ b/net-nds/openldap-totp/Manifest
@@ -0,0 +1 @@
+DIST 2c36a37f908cd2e7297b1bd5621fea2f0d32451a.tar.gz 5630873 BLAKE2B d487ba8bf51dec8ee7c537d3772d55150d75550a449cdd05c56c2503fa927737488d812437dd2eba29a831313bc0b450655c103db07d153e0013f64f67f692d1 SHA512 143b622e7ce33b1c5070da59a32a197d2dcdcf0ad7e5219dbc26cc80945df14f74b4699ecd5e01af14322264186f5dd7c2af6a210c148ad383b018cbc47223b8
diff --git a/net-nds/openldap-totp/metadata.xml b/net-nds/openldap-totp/metadata.xml
new file mode 100644
index 00000000..bd70e455
--- /dev/null
+++ b/net-nds/openldap-totp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version = '1.0' encoding = 'UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person"><email>graaff@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/net-nds/openldap-totp/openldap-totp-20170906.ebuild b/net-nds/openldap-totp/openldap-totp-20170906.ebuild
new file mode 100644
index 00000000..f5a6e3bd
--- /dev/null
+++ b/net-nds/openldap-totp/openldap-totp-20170906.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# This ebuild provides the slapd module for totp in the OpenLDAP git
+# repository.
+# https://www.openldap.org/its/index.cgi/Incoming?id=8836;expression=totp
+# tracks its inclusion in the OpenLDAP release media, at which point
+# totp support should be added to the openldap ebuild.
+
+COMMIT=2c36a37f908cd2e7297b1bd5621fea2f0d32451a
+
+DESCRIPTION="provides support for RFC 6238 TOTP Time-based One Time Passwords in OpenLDAP"
+HOMEPAGE="https://github.com/openldap/openldap/tree/master/contrib/slapd-modules/passwd/totp"
+SRC_URI="https://github.com/openldap/openldap/archive/${COMMIT}.tar.gz"
+
+LICENSE="OPENLDAP"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="net-nds/openldap"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/openldap-${COMMIT}"
+
+src_prepare() {
+ sed -i -e 's/^LIBS = .*/LIBS = -lldap -llber/' contrib/slapd-modules/passwd/totp/Makefile || die
+ eapply_user
+}
+
+src_compile() {
+ pushd include || die
+ emake ldap_config.h
+ popd || die
+ pushd contrib/slapd-modules/passwd/totp || die
+ emake
+}
+
+src_test() {
+ :
+}
+
+src_install() {
+ pushd contrib/slapd-modules/passwd/totp || die
+ emake DESTDIR="${D}" libexecdir="${EPREFIX}/usr/$(get_libdir)/openldap" mandir="${EPREFIX}/usr/share" install
+ dodoc README
+}