summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-12-24 18:42:25 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-12-24 18:42:25 +0000
commita13a34c0d9324b786f83767a8399498b1a910b16 (patch)
treeb5beda7e295d8d2de2ba14361649bb1f98719ba7
parentmedia-gfx/a2png: Remove a2png -> my overlay (diff)
downloadgenstef-a13a34c0d9324b786f83767a8399498b1a910b16.tar.gz
genstef-a13a34c0d9324b786f83767a8399498b1a910b16.tar.bz2
genstef-a13a34c0d9324b786f83767a8399498b1a910b16.zip
add new stratagus, does not work for me yet
svn path=/; revision=92
-rw-r--r--games-engines/stratagus/stratagus-2.2.1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/games-engines/stratagus/stratagus-2.2.1.ebuild b/games-engines/stratagus/stratagus-2.2.1.ebuild
new file mode 100644
index 0000000..cbbb6ff
--- /dev/null
+++ b/games-engines/stratagus/stratagus-2.2.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/stratagus/stratagus-2.1.ebuild,v 1.13 2006/12/04 20:14:19 wolf31o2 Exp $
+
+inherit games eutils autotools
+
+MY_PV=061209
+DESCRIPTION="A realtime strategy game engine"
+HOMEPAGE="http://www.stratagus.org/"
+SRC_URI="mirror://sourceforge/stratagus/${PN}-${MY_PV}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="bzip2 debug doc mikmod mng opengl theora vorbis"
+
+RDEPEND="app-arch/bzip2
+ dev-lang/lua
+ media-libs/libpng
+ media-libs/libsdl
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ mikmod? ( media-libs/libmikmod )
+ mng? ( media-libs/libmng )
+ theora? ( media-libs/libtheora )
+ vorbis? ( media-libs/libogg media-libs/libvorbis )"
+
+DEPEND="${RDEPEND}
+ x11-libs/libXt
+ doc? ( app-doc/doxygen )"
+
+S=${WORKDIR}/stratagus-${MY_PV}
+
+src_compile() {
+ epatch ${FILESDIR}/stratagus-061209-lua-5.1.patch
+ econf \
+ $(use_enable debug) \
+ $(use_with bzip2) \
+ $(use_with mikmod) \
+ $(use_with mng) \
+ $(use_with opengl) \
+ $(use_with theora) \
+ $(use_with vorbis) \
+ --with-x \
+ --x-includes=/usr/include \
+ LDFLAGS="${LDFLAGS} -lX11" \
+ || die "econf failed"
+
+ emake -j1 || die "emake failed"
+ echo $LDFLAGS
+
+ if use doc ; then
+ emake doc || die "making source documentation failed"
+ fi
+}
+
+src_install() {
+ dogamesbin stratagus || die "dogamesbin failed"
+ dodoc README
+ dohtml -r doc/*
+ use doc && dohtml -r srcdoc/html/*
+ prepgamesdirs
+}