summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2006-11-09 12:24:04 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2006-11-09 12:24:04 +0000
commit302b65dbff660cc2d45fbf8bb044723b3c0774b3 (patch)
tree18a2593528f7e0fe09cd4b7bfe417b05f613f594 /net-analyzer
parentMoved in main tree (diff)
downloaddrizzt-302b65dbff660cc2d45fbf8bb044723b3c0774b3.tar.gz
drizzt-302b65dbff660cc2d45fbf8bb044723b3c0774b3.tar.bz2
drizzt-302b65dbff660cc2d45fbf8bb044723b3c0774b3.zip
Added ettercap with as-needed patch by ikelos (BUG: #128675)
svn path=/; revision=24
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ettercap/Manifest12
-rw-r--r--net-analyzer/ettercap/ettercap-0.7.3-r1.ebuild64
-rw-r--r--net-analyzer/ettercap/files/digest-ettercap-0.7.3-r13
-rw-r--r--net-analyzer/ettercap/files/ettercap-0.7.3-as-needed.patch14
4 files changed, 93 insertions, 0 deletions
diff --git a/net-analyzer/ettercap/Manifest b/net-analyzer/ettercap/Manifest
new file mode 100644
index 0000000..80543e9
--- /dev/null
+++ b/net-analyzer/ettercap/Manifest
@@ -0,0 +1,12 @@
+AUX ettercap-0.7.3-as-needed.patch 476 RMD160 1c7f5d24a4b77922e6499d048cd8b7b984db6eb4 SHA1 fd137a91ec37a5b1fbfa28fc075191cc92d298c7 SHA256 7722bd2e6f993d45e74ae8b36b200d34e10257fc7b2b8de7f76a6946f7a8046a
+MD5 e3bf174f8719e24db5331413940a06ef files/ettercap-0.7.3-as-needed.patch 476
+RMD160 1c7f5d24a4b77922e6499d048cd8b7b984db6eb4 files/ettercap-0.7.3-as-needed.patch 476
+SHA256 7722bd2e6f993d45e74ae8b36b200d34e10257fc7b2b8de7f76a6946f7a8046a files/ettercap-0.7.3-as-needed.patch 476
+DIST ettercap-NG-0.7.3.tar.gz 1138643 RMD160 f4e6c0d87b2064b3775e9af60f34575273742616 SHA1 7a2c3f848ca4f39c07fddeb0d6308641265bc4ff SHA256 c74239052d62565c13a82f9bbf217a4fdcce4b34949e361b53bb3f28e3168543
+EBUILD ettercap-0.7.3-r1.ebuild 1621 RMD160 45a68eb8b0dc0b8dcc6e3b1fd874581c28d3c449 SHA1 c09f7b1407bd4fff8cf9cb0679c7a099efddbb28 SHA256 fd1e38dd99dc835b686c226e566cdfabcfe19df5e03571572e228513354591be
+MD5 dfc59d1af4d5ad42b51b56be75dbf003 ettercap-0.7.3-r1.ebuild 1621
+RMD160 45a68eb8b0dc0b8dcc6e3b1fd874581c28d3c449 ettercap-0.7.3-r1.ebuild 1621
+SHA256 fd1e38dd99dc835b686c226e566cdfabcfe19df5e03571572e228513354591be ettercap-0.7.3-r1.ebuild 1621
+MD5 2063ae5fcf7595ed3346dc6c22e44a9e files/digest-ettercap-0.7.3-r1 256
+RMD160 b76cf90077a3b3275e5bbf106d43fd1bbca06e40 files/digest-ettercap-0.7.3-r1 256
+SHA256 8f1f64d3cd96d2893c3194830350996b9c8099fdc0b2fb75e1c740965e7fda68 files/digest-ettercap-0.7.3-r1 256
diff --git a/net-analyzer/ettercap/ettercap-0.7.3-r1.ebuild b/net-analyzer/ettercap/ettercap-0.7.3-r1.ebuild
new file mode 100644
index 0000000..8397a82
--- /dev/null
+++ b/net-analyzer/ettercap/ettercap-0.7.3-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ettercap/ettercap-0.7.3.ebuild,v 1.10 2006/10/25 08:37:12 drizzt Exp $
+
+# the actual version is "NG-0.7.0" but I suppose portage people will not be
+# happy with it (as for the 0.6.b version), so let's set it to "0.7.0".
+# since 'ettercap NG' has to be intended as an upgrade to 0.6.x series and not as
+# a new project or branch, this will be fine...
+
+inherit flag-o-matic
+
+MY_P="${PN}-NG-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A suite for man in the middle attacks and network mapping"
+HOMEPAGE="http://ettercap.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl ncurses gtk debug"
+
+# libtool is needed because it provides libltdl (needed for plugins)
+RDEPEND=">=sys-devel/libtool-1.4.3
+ >=net-libs/libnet-1.1.2.1-r1
+ net-libs/libpcap
+ ncurses? ( sys-libs/ncurses )
+ ssl? ( dev-libs/openssl )
+ gtk? ( >=x11-libs/gtk+-2.2.2 )"
+
+DEPEND=">=sys-apps/sed-4.0.5
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+}
+
+src_compile() {
+ strip-flags
+
+ local myconf
+
+ if use ssl; then
+ myconf="${myconf} --with-openssl=/usr"
+ else
+ myconf="${myconf} --without-openssl"
+ fi
+
+ econf ${myconf} \
+ $(use_enable gtk) \
+ $(use_enable debug) \
+ $(use_with ncurses) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+}
diff --git a/net-analyzer/ettercap/files/digest-ettercap-0.7.3-r1 b/net-analyzer/ettercap/files/digest-ettercap-0.7.3-r1
new file mode 100644
index 0000000..658da46
--- /dev/null
+++ b/net-analyzer/ettercap/files/digest-ettercap-0.7.3-r1
@@ -0,0 +1,3 @@
+MD5 28fb15cd024162c55249888fe1b97820 ettercap-NG-0.7.3.tar.gz 1138643
+RMD160 f4e6c0d87b2064b3775e9af60f34575273742616 ettercap-NG-0.7.3.tar.gz 1138643
+SHA256 c74239052d62565c13a82f9bbf217a4fdcce4b34949e361b53bb3f28e3168543 ettercap-NG-0.7.3.tar.gz 1138643
diff --git a/net-analyzer/ettercap/files/ettercap-0.7.3-as-needed.patch b/net-analyzer/ettercap/files/ettercap-0.7.3-as-needed.patch
new file mode 100644
index 0000000..3a74210
--- /dev/null
+++ b/net-analyzer/ettercap/files/ettercap-0.7.3-as-needed.patch
@@ -0,0 +1,14 @@
+diff -uNr ettercap-NG-0.7.3.orig/src/Makefile.am ettercap-NG-0.7.3/src/Makefile.am
+--- ettercap-NG-0.7.3.orig/src/Makefile.am 2006-04-03 19:33:36.000000000 +0100
++++ ettercap-NG-0.7.3/src/Makefile.am 2006-04-03 19:35:09.000000000 +0100
+@@ -140,7 +140,9 @@
+ ettercap_LDADD += interfaces/gtk/libec_gtk.a
+ endif
+
+-ettercap_LDFLAGS = -export-dynamic @EC_LIBS@
++ettercap_LDADD += @EC_LIBS@
++
++ettercap_LDFLAGS = -export-dynamic
+
+ CLEANFILES = *.log *.out core* missing/*.o *~
+