summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Huettel <andreas.huettel@ur.de>2014-03-12 14:36:21 +0100
committerAndreas K. Huettel <andreas.huettel@ur.de>2014-03-12 14:36:21 +0100
commitd665dc948e3ac9e1e0fd20487e8e7936a81b1693 (patch)
tree7ad84b6f6cd2bb597267299c36219491a232be25 /dev-perl
parent[app-office/libreoffice-l10n] clean up (diff)
downloaddilfridge-d665dc948e3ac9e1e0fd20487e8e7936a81b1693.tar.gz
dilfridge-d665dc948e3ac9e1e0fd20487e8e7936a81b1693.tar.bz2
dilfridge-d665dc948e3ac9e1e0fd20487e8e7936a81b1693.zip
[dev-perl/Lab-Measurement] add experiment
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Lab-Measurement/Lab-Measurement-9999-r1.ebuild63
-rw-r--r--dev-perl/Lab-Measurement/metadata.xml55
2 files changed, 118 insertions, 0 deletions
diff --git a/dev-perl/Lab-Measurement/Lab-Measurement-9999-r1.ebuild b/dev-perl/Lab-Measurement/Lab-Measurement-9999-r1.ebuild
new file mode 100644
index 0000000..53a3aa7
--- /dev/null
+++ b/dev-perl/Lab-Measurement/Lab-Measurement-9999-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Lab-Measurement/Lab-Measurement-9999.ebuild,v 1.11 2014/03/07 12:04:07 dilfridge Exp $
+
+EAPI=5
+
+EGIT_REPO_URI="/home/user/Lab-Measurement"
+EGIT_BRANCH="master"
+EGIT_SOURCEDIR=${S}
+KEYWORDS=""
+S=${WORKDIR}/${P}/Measurement
+inherit perl-module git-2
+
+DESCRIPTION="Measurement control and automation with Perl"
+HOMEPAGE="http://www.labmeasurement.de/"
+
+# this is perl's license, whatever it means
+LICENSE="|| ( Artistic GPL-2 )"
+
+SLOT="0"
+IUSE="debug +xpression"
+
+RDEPEND="
+ dev-perl/Clone
+ dev-perl/Exception-Class
+ dev-perl/Hook-LexWrap
+ dev-perl/List-MoreUtils
+ dev-perl/TermReadKey
+ dev-perl/TeX-Encode
+ dev-perl/XML-Generator
+ dev-perl/XML-DOM
+ dev-perl/XML-Twig
+ dev-perl/encoding-warnings
+ dev-perl/yaml
+ sci-visualization/gnuplot
+ virtual/perl-Class-ISA
+ virtual/perl-Data-Dumper
+ virtual/perl-Encode
+ virtual/perl-Switch
+ virtual/perl-Time-HiRes
+ !dev-perl/Lab-Instrument
+ !dev-perl/Lab-Tools
+ debug? (
+ dev-lang/perl[ithreads]
+ dev-perl/wxperl
+ )
+ xpression? (
+ dev-perl/wxperl
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/perl-Module-Build
+"
+
+pkg_postinst() {
+ if ( ! has_version sci-libs/linuxgpib ) && ( ! has_version dev-perl/Lab-VISA ) ; then
+ elog "You may want to install one or more backend driver modules. Supported are"
+ elog " sci-libs/linuxgpib Open-source GPIB hardware driver"
+ elog " dev-perl/Lab-VISA Bindings for the NI proprietary VISA driver"
+ elog " stack (dilfridge overlay)"
+ fi
+}
diff --git a/dev-perl/Lab-Measurement/metadata.xml b/dev-perl/Lab-Measurement/metadata.xml
new file mode 100644
index 0000000..bcca721
--- /dev/null
+++ b/dev-perl/Lab-Measurement/metadata.xml
@@ -0,0 +1,55 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>dilfridge@gentoo.org</email>
+ <name>Andreas K. Huettel</name>
+ </maintainer>
+ <use>
+ <flag name="xpression">Install the Xpression measurement framework</flag>
+ </use>
+ <upstream>
+ <remote-id type="cpan">Lab-Measurement</remote-id>
+ <remote-id type="cpan-module">Lab::Bus</remote-id>
+ <remote-id type="cpan-module">Lab::Bus::DEBUG</remote-id>
+ <remote-id type="cpan-module">Lab::Bus::IsoBus</remote-id>
+ <remote-id type="cpan-module">Lab::Bus::LinuxGPIB</remote-id>
+ <remote-id type="cpan-module">Lab::Bus::MODBUS_RS232</remote-id>
+ <remote-id type="cpan-module">Lab::Bus::RS232</remote-id>
+ <remote-id type="cpan-module">Lab::Bus::VISA</remote-id>
+ <remote-id type="cpan-module">Lab::Connection</remote-id>
+ <remote-id type="cpan-module">Lab::Connection::DEBUG</remote-id>
+ <remote-id type="cpan-module">Lab::Connection::GPIB</remote-id>
+ <remote-id type="cpan-module">Lab::Connection::IsoBus</remote-id>
+ <remote-id type="cpan-module">Lab::Connection::LinuxGPIB</remote-id>
+ <remote-id type="cpan-module">Lab::Connection::MODBUS_RS232</remote-id>
+ <remote-id type="cpan-module">Lab::Connection::VISA</remote-id>
+ <remote-id type="cpan-module">Lab::Connection::VISA_GPIB</remote-id>
+ <remote-id type="cpan-module">Lab::Data::Meta</remote-id>
+ <remote-id type="cpan-module">Lab::Data::PDL</remote-id>
+ <remote-id type="cpan-module">Lab::Data::Plotter</remote-id>
+ <remote-id type="cpan-module">Lab::Data::Writer</remote-id>
+ <remote-id type="cpan-module">Lab::Data::XMLtree</remote-id>
+ <remote-id type="cpan-module">Lab::Exception</remote-id>
+ <remote-id type="cpan-module">Lab::Exception::Base</remote-id>
+ <remote-id type="cpan-module">Lab::Instrument</remote-id>
+ <remote-id type="cpan-module">Lab::Instrument::DummySource</remote-id>
+ <remote-id type="cpan-module">Lab::Instrument::HP34401A</remote-id>
+ <remote-id type="cpan-module">Lab::Instrument::HP3458A</remote-id>
+ <remote-id type="cpan-module">Lab::Instrument::HP83732A</remote-id>
+ <remote-id type="cpan-module">Lab::Instrument::ILM</remote-id>
+ <remote-id type="cpan-module">Lab::Instrument::IPS12010</remote-id>
+ <remote-id type="cpan-module">Lab::Instrument::ITC503</remote-id>
+ <remote-id type="cpan-module">Lab::Instrument::MagnetSupply</remote-id>
+ <remote-id type="cpan-module">Lab::Instrument::Multimeter</remote-id>
+ <remote-id type="cpan-module">Lab::Instrument::SR830</remote-id>
+ <remote-id type="cpan-module">Lab::Instrument::Source</remote-id>
+ <remote-id type="cpan-module">Lab::Instrument::TRMC2</remote-id>
+ <remote-id type="cpan-module">Lab::Instrument::TemperatureControl::TLK43</remote-id>
+ <remote-id type="cpan-module">Lab::Instrument::Yokogawa7651</remote-id>
+ <remote-id type="cpan-module">Lab::Instrument::YokogawaGS200</remote-id>
+ <remote-id type="cpan-module">Lab::Measurement</remote-id>
+ <remote-id type="cpan-module">Lab::Measurement::Ladediagramm</remote-id>
+ </upstream>
+</pkgmetadata>