aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/zodiac/Manifest5
-rw-r--r--sci-chemistry/zodiac/files/build.patch41
-rw-r--r--sci-chemistry/zodiac/files/gcc-4.3.patch12
-rw-r--r--sci-chemistry/zodiac/files/openbabel-2.2.patch15
-rw-r--r--sci-chemistry/zodiac/zodiac-0.5.ebuild39
5 files changed, 112 insertions, 0 deletions
diff --git a/sci-chemistry/zodiac/Manifest b/sci-chemistry/zodiac/Manifest
new file mode 100644
index 0000000..ccf35a7
--- /dev/null
+++ b/sci-chemistry/zodiac/Manifest
@@ -0,0 +1,5 @@
+AUX build.patch 1144 RMD160 904e5385bf186a1084cf34bfdc2dca41723164fb SHA1 70b1534f2485620f50567750539c01604194b81d SHA256 cb8daff95b9358932fa53184ad6246fb9e1766f3656b63dd913f80b91ce51b2b
+AUX gcc-4.3.patch 420 RMD160 eadcde30a7be61b5cdb95a4662a3067d431027b9 SHA1 b70978dcbdae77e922abe01797a47a9069cb2329 SHA256 d15e1500e1cb8c21b6fe9e013c15638f099ee28986e2d3641bbf70d70d545dd1
+AUX openbabel-2.2.patch 551 RMD160 881dd64e05060c97481443a77f5ca42fcb9c9078 SHA1 00b4576ce1f690ef9c5e8c2392da598b535fe876 SHA256 28bfc6ec7d1ed9d501dd3ab4b9b6d265fb62ab024218ca9ea9bfdcf493d19afb
+DIST zodiac_0_5_src.tar.gz 1110773 RMD160 6abbf98376193ba4e9035edd85809a1dbb0c50f3 SHA1 470ed8c079b9f834c6c95713afe4f186c70a93aa SHA256 116ff26481027f3e0a9863da147b35b5289006e317272a7940f5d80843cde061
+EBUILD zodiac-0.5.ebuild 888 RMD160 f0dc962829c83059cb03e49fb140bc9fadf903dd SHA1 faecf08dfca2711b856c43efc3b66732ee7823d4 SHA256 f2a3442a919beee97123cb141cc0418d06907a1d709535fd2f88fbee36b822a8
diff --git a/sci-chemistry/zodiac/files/build.patch b/sci-chemistry/zodiac/files/build.patch
new file mode 100644
index 0000000..6848001
--- /dev/null
+++ b/sci-chemistry/zodiac/files/build.patch
@@ -0,0 +1,41 @@
+diff -x Makefile -x 'moc_*' -x 'qrc_*' -x ui_zodiac.h -ur zodiac-0.5.orig/Zodiac.pro zodiac-0.5/Zodiac.pro
+--- zodiac-0.5.orig/Zodiac.pro 2008-04-30 07:03:22.000000000 -0700
++++ zodiac-0.5/Zodiac.pro 2008-07-13 21:20:38.000000000 -0700
+@@ -9,12 +9,14 @@
+ RC_FILE = zeden.icns
+
+ # Input
+-HEADERS += arcball.h \
++HEADERS += actions.h \
++ arcball.h \
+ builder.h \
+ chemscore.h \
+ command.h \
+ constants.h \
+ cutoffGrid.h \
++ database.h \
+ ddwin.h \
+ FF.h \
+ graphical_object.h \
+@@ -36,11 +38,13 @@
+ ZNdata.h \
+ zodiac.h
+ FORMS += zodiac.ui
+-SOURCES += arcball.cc \
++SOURCES += actions.cc \
++ arcball.cc \
+ builder.cc \
+ chemscore.cc \
+ command.cc \
+ constants.cc \
++ database.cc \
+ ddwin.cc \
+ FF.cc \
+ graphical_object.cc \
+@@ -63,3 +67,6 @@
+ ZNdata.cc \
+ Zodiac.cc
+ RESOURCES += resources.qrc zodiac.qrc
++CONFIG += qt opengl link_pkgconfig
++QT += qt3support opengl
++PKGCONFIG += openbabel-2.0
diff --git a/sci-chemistry/zodiac/files/gcc-4.3.patch b/sci-chemistry/zodiac/files/gcc-4.3.patch
new file mode 100644
index 0000000..329a815
--- /dev/null
+++ b/sci-chemistry/zodiac/files/gcc-4.3.patch
@@ -0,0 +1,12 @@
+diff -x Makefile -x 'moc_*' -x 'qrc_*' -x ui_zodiac.h -ur zodiac-0.5.orig/plantsconfig.h zodiac-0.5/plantsconfig.h
+--- zodiac-0.5.orig/plantsconfig.h 2008-04-30 07:03:22.000000000 -0700
++++ zodiac-0.5/plantsconfig.h 2008-07-13 19:17:37.000000000 -0700
+@@ -54,7 +54,7 @@
+ PlantsMainWin* targetmw;
+ string boolstr (bool boo);
+
+- vector<string> vector;
++ std::vector<string> vector;
+
+
+ // void Read ();
diff --git a/sci-chemistry/zodiac/files/openbabel-2.2.patch b/sci-chemistry/zodiac/files/openbabel-2.2.patch
new file mode 100644
index 0000000..0b6958e
--- /dev/null
+++ b/sci-chemistry/zodiac/files/openbabel-2.2.patch
@@ -0,0 +1,15 @@
+diff -x Makefile -x 'moc_*' -x 'qrc_*' -x ui_zodiac.h -ur zodiac-0.5.orig/actions.cc zodiac-0.5/actions.cc
+--- zodiac-0.5.orig/actions.cc 2008-04-30 07:03:22.000000000 -0700
++++ zodiac-0.5/actions.cc 2008-07-13 21:19:31.000000000 -0700
+@@ -39,8 +39,9 @@
+
+
+ double Actions::compute_logP (Molecule *mol) {
+- OBLogP logp;
+- return logp.Predict (*mol);
++ OBDescriptor* pDesc = OBDescriptor::FindType("logP");
++ if(pDesc)
++ return pDesc->Predict (mol);
+ }
+
+ vector <double> Actions::compute_logP (Database *dat) {
diff --git a/sci-chemistry/zodiac/zodiac-0.5.ebuild b/sci-chemistry/zodiac/zodiac-0.5.ebuild
new file mode 100644
index 0000000..665b3ad
--- /dev/null
+++ b/sci-chemistry/zodiac/zodiac-0.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit versionator qt4
+
+MY_P="${PN}_${PV}"
+MY_P="$(replace_all_version_separators _ ${MY_P})"
+DESCRIPTION="Software for molecular modelling - computer-aided drug design"
+HOMEPAGE="http://www.zeden.org/"
+SRC_URI="mirror://sourceforge/zodiac-zeden/${MY_P}_src.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RDEPEND="sci-chemistry/openbabel"
+DEPEND="${RDEPEND}"
+
+QT4_BUILT_WITH_USE_CHECK="opengl qt3support"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/build.patch
+ epatch "${FILESDIR}"/gcc-4.3.patch
+ epatch "${FILESDIR}"/openbabel-2.2.patch
+}
+
+src_compile() {
+ eqmake4 \
+ Zodiac.pro \
+ INCLUDEPATH=/usr/include/openbabel-2.0 \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}