aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/aggdraw/aggdraw-1.2_alpha3.ebuild')
-rw-r--r--dev-python/aggdraw/aggdraw-1.2_alpha3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/aggdraw/aggdraw-1.2_alpha3.ebuild b/dev-python/aggdraw/aggdraw-1.2_alpha3.ebuild
new file mode 100644
index 0000000..80e4a03
--- /dev/null
+++ b/dev-python/aggdraw/aggdraw-1.2_alpha3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+ESVN_REPO_URI="http://svn.effbot.org/public/tags/aggdraw-1.2a3-20060212"
+
+inherit eutils distutils subversion
+
+DESCRIPTION="Python library for high-quality drawing, with anti-aliasing and alpha compositing"
+HOMEPAGE="effbot.org/zone/aggdraw-index.htm"
+#SRC_URI=""
+LICENSE="ElementTree"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+RDEPEND="x11-libs/agg
+ media-libs/freetype:2"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # clean out bundled x11-libs/agg copy to make sure we don't use it
+ rm -rf agg2/ || die
+ epatch "${FILESDIR}"/build-against-external-agg-2.5-and-freetype.patch
+}