aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-03-24 12:05:46 -0700
committerDonnie Berkholz <dberkholz@gentoo.org>2008-03-24 12:05:46 -0700
commit8f9af14e0172ebb088b7f9d8eb8322d015df1486 (patch)
treeb68f31775fd4b3bf406bee0bd40859e5c3d92649 /sys-cluster
parentiw: New wireless config utility, live-git ebuild. (diff)
downloaddberkholz-8f9af14e0172ebb088b7f9d8eb8322d015df1486.tar.gz
dberkholz-8f9af14e0172ebb088b7f9d8eb8322d015df1486.tar.bz2
dberkholz-8f9af14e0172ebb088b7f9d8eb8322d015df1486.zip
pbs-python: new package; bindings to the PBS API.
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/pbs-python/Manifest2
-rw-r--r--sys-cluster/pbs-python/pbs-python-2.9.4.ebuild22
2 files changed, 24 insertions, 0 deletions
diff --git a/sys-cluster/pbs-python/Manifest b/sys-cluster/pbs-python/Manifest
new file mode 100644
index 0000000..07868e2
--- /dev/null
+++ b/sys-cluster/pbs-python/Manifest
@@ -0,0 +1,2 @@
+DIST pbs_python-2.9.4.tar.gz 90134 RMD160 58a8fb56b90ca7f30b46837bc3eda8e327e471ae SHA1 fd79803a9a900f73c85cb22877d50cc496db4aaa SHA256 a0d58c0186ff49f907ad72b9dfcfbbbd3f10d56883cfadc2221ff2ea93e3c4fb
+EBUILD pbs-python-2.9.4.ebuild 493 RMD160 db56a56a783dcfc5e79be682cd74f5e380a2ee86 SHA1 f9537db5376a0e23f9d9a9486bd9bf05e6177eec SHA256 a81da89170779f3a444d57e0e6b8c8efa1b9588741b4644641a289d84d284f7f
diff --git a/sys-cluster/pbs-python/pbs-python-2.9.4.ebuild b/sys-cluster/pbs-python/pbs-python-2.9.4.ebuild
new file mode 100644
index 0000000..181e877
--- /dev/null
+++ b/sys-cluster/pbs-python/pbs-python-2.9.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Python bindings to the PBS C API"
+HOMEPAGE="https://subtrac.sara.nl/oss/pbs_python/"
+SRC_URI="ftp://ftp.sara.nl/pub/outgoing/${MY_P}.tar.gz"
+LICENSE="openpbs as-is"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+RDEPEND="virtual/pbs"
+DEPEND="${RDEPEND}"
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ econf || die
+ distutils_src_compile
+}