aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2011-02-18 18:07:52 -0600
committerDonnie Berkholz <dberkholz@gentoo.org>2011-02-18 18:07:52 -0600
commit0031f7b4e4da7d0a517ace4b0d4830f4cdd3b90d (patch)
tree3608180d6ed439dd994a87b476200cb5aea4f62c /sci-mathematics
parentv4l2ucp: Add qt4 version -- only available in git so it's a live ebuild. (diff)
downloaddberkholz-0031f7b4e4da7d0a517ace4b0d4830f4cdd3b90d.tar.gz
dberkholz-0031f7b4e4da7d0a517ace4b0d4830f4cdd3b90d.tar.bz2
dberkholz-0031f7b4e4da7d0a517ace4b0d4830f4cdd3b90d.zip
elefant: Add a new machine-learning package.
Description: Efficient learning large-scale inference optimization toolkit (machine learning).
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/elefant/Manifest2
-rw-r--r--sci-mathematics/elefant/elefant-0.4.0.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/sci-mathematics/elefant/Manifest b/sci-mathematics/elefant/Manifest
new file mode 100644
index 0000000..e92ef6f
--- /dev/null
+++ b/sci-mathematics/elefant/Manifest
@@ -0,0 +1,2 @@
+DIST elefant-0.4.0.tar.bz2 6184546 RMD160 e48f80d946096f78c99617b7d6c2d37ef462db09 SHA1 90dd2b4f685173edb8a122f7067f5158cfb251eb SHA256 2c5bd323579aa1e4008ad13b5b9168c9d37ed183e0222197218096d8c21a4cad
+EBUILD elefant-0.4.0.ebuild 739 RMD160 53536e3fdc28c90b56c57b3e380fd76b50688b30 SHA1 f4b35e19e7c7c787172c87e955c7ddd38abd5a28 SHA256 b67b833d24be74e9a4e6fff3b43dd2a41621780401ba2eaf19131d861940caf4
diff --git a/sci-mathematics/elefant/elefant-0.4.0.ebuild b/sci-mathematics/elefant/elefant-0.4.0.ebuild
new file mode 100644
index 0000000..1978bff
--- /dev/null
+++ b/sci-mathematics/elefant/elefant-0.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit distutils
+
+DESCRIPTION="Efficient learning large-scale inference optimization toolkit (machine learning)"
+HOMEPAGE="http://elefant.developer.nicta.com.au/"
+SRC_URI="${HOMEPAGE%/}/download/release/${PV:0:3}/${P}.bz2 -> ${P}.tar.bz2"
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+RDEPEND="
+ >=dev-python/numpy-1.3
+ >=sci-libs/scipy-0.7.1
+ >=dev-python/matplotlib-0.99
+ >=dev-python/wxpython-2.8
+ >=dev-lang/swig-1.3
+ "
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # Be compatible with 2.7 too
+ if [[ $(python_get_version) == 2.7 ]]; then
+ sed \
+ -e 's:2, 6:2, 7:' \
+ -i "${S}"/setup.py || die
+ fi
+}