aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2010-06-03 10:29:36 -0500
committerDonnie Berkholz <dberkholz@gentoo.org>2010-06-03 10:29:36 -0500
commitbb72f0434eb00887b0bd7b1df623a25ee9222d83 (patch)
treeba023f5aef03b68ac7b5e6540920935e8926d4f3 /sci-chemistry
parentautodock-vina: New ebuild for a docking program. (diff)
downloaddberkholz-bb72f0434eb00887b0bd7b1df623a25ee9222d83.tar.gz
dberkholz-bb72f0434eb00887b0bd7b1df623a25ee9222d83.tar.bz2
dberkholz-bb72f0434eb00887b0bd7b1df623a25ee9222d83.zip
pyrx: bump to 0.6, now compatible with Autodock Vina.
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/pyrx/Manifest6
-rw-r--r--sci-chemistry/pyrx/files/use-external-opal.patch6
-rw-r--r--sci-chemistry/pyrx/pyrx-0.6.ebuild (renamed from sci-chemistry/pyrx/pyrx-0.3.ebuild)18
3 files changed, 20 insertions, 10 deletions
diff --git a/sci-chemistry/pyrx/Manifest b/sci-chemistry/pyrx/Manifest
index f44f954..448e38f 100644
--- a/sci-chemistry/pyrx/Manifest
+++ b/sci-chemistry/pyrx/Manifest
@@ -1,3 +1,3 @@
-AUX use-external-opal.patch 617 RMD160 58b274b148560d22f213ef0c6498a07082828fe6 SHA1 4ebd273b8ebacea6f7069e12f6e5c85f8bee3039 SHA256 585772e15ef59c680700c1bf2eb5df3f8889fa4522e97c8d668996fde7314576
-DIST PyRx-0.3-Source.tar.gz 257505 RMD160 42191f1c70b5dc87267c3dc71563b684d0439924 SHA1 d47612ac379b87c33c9654e879de58a43de4bd26 SHA256 c6dce9174ad7141cc069ed4ca69d39048d6345808b249c1aa8974412205a4707
-EBUILD pyrx-0.3.ebuild 1001 RMD160 e2bc843237e0deec851a7f3a6d7f53d9db1db084 SHA1 71bc2e301949e65af6fe79733b90aad2a9dc7d2a SHA256 940c7824d52cdaa0fcd26540d78f648b685c5ca2c132d977bf9be3fe8370612d
+AUX use-external-opal.patch 584 RMD160 ca0512bfb8cd7afa0770ce8d90d28e6f91b3abef SHA1 2e7e8e04c8f362a8d3726cb3c2c2051788686f06 SHA256 f5faed8ecd2bc8bd06d008343d00d8a3c4cedf8dc857b2bde8fc847a6b161029
+DIST PyRx-0.6-Source.zip 1261435 RMD160 30fcd5004347b485d30582e82c02ed0a9649a168 SHA1 fca33cb505e2e39d8db61a9eda37fb403012e350 SHA256 d3f61db8b29dcd4bfbeb6f30f6200e29a81ee2a2bd3f26faf8ab23c25d3e928d
+EBUILD pyrx-0.6.ebuild 1071 RMD160 75c938e6557e442351a3269bbd119a4e36f04682 SHA1 040e36f8d3c54ea8bc1d12be7d67496199500cb3 SHA256 ea6541a3177226296e1f224a446c767bc3548cf33279c467ea43c974d1e4b1ed
diff --git a/sci-chemistry/pyrx/files/use-external-opal.patch b/sci-chemistry/pyrx/files/use-external-opal.patch
index 1cf3d67..18fe056 100644
--- a/sci-chemistry/pyrx/files/use-external-opal.patch
+++ b/sci-chemistry/pyrx/files/use-external-opal.patch
@@ -1,8 +1,8 @@
---- PyRx/webServices.py.orig 2009-09-14 21:34:14.000000000 -0500
-+++ PyRx/webServices.py 2009-09-14 21:34:23.000000000 -0500
+--- PyRx/webServices.py.orig 2010-06-03 10:19:16.348528867 -0500
++++ PyRx/webServices.py 2010-06-03 10:19:22.516126260 -0500
@@ -1,8 +1,8 @@
#Author: Sargis Dallakyan (sargis@scripps.edu)
- #$Header: /opt/cvs/PyRxDIST/PyRx/webServices.py,v 1.16 2009/07/30 18:09:30 sargis Exp $
+ #$Id: webServices.py 47 2010-05-10 19:34:36Z sarkiss $
-from AppService.AppService_client import AppServiceLocator,\
+from AppService_client import AppServiceLocator,\
launchJobRequest, getOutputsRequest, queryStatusRequest, destroyRequest
diff --git a/sci-chemistry/pyrx/pyrx-0.3.ebuild b/sci-chemistry/pyrx/pyrx-0.6.ebuild
index 8e42c11..ac01077 100644
--- a/sci-chemistry/pyrx/pyrx-0.3.ebuild
+++ b/sci-chemistry/pyrx/pyrx-0.6.ebuild
@@ -10,7 +10,7 @@ MY_PN="PyRx"
MY_P=${MY_PN}-${PV}
DESCRIPTION="GUI for Virtual Screening with AutoDock"
HOMEPAGE="http://pyrx.sf.net"
-SRC_URI="http://pyrx.scripps.edu/download/${PV}/${MY_P}-Source.tar.gz"
+SRC_URI="http://pyrx.scripps.edu/download/${PV}/${MY_P}-Source.zip"
LICENSE="free-noncomm"
SLOT="0"
KEYWORDS="~amd64"
@@ -23,7 +23,8 @@ RDEPEND=">=sci-chemistry/mgltools-autodocktools-1.5.4
sci-visualization/mayavi
dev-python/opal-client
>=sci-chemistry/openbabel-2.2.1
- >=sci-chemistry/autodock-4"
+ >=sci-chemistry/autodock-4
+ >=sci-chemistry/autodock-vina-1.1.1"
DEPEND="${RDEPEND}"
S=${WORKDIR}
@@ -33,6 +34,15 @@ src_prepare() {
src_install() {
distutils_src_install
- cp -r PyRx/Images/silk_icons ${D}usr/$(get_libdir)/python${PYVER}/site-packages/${MY_PN}/Images/ || die
- cp PyRx/preferences.ini ${D}usr/$(get_libdir)/python${PYVER}/site-packages/${MY_PN}/ || die
+
+ PYVER=$(python_get_version)
+ PYRX="${D}usr/$(get_libdir)/python${PYVER}/site-packages/${MY_PN}"
+ cp -r PyRx/Images/silk_icons \
+ ${PYRX}/Images/ \
+ || die
+ cp PyRx/preferences.ini \
+ ${PYRX}/ \
+ || die
+
+ dodoc README.txt || die
}