aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2010-06-14 15:06:24 -0500
committerDonnie Berkholz <dberkholz@gentoo.org>2010-06-14 15:06:24 -0500
commitb465533c7cc7e76c6cfbd9d951ba3bf15838fb48 (patch)
tree8da00fb536075da71a7ba7e158955474130011f3 /sci-chemistry
parentInitial aggdraw ebuild; high-quality, antialiased, subpixel Python drawing. (diff)
downloaddberkholz-b465533c7cc7e76c6cfbd9d951ba3bf15838fb48.tar.gz
dberkholz-b465533c7cc7e76c6cfbd9d951ba3bf15838fb48.tar.bz2
dberkholz-b465533c7cc7e76c6cfbd9d951ba3bf15838fb48.zip
open3dqsar: New package for pharmacophore detection.
QSAR is quantitative structure-activity relationships, which are used in structure-based drug design to explain which atomic interactions are important.
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/open3dqsar/Manifest3
-rw-r--r--sci-chemistry/open3dqsar/open3dqsar-1.2.ebuild39
-rw-r--r--sci-chemistry/open3dqsar/open3dqsar-1.2.ebuild~25
3 files changed, 67 insertions, 0 deletions
diff --git a/sci-chemistry/open3dqsar/Manifest b/sci-chemistry/open3dqsar/Manifest
new file mode 100644
index 0000000..081501b
--- /dev/null
+++ b/sci-chemistry/open3dqsar/Manifest
@@ -0,0 +1,3 @@
+DIST open3dqsar-1.2.tar.gz 6423763 RMD160 5235b871873b45a01c9fe53c31bad99d163e4d08 SHA1 808c2130c82f0651771649f0407ee8758e80b948 SHA256 71a57e87a7e636d38033fc1e586341ea4f0bb63a65b7a5ad3c2a7ae530aa0e08
+EBUILD open3dqsar-1.2.ebuild 827 RMD160 f669a8810b55f0470b3e03509df46adfde6843f5 SHA1 e1f63996db4b62246ef56cc113d7c369a3334f9b SHA256 c6d2dbed063dedad414bceb9380bcd3bfe742d449e4881c6ef77acaad93c5323
+MISC open3dqsar-1.2.ebuild~ 470 RMD160 6cbbdd58c29cc83a54832122b68d33c9cc5c4abe SHA1 f3cb30507d088ade8b98b54afb03f742cfac6087 SHA256 942bf9073b84c873d59686251bcef69ddf2066df98350243415657429de4f2bf
diff --git a/sci-chemistry/open3dqsar/open3dqsar-1.2.ebuild b/sci-chemistry/open3dqsar/open3dqsar-1.2.ebuild
new file mode 100644
index 0000000..4c77d32
--- /dev/null
+++ b/sci-chemistry/open3dqsar/open3dqsar-1.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit autotools
+
+DESCRIPTION="Pharmacophore exploration by high-throughput chemometric analysis of molecular interaction fields (MIFs)"
+HOMEPAGE="http://www.open3dqsar.org/"
+SRC_URI="${P}.tar.gz"
+LICENSE="${PN}"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+RESTRICT="fetch"
+RDEPEND="virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}"
+
+pkg_nofetch() {
+ elog "Register at ${HOMEPAGE}, then download ${SRC_URI} and place it in ${DISTDIR}."
+}
+
+src_prepare () {
+ eautoreconf || die
+}
+
+src_configure() {
+ # --with-atlas just makes it look for a generic blas/cblas/lapack interface
+ econf \
+ --with-atlas \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README || die
+}
diff --git a/sci-chemistry/open3dqsar/open3dqsar-1.2.ebuild~ b/sci-chemistry/open3dqsar/open3dqsar-1.2.ebuild~
new file mode 100644
index 0000000..b88ce8f
--- /dev/null
+++ b/sci-chemistry/open3dqsar/open3dqsar-1.2.ebuild~
@@ -0,0 +1,25 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION=""
+HOMEPAGE=""
+SRC_URI="${P}.tar.gz"
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+RESTRICT="fetch"
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+pkg_nofetch() {
+ elog "Register at ${HOMEPAGE}, then download ${SRC_URI} and place it in ${DISTDIR}."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README || die
+}