aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-08-29 10:34:24 -0700
committerDonnie Berkholz <dberkholz@gentoo.org>2008-08-29 10:34:24 -0700
commitaaa1bc43ca6506ce255a7cd843d43378f96e914a (patch)
tree4cc803bae7921f649013e5430f2cd705e66cfd77 /sci-chemistry
parentccp4: split out ccp4i into separate package. (diff)
downloaddberkholz-aaa1bc43ca6506ce255a7cd843d43378f96e914a.tar.gz
dberkholz-aaa1bc43ca6506ce255a7cd843d43378f96e914a.tar.bz2
dberkholz-aaa1bc43ca6506ce255a7cd843d43378f96e914a.zip
mole-bin: Replacement for Caver, including Pymol plugin.
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/mole-bin/Manifest2
-rw-r--r--sci-chemistry/mole-bin/mole-bin-1.2.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/sci-chemistry/mole-bin/Manifest b/sci-chemistry/mole-bin/Manifest
new file mode 100644
index 0000000..a9af3c3
--- /dev/null
+++ b/sci-chemistry/mole-bin/Manifest
@@ -0,0 +1,2 @@
+DIST mole-install.tar.gz 1610527 RMD160 fa6adb8cd23635f651b05046dc8ee1e9eefaa87c SHA1 003564745f895a28a32a9b40f990fb214eb7429f SHA256 22820c1c1fe9000fc9d756068b037d93928d30d67900291cd8346ab3fda3aa27
+EBUILD mole-bin-1.2.ebuild 1112 RMD160 aed95b2f453040d510778a35ab3243cd4aae5956 SHA1 f5b85fd3d09d751bf68ed38c089e9fa0597c613f SHA256 428b91b21cfeb07c3db23434da189dade0a1796bf8985e717f38289f12dfe263
diff --git a/sci-chemistry/mole-bin/mole-bin-1.2.ebuild b/sci-chemistry/mole-bin/mole-bin-1.2.ebuild
new file mode 100644
index 0000000..5ea70dd
--- /dev/null
+++ b/sci-chemistry/mole-bin/mole-bin-1.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils multilib python distutils
+
+MY_P="mole-install"
+PYTHON_MODNAME="pmg_tk/startup"
+
+DESCRIPTION="A toolkit for automated location channels, tunnels and pores in molecular structures"
+HOMEPAGE="http://mole.chemi.muni.cz/"
+SRC_URI="http://mole.chemi.muni.cz/binary/linux/mole_v${PV}/${MY_P}.tar.gz"
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pymol"
+RDEPEND="pymol? ( sci-chemistry/pymol )
+ media-libs/qhull"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ if use pymol; then
+ python_version
+ insinto /usr/$(get_libdir)/python${PYVER}/site-packages/pmg_tk/startup
+ doins mole.py || die
+ fi
+
+ exeinto /opt/mole/bin
+ doexe bin/Mole.exe || die
+ dosym ../mole/bin/Mole.exe /opt/bin/mole || die
+
+ edos2unix dat/* || die
+ insinto /opt/mole/share
+ doins -r dat examples || die
+ dohtml README.html || die
+ dodoc README.txt || die
+
+ cat >> "${T}"/${PN} <<- EOF
+ TEMP="\${TMP}"
+ MOLEDIR="/opt/mole/share"
+ EOF
+ newenvd "${T}"/${PN} 20${PN} || die
+}