aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-07-09 00:19:36 -0700
committerDonnie Berkholz <dberkholz@gentoo.org>2008-07-09 00:19:36 -0700
commite27582bf3c2169c9222547d92f6b02d1ba7fb127 (patch)
treed7fbafbd2f2ed4c1560aca6b05cf05acf27298c2 /app-admin
parentdistcc: don't allow -Werror, block net-misc/pump. (diff)
downloaddberkholz-e27582bf3c2169c9222547d92f6b02d1ba7fb127.tar.gz
dberkholz-e27582bf3c2169c9222547d92f6b02d1ba7fb127.tar.bz2
dberkholz-e27582bf3c2169c9222547d92f6b02d1ba7fb127.zip
collectd: bump to 4.4.1 from 4.0.4 in sunrise overlay.
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/collectd/ChangeLog16
-rw-r--r--app-admin/collectd/Manifest7
-rw-r--r--app-admin/collectd/collectd-4.4.1.ebuild87
-rw-r--r--app-admin/collectd/files/collectd-4.0.4.conf38
-rw-r--r--app-admin/collectd/files/collectd-4.0.4.confd16
-rw-r--r--app-admin/collectd/files/collectd-4.0.4.initd29
-rw-r--r--app-admin/collectd/metadata.xml5
7 files changed, 198 insertions, 0 deletions
diff --git a/app-admin/collectd/ChangeLog b/app-admin/collectd/ChangeLog
new file mode 100644
index 0000000..e7d43fd
--- /dev/null
+++ b/app-admin/collectd/ChangeLog
@@ -0,0 +1,16 @@
+# ChangeLog for app-admin/collectd
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 29 Jun 2007; Christian Faulhammer <opfer@gentoo.org>
+ collectd-4.0.4.ebuild:
+ added trailing slash to HOMEPAGE URI; added a looot of quotes and this
+ myconf construct is just not necessary; exchange make with emake and use
+ canonical die comments. Please make sure your ebuilds stick at least a bit
+ to the normal QA standards
+
+ 28 Jun 2007; Wolfgang Frisch (xororand) <xororand@frexx.de>
+ +collectd-4.0.4.ebuild, +files/collectd-4.0.4.confd,
+ +files/collectd-4.0.4.initd, +metadata.xml:
+ New ebuild for bug 107076
+
diff --git a/app-admin/collectd/Manifest b/app-admin/collectd/Manifest
new file mode 100644
index 0000000..5f35d99
--- /dev/null
+++ b/app-admin/collectd/Manifest
@@ -0,0 +1,7 @@
+AUX collectd-4.0.4.conf 658 RMD160 e8bd064475cd88a62f2177f5765cfe0c219ef77a SHA1 e82cc8e0cc4c40303bf2d3fb5176933b45db28d5 SHA256 f6608f3be6a30cc4b7de68d4be4669359ac3fd8a9511a06224b7b5fd9cf4cee5
+AUX collectd-4.0.4.confd 529 RMD160 52920082294789ed9b46d2db37ae85a697587070 SHA1 5993dc1aa3a1a51464ffe84b2f3133c343253739 SHA256 93841388cdc88bc9cc8916a33892191e7cb1ce5557f76051d5b65ef0ea4cc558
+AUX collectd-4.0.4.initd 655 RMD160 e6386b437fb6175cf35e3207a16a938341e70513 SHA1 5c9684f94b95ef1a835cdc0402003ec9966d2e96 SHA256 642c8463dfa0c49b71b9e145b2913ae59371b43f4dd6671c1701fa03b0b3140c
+DIST collectd-4.4.1.tar.bz2 921902 RMD160 d12c40e27c7fe6838cd6a490c44661af67abed08 SHA1 d927bbf045179359ad4bd29ed0ad77fd6105e2d4 SHA256 2e0373bb4e9e78f52739975575f1ad4874311853551b59c8562b5848a38eb85a
+EBUILD collectd-4.4.1.ebuild 2173 RMD160 40cae058aa84918cc4fb9fcb8078645532092b0f SHA1 0aa53d4215b69fb8cc78d0acc37f3771fa8ef5c2 SHA256 4fd95be65ce5c2202a2eeb678b7208f747f4c884c94e794a9a7be23f22adaa51
+MISC ChangeLog 646 RMD160 f2a6d3ee98bc3e562186f5699906df9511e9813b SHA1 77ac96373878216ead62631880f1e0a49fad1184 SHA256 fa73a2287a5951024529896cf729e4aeb46589eba1bfd37e5e79457120ff647a
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/app-admin/collectd/collectd-4.4.1.ebuild b/app-admin/collectd/collectd-4.4.1.ebuild
new file mode 100644
index 0000000..7f3fe79
--- /dev/null
+++ b/app-admin/collectd/collectd-4.4.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="A small daemon to collect system statistics into RRD files."
+HOMEPAGE="http://collectd.org/"
+SRC_URI="http://collectd.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="apcupsd dns hddtemp ipmi iptables libvirt lm_sensors mysql
+ netlink nut perl rrdtool snmp"
+
+DEPEND="
+ net-misc/curl
+ sys-libs/libstatgrab
+ apcupsd? ( sys-power/apcupsd )
+ dns? ( net-libs/libpcap )
+ hddtemp? ( app-admin/hddtemp )
+ ipmi? ( sys-libs/openipmi )
+ iptables? ( net-firewall/iptables )
+ libvirt? ( app-emulation/libvirt )
+ lm_sensors? ( >=sys-apps/lm_sensors-2.9.0 )
+ mysql? ( >=dev-db/mysql-4.1 )
+ netlink? ( sys-apps/iproute2 )
+ nut? ( sys-power/nut )
+ liboping? ( net-libs/liboping )
+ pcap? ( net-libs/libpcap )
+ rrdtool? ( >=net-analyzer/rrdtool-1.2 )
+ snmp? ( net-analyzer/net-snmp )
+ "
+
+src_compile() {
+ local myconf
+ if ! built_with_use --missing true dev-lang/perl ithreads; then
+ myconf="--disable-perl"
+ else
+ myconf="$(use_enable perl)"
+ fi
+
+ econf \
+ --with-libstatgrab \
+ $(use_enable apcups) \
+ $(use_enable dns) \
+ $(use_enable hddtemp) \
+ $(use_enable ipmi) \
+ $(use_enable iptables) \
+ $(use_with iptables libiptc) \
+ $(use_enable libvirt) \
+ $(use_enable lm_sensors sensors) \
+ $(use_enable mysql) \
+ $(use_enable netlink) \
+ $(use_enable nut) \
+ $(use_enable rrdtool) \
+ $(use_enable snmp) \
+ ${myconf} \
+ KERNEL_DIR=/usr/src/linux \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog README NEWS TODO
+
+ docinto contrib
+ dodoc contrib/*
+
+ keepdir /var/lib/collectd
+
+ newinitd "${FILESDIR}/${PN}-4.0.4.initd" collectd || die
+ newconfd "${FILESDIR}/${PN}-4.0.4.confd" collectd || die
+
+ insinto /etc
+ newins "${FILESDIR}/${PN}-4.0.4.conf" collectd.conf || die
+}
+
+pkg_postinst() {
+ einfo "collectd introduced some changes in the new 4.x series."
+ einfo "For further information, read http://collectd.org/migrate-v3-v4.shtml"
+ einfo "The migration script can be found at:"
+ einfo "/usr/share/doc/${P}/contrib/migrate-3-4.px.bz2"
+}
diff --git a/app-admin/collectd/files/collectd-4.0.4.conf b/app-admin/collectd/files/collectd-4.0.4.conf
new file mode 100644
index 0000000..51c897a
--- /dev/null
+++ b/app-admin/collectd/files/collectd-4.0.4.conf
@@ -0,0 +1,38 @@
+#
+# Config file for collectd(1).
+# Please read collectd.conf(5) for a list of options.
+# http://verplant.org/collectd/
+#
+
+Mode Local
+DataDir /var/lib/collectd
+PIDFile /var/run/collectd.pid
+PluginDir /usr/lib/collectd
+
+LoadPlugin cpu
+LoadPlugin cpufreq
+LoadPlugin df
+LoadPlugin disk
+LoadPlugin load
+LoadPlugin memory
+#LoadPlugin nfs
+#LoadPlugin ping
+LoadPlugin processes
+#LoadPlugin serial
+LoadPlugin swap
+LoadPlugin traffic
+LoadPlugin users
+#LoadPlugin hddtemp
+#LoadPlugin mysql
+#LoadPlugin sensors
+
+#<Plugin ping>
+# Host host.foo.bar
+#</Plugin>
+
+#<Plugin mysql>
+# Host database.serv.er
+# User db_user
+# Password secret
+## Database db_name
+#</Plugin>
diff --git a/app-admin/collectd/files/collectd-4.0.4.confd b/app-admin/collectd/files/collectd-4.0.4.confd
new file mode 100644
index 0000000..bfc40db
--- /dev/null
+++ b/app-admin/collectd/files/collectd-4.0.4.confd
@@ -0,0 +1,16 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# Nice value used to launch collectd, to change priority of the process. As
+# you usually will want to run it in background, a default of 5 is used.
+#
+
+#COLLECTD_NICELVL='5'
+# Location of configuration file. Modify if you don't like the standard one.
+#
+#COLLECTD_CFGFILE='/etc/collectd.conf'
+
+# File used to store the PID file. Usually you won't need to touch it.
+#
+#COLLECTD_PIDFILE='/var/run/collectd.pid'
diff --git a/app-admin/collectd/files/collectd-4.0.4.initd b/app-admin/collectd/files/collectd-4.0.4.initd
new file mode 100644
index 0000000..913269d
--- /dev/null
+++ b/app-admin/collectd/files/collectd-4.0.4.initd
@@ -0,0 +1,29 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+: ${COLLECTD_PIDFILE:='/var/run/collectd.pid'}
+: ${COLLECTD_CFGFILE:='/etc/collectd.conf'}
+: ${COLLECTD_NICELVL:='5'}
+
+
+depend() {
+ :
+}
+
+start() {
+ ebegin "Starting collectd"
+ start-stop-daemon --start --quiet \
+ --nicelevel "${COLLECTD_NICELVL}" --exec /usr/sbin/collectd -- \
+ -P "${COLLECTD_PIDFILE}" -C "${COLLECTD_CFGFILE}"
+ eend $? "Failed to start collectd"
+}
+
+stop() {
+ ebegin "Stopping collectd"
+ start-stop-daemon --stop --quiet \
+ --pidfile "${COLLECTD_PIDFILE}"
+ eend $? "Failed to stop collectd"
+}
+
diff --git a/app-admin/collectd/metadata.xml b/app-admin/collectd/metadata.xml
new file mode 100644
index 0000000..7e32869
--- /dev/null
+++ b/app-admin/collectd/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>